Problem loading saved songs

I just bought a Aeros Looper, so I’m a new beginner.
I’ve can save my songs and they appear in the list but when I try to open the song it doesn’t work. When I try it a new empty song opens. Furthermore new songs are generated in the song list automaticly, song_1, song_2, etc.
Is this a hardware or software problem? Something I missed in the settings?
According to the Looper I have the latest update.

I solved it myself. It must be a bug. If I keep the the name generated be the Aeros, song_1 song_2…, it’s possible to save and load the the song but If I change the name it’s not.

Is this a wellknown problem and are Singularsound working on a solution?

Are you using 2.13.2 or the beta 2.15.6?

2.13.2. I’m getting the beta today and try it out. I hope it doesn’t mess with my saved song!?

And now it works, thanks! Will it be possible to export and import files with the USB-port in the future. Would be nice to skip the SD-card management!

1 Like

Hey there, we are still looking into implementation of that port, stay tuned!

Hi again!

First i want to say that the Aeros is a fantastic product and it’s got potential of getting amazing. I really enjoy working with it and I still learning. The new 2:17:x works perfect!

I primarily use it as a pedal-DAW, not a looper for gigs. I left my Trio+ for our Aeros some weeks ago.

What I wish to come is:

1: An easy way of importing tracks to Aeros, preferably by the USB-port.

2: Ability for labeling parts and tracks.

3: More accessable memory for each song, I hit the roof quit fast.

4: Locking songs/tracks from recording, ie playing without the danger of accidentally changing the recording.

5: The ability to arrange parts to play in a specific sequence.

1 Like

We’re glad you’re loving it!

Thank you for the feedback, it is definitely noted, stay tuned!