Problem with Beat Buddy recognizing MIDI commands from OnSong for folders above 128

I’m using OnSong to control my Beat Buddy by sending it MIDI commands. Everything works fine for the first 128 folders (MSB=0, LSB=0-127, Program Change=0-127). For example, if I want to play the first song in my 128th folder I send the MIDI command MIDI: 0.127:0. If I move that folder to the 129th position or beyond I set MSB=1 but my Beat Buddy doesn’t respond. Example, I moved the folder to 129th position and tried to play the first song again by sending the MIDI command MIDI:1.0:0 but my Beat Buddy doesn’t respond. Any ideas on how to fix this so I can access my folders beyond 128? Any help or advice would be appreciated.

I can’t offhand remember my OnSong syntax, but in the two examples you gave, you have different syntax. The original MIDI: 0.127:0, has a space after MIDI:. Your second command does not show a space after MIDI:. Are you sure you are entering it correctly?

Hi Phil, thanks for responding so fast. Sorry that was a typo. I used the same format for both. I experimented with moving the folder around and as long as the folder number is less than 129 with MSB=0 everything works just like I expect. As soon as I move the folder to position 129 or beyond and change MSB=1 then it doesn’t work. I’m not home right now but I’ll look at it again tomorrow and let the forum know if I discover anything. Let me know if you have any other ideas or things to check. Thanks again.

MIDI only goes to 1- 128 (or 0-127 to be more correct). BTW in that syntax it is the LSB you are dealing with. 0 is the MSB. So 0 (MSB) : 127 (LSB) : 0 (PC). Why not try altering the MSB to 1? Or variations thereof?

I tried again tonight and still have the same behavior. If my folder is in position 128, I set MSB=0 and LSB=127 and everything works correctly. If I then take the folder and move it to position 129, I set MSB=1 and LSB=0. The BeatBuddy doesn’t select the correct folder and acts like OnSong didn’t send it a MIDI command (it just stays on the last patch). Any ideas on what to try or check?

According to the midi manual for beatbuddy, if you want to select folder 129, both LSB and MSB would be set to 1.

1 Like

Olá amigo, tive o mesmo problema com meu Beatbuddy, atualizei o firmware para a versão 3.99 e tudo foi resolvido. consigo acessar qualquer pasta acima do 128.

Hello friend, I had the same problem with my Beatbuddy, I updated the firmware to version 3.99 and everything was solved. I can’t access any folder above 128.

B0 00 01
B0 20 10
C0 00

Please translate to English so that all forum users can understand your contribution. Thank you.

MSB would not change to 1 it always stays at zero. The MSB stands for the BeatBuddy, the LSB is the folder in the BeatBuddy and the last number stands for the song in the folder of the BeatBuddy

Try sending as separate CC commands

CC #0 = 1
CC #32 = 0
PC #0 (Don’t set lsb or msb to anything)
This should select song 128

Hi all.
I see that this topic is very much alive so here’s my recommendation (which I always use):

Try using the interactive (Pop up) MIDI window that Onsong offers when you press & hold the song title, instead of typing the MIDI instructions -very error prone, if you ask me…

That has never failed me, @Larry_DirtBag