problems with Beatbuddy after tonight's gig

#1

I finally finished my pedalboard, had a gig tonight.

(1) It had different volume levels. For most of the songs, I set the volume level at 60%-70%, but when I finished WICKED GAME, I started playing DIAMONDS by Rihanna, The volume was a bit too loud, then for the song ONE by U2, it was a bit too loud as well. How can I adjust the volume levels at the same?

(2) I played first part of the song Grenade – first part is acoustic picking, including verse and chorus and interlude, Second part I use drum machine. When I pressed BB, they was a delay. unlike Boomerang looper footswitch, or even the BB footswitch, I think there is no delay, But Beatbuddy itself, I experienced delay. Do I really need to kick very very hard to activate it?

Thanks.

#2

Hi Flying Bird.
I haven’t received my beat buddy yet but I have been using the software. I may be able to shed some light on number 1 with volume differences.

For starters the different drum sets can have a difference in volume. The brushes drumset is quieter than the rock and metal drum kits.
Second, When programing the midi beats like on say Reaper you can set the volume or velocity of each hit on the drum kit be it snare, drum, cymbal etc on a scale of 0 - 127. On a snare 127 is a hard sharp hit while 50 will be a soft quiet hit. This will effect the volume depending where these values are set to. It would be possible to load up the midi files to a midi editor and change these values. Eg on metal 1 the velocity is all over 100, on Blues 3 the velocity is mostly under 70.

It’s probably a bit like a real drummer. When the drummer in my band plays Led Zep Rock n Roll it’s twice as loud as any other songs.

Hope this helps you out abit.

#3

Guitar Stu is very accurate on point 1. Currently there is simply no such figure for a BBS (BeatBuddy song) as master volume (like Tempo, for example). So in order to balance the volume level across songs, you probably need to go through all the MIDI notes.

As for point 2, I can provide an answer for you. The trick is that BeatBuddy actually starts playing on pedal release instead of press, so you will probably need to time your press more precisely as you have to release it when you want beats to kick in. I’ve encountered this very problem.

Also it should be noted that you can’t simply hold the pedal and release it when you need it, as you will then enter the tap tempo mode… Probably this behavior should get changed to at least have an option to turn that off.

As for requesting the pedal behavior changed to actual press and not release - that is, unfortunately, simply impossible. BeatBuddy will not be able to register pedal hold if it needs to fire tap action right away! Or it should then somehow cancel the fired tap action. This will lead to even more problems and undefined behavior.

#4

One other thing you could do unsing the Beatbuddy Manager is to change the volume of the individual “instruments” within a BeatBuddy kit.

  1. Click on Drumsets
  2. Choose the drumset you want to edit
  3. Double click on it and agree for it to be copied to your user area.

You will see something as below. If you click on the name of the instrument (circled in red) it will bring up the grey box in the middle of the screen shot, where you can edit the overall volume of the different parts of the kit. However you would need to do this with all the “instruments” within a kit. As has been mentioned there is no master kit volume.

#5

Worth noting, that editing the volume of a drumset will apply the changes to all the songs played with this drumset. So if song A is too loud for your taste, and song B is too silent, but they use one drumset, you will not be able to fix the problem in question.