Recording one track only then jamming to it

I’m usually pretty nerdy but I’m having a rough time with what seems like it should be 2 simple functions. I’m using the Beatbuddy and 2x2 mode on Aeros. I’m just wanting to record a couple of measures then play to them. No second track… yet. It keeps forcing me into recording a second track.

Also when it kicks me to the second track, and I mess up, I’m not able to delete the second track. I hold the button and it cycles thru settings and Undo just blinks but the waveforms remain and I still hear the sounds. Any newbie help appreciated. Thanks in advance.

In the settings menu is it set to ROP? (Record, Overdub, Play). If so, change it to RPO (Record, Play, Overdub). To delete a track if still recording, you may short press the “Play/Stop All” button to abort/undo your current recording. If you’ve already pressed play (bottom right switch) after recording, it will change to Overdub. You may long press this and the waveform will “dim/grey” and the track is undone.


Beatbuddy settings (press drumset & Tempo together)
Main pedal> Midi settings>Midi out>next part CC 102 set to DISABLE

1 Like

Hey there, when you say second track do you mean Track 2 in part 1 or are you talking about a new part?

The Aeros does not force recording a second track within a part. In 2x2, the tracks are controlled individually by the Middle and Right buttons on the Aeros to control the Bottom and Top tracks, respectively.

I believe you may be talking about a new part, if so, you should follow NYHC’s advice. Simply disable the CC102 setting on the BeatBuddy [Main Pedal > MIDI Settings > MIDI Out > Next Part (CC 102)].

CC102 is a command that the BeatBuddy sends when it changes parts, this command is read by the Aeros as an immediate change part command. This is to allow for ultimate control of both units, but can be disabled as described. The only downside is the Aeros would have to switch parts on its own either manually or via a MIDI command, but it seems parts are not totally necessary for you!

Let me know if you have any other questions!


1 Like

Being brand new, and trying to learn proper procedures, I’m positive I’m not explaining this right but I could not get the 1st track to stop. As soon as I tried, with available buttons, the 2nd track (within the part) would start recording. I could find no ‘exit’ point.

I am happy to know about the CC102 procedure and I may implement it in the future but for now changing from ROP to RPO, as JusDandy recommended, solved my problem. I really appreciate the input from all of you.

1 Like

I miss read your post
You speaking about One track!
I tough it was the parts
Disable the CC 102 is to not switch to a next PART or record, when using the transition of the BB
Sorry !

1 Like

No worries at all. I knew what you meant and am happy to know about it. I may use this modification at some time depending on how I end up using this gear.

1 Like