Remove SD card before attempting firmware update

I have a 32GB card in my Aeros, ready to go for when those features are available. Apparently, that does not play well with the firmware update feature. The firmware (2.8.2) downloaded to about 52% and then the screen went black. Aeros restarted and gave message indicating that a firmware update card was needed from support. It also said to remove the power cord and plug it back in. I removed the cord, and also the SD card, since I don’t have a card from Support. I restarted the Aeros, and it still showed 2.7 firmware, but it did boot properly. I then tried the auto update, and it went through the process properly and applied 2.8.2.

Verdict, as the title to this message says “Remove SD card before attempting firmware update.”

3 Likes

I just tested and have the same results.

Hi

I had no SD card in my Aeros when I downloaded the latest Firmware.
It tried to apply software but asked me to insert a valid SD card (mine is 8 GB class 4). So I used the above mention SD formatted card and after downloading it came back with the same error ‘Please insert a valid update file using the SD Card’. Now I don’t know what to do. Any help would always be appreciated.

BEAUTIFUL!

Kept trying to update several times on the last attempt IT BIT and updated to latest firmware! I have Firmware 3.0.0 installed now. Thank you whoever helped me on the Server Side. :slight_smile:

Stay Safe!

How many times do you think you tried until it took? I’m having the same problemM
“Error code: 0

  1. Please insert a valid update file using the sd card
  2. Unplug the Aeros power supply
  3. Reconnect the Aeros power supply.”

EDITED…. I never had an SD card in the Aeros. It took me 5 or 6 tries. I finally started plugging in the instrument cables out of boredom, and that’s when it finally “took.” Probably just a coincidence. : -)

So what happens is, when the wifi download fails, the insert valid SD thing is telling you to download the update onto an SD card, and then insert that in the Aeros. Otherwise, if you have an SD card in the Aeros that does not have the firmware update on it, it will continually fail, since it assumes you have the firmware update on the card that is already in the Aeros. Thus, as the heading to this string of posts states, you should remove any SD card that you have before attempting the (WIFI) firmware update.

For me, with super hi-power broadband internet that lets me download close to a terabyte a day at my WIFI connected computer, I have NO success doing the download unless the Aeros is within 5 feet of my WIFI transmitter.

Those would be the 2 things I would stress most when trying to do the WIFI update. 1) have no card in the Aeros. 2) be right next to your WIFI transmitter.

Even with that, I have had issues where it fails a couple time. I think it took 4 tries for the most recent update.

Thank you! I was compliant with both of those suggestions. Thankfully, it updated. Now if I could just figure out how to loop on this thing, I’d be happy. I’ve been looping for almost 2 years now on an RC-300, but the Aeros makes me feel incompetent. I can’t even get a basic 2 bar loop to work right. What am I doing wrong?!?!

I haven’t used it in awhile. I’ve been waiting for all of the development issues to be resolved. When I first got it, I had it working with the original release software, to the point where I could play a verse and then have a loop to jam over. After one of the updates, it wasn’t working for me the same way, so I just set it aside for now, as I have a couple hundred other projects on tap. Bottom line, I am not the best one to resolve your looping problem.