Section of tracks go missing after recording 2nd part and saving

Anybody know why this is happening? Im using Aeros with BB and MM all synced - recording bass and guitar tracks through a helix LT. Creating a two part song.
In 2 x 2 mode. Record 1 track - save. ( this is the 2nd part)
Record next track and this takes a number of goes to get it right. So after each take I hit the long press on the button put the track back into record mode. Two things happen -

  1. Over the duration of the takes - the bar lines start to get out of sync - the music doesn’t - just the bar lines. When I get a take Im happy with I then switch back to the first part - play that through then hit next part - and two things have happened - the bars line up - but some of the last rack I recorded is missing!!! The same thing has happened after saving the song. i.e its ok till save it - then the 2nd part has part of a track missing.
    This has happened twice now. Its just so dam strange.

This is a bug that has something to do with getting external midi clock, I’ve had it many times (without a BB). They’re working on it.

1 Like

I’ve lost several recordings since the most recent firmware update. This has occurred on both newly recorded and existing songs. I haven’t used my Aeros for 4-6 weeks, but it feels like many changes have been made to the workflow. When recording two tracks, I noticed yesterday that the middle foot switch controls the ‘bottom’ track, whereas it used to control the ‘top’ track. I didn’t try with six tracks, but that change alone led me to immediately overwrite a 10 minute track that I had just recorded.

In general, I found numerous issues that resulted in lost recordings. Closing files without saving did not work to prevent the lost data.

I was hoping others here have already detailed the issues. If not, I’ll try to describe, but I don’t see how this last update made it past any testing.

Just went through the same thing using 6x6 - And bugger me if the same thing happened again! - I lose part of the last track I recorded in Part 2. And what is there is out of sync. A pretty serious bug I think. It renders my areos unusable. I. have notified support and sent pictures. I don’t recall having this problem previously - It may be from the latest firmware update.

Is the tempo and drum kit the same as when you recorded it? Does it still happen when you unplug the midi cable from the Aeros?

Yeah the tempo and drum is the same. I haven’t checked without the midi cable in. I need it work that way though…

Hey there, thanks for reporting, when you say missing, is it only the visual waveform or is the audio also missing?
Can you reproduce this behavior or has it only happened once or twice and not again?

Hello, welcome to the forum, I’m sorry to hear you had this experience, but it’s possible something else happened and it is not necessarily a bug, but through a change in usage that you would be all set. Please, in the future, write to either the community here or to so we can better assist you and ensure you have a smooth experience.

You may be misremembering, this never worked the other way, although many users have requested that it be switched or have commented they don’t agree with Top=Right and Left=Bottom

Please forward some more information of what you are describing, with steps and videos if possible, without more info we cannot help you much more or fix anything that may be wrong

Thank you

Hi, its the waveform and the audio that goes missing. Ive sent some videos to tech support. Im going to go back a firmware version ( currently using 4.1.5 and try a few different songs and tempos. I did try 4.2 as there is a note that says that a missing track issue has been fixed? But 4.2 beta seems a little too unstable at present.

Hey there, thanks for the report, we hope to have maybe fixed this, yes, so please let us know if you see it happen again!

The next iteration of 4.2.x is not too far away, stay tuned!

I have a Loop Studio (4.02) and BB.
Sometimes I record 16 bars of drums using freeform. I use the stop and start to create the loop.

I add a track and record guitar or something and I have an instant rhythm track.
So far so good!

When I save the loop… sometimes… 8 beats or so of track 1 dont record.
Both tracks keep in sync, but the sound drops out, just as if a dub mix engineer, muted the channel.

The visual representation shows the gap.

The pleasurable experience of recording something worth saving was transformed into the annoying nuisance of a botched save to device operation.

Thanks Vince

1 Like

I have sent more videos to the support email. The latest manifestation of this problem is that it will actually substitute bars of stuff I have recorded with basically random stuff. And not consistently in the same bars. I was using 4.1.5 and tried doing the same with version 4.02. Same problem. In happens on the 2nd part and after using the long press on the aeros button to undo the last recording. I go back to part 1 and then hit the next part button to get back to part 2 and it has basically gone to shit! I really don’t want to delete the whole songs and start again. And I just don’t trust the machine at all now. perhaps if I could export the song and actually delete the track ( instead of undo) it might clear it all out. But that doesn’t seem to be an option. Any body got any suggestions?

We will definitely be looking into this, unfortunately it likely has become corrupted and cannot be fixed in 4.1.5

If we have fixed this issue internally (we fixed another similar issue) you should be able to re-record on the lost track however, I or support will let you know soon.

This could be verified using 4.2.0 which is in beta, but it is best you wait for the next iteration which will be more stable.

If you have sent a copy of your song to support as well, then we can try to do so ourselves.

If we have any more questions support will send them to you!

Thanks for your patience.

got the same behaviour. I record the loop, the wavesignal seems to be complete (at least it looks that way on the screen). But while playing the loop the last 8 beats went missing.
After a couple of rebooting the effect seems to go away, but then it happens again without specific reason.

Looking forward to the fix. You’re doing great work so far, go on!

Hello, are you sure the BeatBuddy (or master clock) and Aeros are set to the same BPM?

1 Like

Hey again, I know you are in contact with support but I don’t believe you sent your affected songs to us from your SD.

Please, if possible, connect your SD to the computer, copy the affected song folder from SD to computer.When doing this copy the folder not the contents, do not alter the contents or this could corrupt the song from being readable by the Aeros. Compress the song folders into a .zip or similar format and send to

Something that would also be helpful to have from you is your log files after this happens to you. If possible, please activate the Active Logger and get the Aeros to have the exact same behavior. Then, please send the logs along with your songs to support as well!

Here is how to use the active logger as described in the manual:

Active Logger

This is a new logging system that is available starting with version 4.0.0. This logger records all events that the looper undergoes and is intended to help us diagnose issues that are hard to replicate. This system can only be used if there is an SD card inserted into the Aeros. To turn on the Active Logger go to the Updates Page, then to the Diagnostics Page. On the Diagnostics Page there is a toggle button at the top right of the page, turn this on to start the Active Logger.

If this feature is off, the Aeros’ logging system will work as it did previously: When an SD card is inserted, boot-up data as well as any data from a crash will be saved in a log file on the SD card. These events will also be logged when the Active Logger is on.

Note: This Logger does use some memory when active, due to this reason you may experience less than perfect audio quality when it is on. This Active Logger is by default off, only turn it on when trying to catch a bug that is hard to reproduce.

Important: Logs are not saved forever, a log will be saved from the previous power on, but if you turn the Aeros off and on again, that log will be lost. Only the current power cycle and previous power cycle logs are kept.

For now, I would create a new song (do not simply clear and reuse the same song) and use that. This song file may have something odd going on. Because I cannot verify if the other users reporting the exact same behaviors at this time, you are the only user reporting this specific behavior.

One question I’d ask is what type of SD do you use?

Thank you for your patience!

Tempo on the Aeros is N/A. I am recording in Freeform mode.

The BeatBuddy cannot be used in conjunction with the Aeros while Aeros is in freeform, it must be Quantized.

Can you confirm you are using the Aeros in this way?

I can confirm that is how I am using it… If I’m jamming with Beatbuddy and then I happen to like the groove, I would like to reach over and hit record in freeform… just like any looper.

I usually record 16 measures of groove at a time.
Works fine. I can stop and start the groove… add tracks… The problem is when I save… the resulting file corrupts.

Anyway. I now understand that I cannot use Beatbuddy with Aeros in freeform.


This is slightly off topic at the moment, however let me explain:

The Aeros uses quantized mode to achieve exactly what you are describing as long as a song is not already recorded to. If you clear a song, it will adjust to tempo changes on the fly, you cannot change tempos once a song has been recorded to.

Freeform mode is not meant to be used with any other device in tandem, it is only meant to be used with the looper as standalone.

If you have more questions feel free to write to or create a new thread in the appropriate location of the forum.

Please avoid from posting on this thread further because we are now off topic


Where are we at with that one, Brennan? Wasn’t there a plan to have the ability to turn off any incoming clock? I do a lot of freeform, but my whole board is clock synced.