Section of tracks go missing after recording 2nd part and saving

You should have no issue using the Aeros in freeform with a clock passing through already, clock should not have an effect on Aeros in freeform

If you are experiencing any issue please start a new thread explaining your issue, this is still off-topic

Thanks for the question

It has occurred several times
I’ve been recording on 2 track with freeform time signature.

I’ve had loop studio for a few months and spent enough time with it to know how to do simple recording without losing everything.

I thought that’s what I was doing with my first post above. :slight_smile:

Fair enough. I have spent more time recording on 6 tracks.

I’ll try to get some details together this weekend. I was hoping that others had already reported similar issues.

Honestly, I don’t have much time for debugging. Does aeros have QA testers? 2 track, freeform time sig and start hitting: start recording on track 1; stop recording track 1; start recording track 2; etc. stop recording. exit to the menu. save the track. play or overdub.

beyond the easily lost recordings I have found that the record buttons (middle and right) are very sensitive. accidentally partially clicking either of the record buttons causes true havoc. with freeform time sig I may have a 10 min recording on track 1 and then suddenly a 3 second loop on track 2. obvs not what I wanted; I tried to undo (believing that long press would undo). I also tried double click/long pressing the record button to undo when getting into a bad (3-second) loop. I don’t remember the exact cause-effect though. I’ll try to get that sorted out this weekend.

HI Brennan, Im doing this either tonight or tomorrow. Ive been delayed due to a heat wave and losing power at nights - 3 nights in a row now. The SD card I have is a scan disk extreme 32Gb. Its speed is up to 90MB/sec. I know your specs say 32-4. But I can’t buy anything like that. Ill get the files to you ASAP. Thankyou for helping.

Thank you for the information, however, because of the complexity of the product and the amount of different ways of using it, there is possibility for things to go wrong that may miss testing because of the specific steps needed to achieve the bug.

We do not expect you to test anything yourself, but without evidence or steps to reproduce the issue it is hard to say either if the problem is the same as the one evidenced on this thread or how to assist your situation. If it is not the same issue it would be good to know so we look into it!

If you can send over videos please forward them to support@singularsound.com, unlisted YouTube videos work great for this.

Thank you for your feedback

Thank you very much for the info, is it this one?

I wanted to write to you to share a development that may explain the anomaly here!

It does depend on one factor, did you possibly save the song with the 2nd (bottom) track recorded and nothing recorded in track 1 (top)?

We have found a bug where if the only track in a part is track 2 when the track is saved, and you then undo and re-record track 2 after saving but leave the song or turn off unit without saving that it will lose the audio and it can mess with track 1 playback or completely overwrite it.

The reason for this is the Aeros considers Track 1 to be necessary to save correctly, this is because the logic for 6x6 and 2x2 is inherently tied. The Aeros does not allow “holes” or empty tracks between other tracks, and it is for this reason that if track 1 is “missing” when saved that this bug can happen when undoing and re-recording and not saving before reopening.

We believe it is not a major bug to fix coding wise, but will likely focus on it for 4.3.x which is also being worked on as we finalize 4.2.x. This bug has been around since at least 3.5.1, and it is for this reason we won’t rush it into 4.2.x and delay the release.

It is possible you did not do this exactly, but the logic error is there and so we believe it is linked to your issue.

Thank you for reporting and for sending the videos of your issue was very helpful!

May you both have a great one! Let me know if you have any questions

Well that’s interesting. I don’t think I’ve don’t it that way but I can’t be 100% sure. maybe I have! Ill spend today running some test cases. And yes that is the SD card I am using.
Cheers Tony

That sounds very much like what was happening to me. I do think that I tried saving a two-track song with only track one recorded though; almost certain that I did the same with having only track two recorded.

Having freeform time sig with no count in or quantizing can be tricky to get right. accidentally hitting the record button again while recording instantly puts the current track into a loop - which is just what it should do, but if I accidentally hit the record button at the wrong time (say, a few seconds after the recording starts) then it’s really difficult to correct that action. I would want to keep track 1 but fix the short-loop track two. How would I do that? long press the track two record button? double click the track two record button?

Excellent! I’ll always save with at least track one recorded from now on!!

Thanks!

Please ignore that. I meant to chop that line before posting. I didn’t mean for it to sound unfriendly.
:woozy_face:

Hi Brennan, I have sent a song file and diagnostic file to Jay at support
This is the text I sent him.
The problem happens for me on Part 2. And it goes exactly like this.
I record and save part 1 ( 2 tracks). I hit next part - which automatically arms Track1 of Part2. I record Track 1 of part 2 then track 2 of part2. Save it. Listen back - all is well.
BUT then I go to part 2 and decide I don’t like track 1. So I hit the long press on the top track and re record it.
I go back to to part1 play that back and hit next part to go to part 2. There I find that half the track 1 is missing. That is the song I sent you .
Actually I replicated this issue 3 times - each has a different outcome. It may either substitute audio or just delete part of the track.
As far as I can tell though it seems to happen when redoing track 1 after track 2 has been recorded - and only on Part 2.
Also I have made sure I recorded Part 1 with the top track first.
I replicated this problem 3 times so I imagine you can as well. I’m using firmware 4.1.5. I did go back to 4.02 and the same thing occurs there too.
Looking forward your reply.
Thanks Tony

The aeros gets the clock from the step sequencer, in the described case it was an arturia beatstep. Once the clock / rhytm is started, the aeros has the same bpm as the sequencer.

Hey, we have received all the files and videos, thank you!

The developer looked into your files and found something odd, I wanted to ask you, did this song ever have any locked tracks in it? Also, did you possibly record this song as a 6x6 song that had locked tracks, cleared it, and re-recorded as a 2x2 song? Anything you recall about having locked tracks on the song at some point?

Let me know, we are investigating and would like to see if we’re missing a piece here, thanks!

Hi. The song I sent with along with diagnostic log were recorded brand new as a 2x2 song. I have never used locked tracks- well not intentionally. To be honest I don’t even know how to do that.
Thanks. I hope this helps.

I’m not sure if that’s always the case. But in general: yes, aeros gets the signal, and shows it correctly, when started.

Thank you for this info, last questions, do you remember the version you were on before you updated?

Did you already have the song created before updating to 4.1.5?

Let me know when you can thanks!

Hi there can you replicate this behavior? You’re saying you’re sure they were always set to the same bpm?

Let me know thanks

1 Like

Yes, we should be able to replicate it. Will try to do that 2morrow eve and send you the record / debug file. Thanks

Thank you, please forward to support@singularsound.com

1 Like

Hi. I was on version 4.1.5 before I created the song. What ever version I had prior to that would have been the version issued by SS. I just update each time it tells me there is a new version. I had, as part of this exercise gone back to 4.02 to test if this issue still arose. It did. But then I went back to 4.1.5. Is that the info you need?

Hey Brennan,

today we did some recording. But unfortunately we were not able to reproduce the bug. We currently use 4.1.5. But as far as it looked, the aeros always got the same bpm as the clock (torso t-1) provided.
…at least, is there an option to check bpm during recording? We only see that on the song page, when the playback stopped.
We can send you the records for diagnostic anyway if you like us to. But will try tomorrow again.

Any news on this? I’ve heard nothing from support.

That is fine for now, thanks let us know if you see anything!

We are still looking into it, I would say give us about a week to get back to you, the developers are doing a deep dive.

Thanks for the question

2 Likes