SOLVED:Loud background hiss noise?- nope its back again!

I have read a few posts here re backgorund noise, with some describing it as a “river” like noise, and others saying it is so loud as to make the unit unusable.

I have had the BB for a long time now, with no use (haha it still has the plastic on the screen). I bought it, but then changed direction and had no need until recently when I decided to revisit using it again.
It is probably out of warranty, so I’ll proably have no recourse that way, but I do notice a low level hiss, admittedly when levels are high. The question I have is: is this level of background hissing noise normal for all BB units…(bearing in mind the “extreme” levels mentioned by other users)?

The other issue I notice is when using headphones, there is also digital noises (similar to USB noises from a laptop when using USB audio interfaces)…again when level is low (say aout 30%) not really noticeable, but take the headphone to say 70% and it is VERY intrusive. Again just asking is this normal?

Although as it is probably out of warranty (even with no real use) I guess I will be stuck with it, but I would still like to clarify things.


It shouldn’t be considered normal. A couple of things to try:
[]Update to the latest firmware version
]Make sure you are using the power supply that came with your pedal
[]Check that all patch and MIDI cables are firmly seated in the pedal
]If you’re using a remote foot switch, check that it’s a TRS cable
[]Make sure there’s no other source of interference nearby such as from a cellphone or a fluorescent lamp
]If you’re still getting noise, try a new SD card

Cool, thanks - did the update and the noise has pretty much disappeared :smiley:

did the update as above and yesterday I could not relyl pick up any background hissing, but today it’s back again! Quite loud

Only thing I can suggest is that if you haven’t done so already, try a new SD card.

If this doesn’t fix it, your next step will be to contact and make sure you check your spam folder or white list the email address.

Thanks, but as I wrote earlier I am pretty sure this is out of warranty (I am in Australia) so really, dealing with support in the USA is prettty awkward. I know pretty much that oence items are out of warranty period here (12 months) stores have, well, zero interest in helping out as they have no legal obligation to do so. I am quite sure Singular Sound will NOT replace this unit, so there is not much point really!

EDIT: PS: An SD card would have not much to do with audio output circuits and op amps/DACs - if it did, Singular Sound would have some wierd PCB mayhem going on inside this then hahaha! SD circuits should be no where near the audio circuits…but if someone from the company wants to chime in, happy to be corrected :slight_smile:

Have you tried the pedal with headphones? Maybe it’s a bad output jack. Also, are you sure the cable you are using is good? It’s odd that the sound went away and then came back.

Yep tried it with phones, with different audio cables, with a headphone to jack cable - all sorts haha! Actually the headphone out is even worse, once it goes past about 30% it gets noticable…to totally unusable past 60%.

Oh and I forgot to add it also generates “usb type noise (low whine and buzz)” when it loads a new drum kit!

I would still try with Singular to see if they might offer you something. IDK what the shipping both ways would cost you, but it’s very odd for a Beat Buddy to be acting that way.

There are two takeaways:
[]It seems like an SD card should not have much to do with the noise issue but it’s inexpensive enough to be worth trying. It has worked for others.
]And as Phil suggested, try Support. After all, nothing ventured, nothing
Hope you sort it out.

Yep just sent a message off to them.

Oh and for the record, I just tried an alternative SD card - no difference. Also to add, when using the main outs, the volume control has no affect on the hissing. However when using the headphone jack if it is at 0 (volume wheel), then it is totally quiet. BTW, the headphone volume control when using main outs also makes no difference to hissing noise.

Hey Pax,
I had my BeatBuddy on a powersupply chain and it would cause a lot of noise. For some reason, the BeatBuddy does not play well with other devices on the same 9v power line; needs to be isolated.

I’d recommend reading this:

nope, power supply is on an isolated circuit. I already read about others having issues with a PS.

Hey Pax,
Without knowing what testing you’ve done already, my suggestion would be to try isolate the problem. I’d take the beat buddy to another wall socket in your house and plug in some headphones (and nothing else) and see if the issue persists. If it does, you can be fairly certain the unit is stuffed. Whilst you may be out of warranty, I’d hope that Singular Sound offer some sort of servicing.

Also, fellow Aussie here.

Thanks, I have done all the varying tests. I even have three matching power supplies (including original) and all three gaev the same result, even on different circuits. No this issue is definitely in the box somewhere, afaics :frowning:

Well, support got in contact and pretty much just repeated what has already been mentioned and tried on this thread. At least they bothered to reply haha! I know of a few (support desks) that don’t :wink:

I have similar problems to yours and did those tests also. In my particular case it seems to be related to the USB port. I tend to leave my beatbuddy connected to an USB hub. The hub has on/off switches for every port it has so its convenient to press a button just to turn on or off the connection to the computer.

Unfortunately, even when the usb port is off, the hissing persists. If I physically disconnect the USB from the beatbuddy most of the noise disappears.

I suspect that this has something to do with BeatBuddy’s USB port… since I have other audiointerfaces hooked up on the same computer through USB and there’s no noise there. I’ve tried hooking up BB to different ports available, but I got the same result.

Well, support got in contact and pretty much just repeated what has already been mentioned and tried on this thread. At least they bothered to reply haha! I know of a few (support desks) that don’t :wink:

Thaknks Dan, not using the USB port at all :slight_smile: