[Solved] OnSong / BB / MiIDI / Change song - Schoolboy error?

Update: The lesson learned is ensure that your BB MIDI cables are connected.

Hi Everyone,

I’m one of the lonely souls trying to change a song in the BB when swiping to a new song in OnSong.

I read every post I can find on the topic, BB and OnSong manuals and scoured YouTube.

It should be so simple to manage once you get yor head around it. But… I just can’t make it work.

This YT video (https://www.youtube.com/watch?v=Cy9O6h1le6o&t=278s) makes it seem easy and I’ve mirrored the settings on my pedal and iPad to no avail.

I can’t help but feel that I’m missing a really obvious step somewhere.

I’m connecting from iPad to the BB via a CME Thru6 BT box.

I reset my BB midi settings and then configured as follows (using the settings in the YT video above).

Any suggestion about what’s wrong gratefully received.


BB > Main pedal > MIDI settings

Channel 1
Sync > Disable
Start > Intro
Time signature > Enable

Channel 1
Control Change (CC) > Enable

I have 2 songs in the First folder in the BB.
I have 2 songs in OnSong.

The headers in the songs are:
Welcome to OnSong
Key: C
Tempo: 85
Time: 4/4
MIDI: 0.0:1@0

Stray Cat Strut
Tempo: 123
MIDI: 0.0:0@0

Other information on OnSong settngs:
Settngs > Editors > MIDO > Wrench
MIDI enabled
Sources 3/3 > Network Session 1, WIDI Thru6, OnSong 2023
Bluetooth > WIDI Thru6 Connected

Destinations 3/3 > Network Session 1, WIDI Thru6, OnSong 2023
Bluetooth > Status iOS (Not Advertised).
(iOS does jump between Peripheral settings and Status)

Playback > Audio playback
Virtual MIDI > Enabled
Broadcast > Off
Time signature > Enabled
Tempo > Channel 1
Tap . Off

Chord Events > Enabled
Program changes > Enabled
MIDI Note start Yamaha (C3)

All other settings are disabled.

This needs to be changed to MIDI: 0.0:1@0 (note the colon) to load the second song
MIDI: 0.0:0@0 will load the first song.

Quick plug: the BBFF editor prints the correct MIDI sequence in the status bar for each song:


There was a typo (x2) in my post. This is what’s in OnSong.

The quest continues…

Got it. And it was a schoolboy error.

I’d been fiddling with my pedal board and in the mess of cables didn’t notice that I’d disconnected the midi cables form the CME Thru6. Doh.