Song names with '/' chars

Hi -

I tried to editing the name of a pre-existing song to include a ‘/’ character and upon pressing save, got an error “there already exists a song named NAME”, where NAME is the name I tried to change the song to. (Note: I did double check that there was no other song named NAME). Further, once I closed that error dialog, the rename dialog also closed, discarding all the typing I’d done to edit the song name.

This is a recreateable issue for me, but it only happens when editing a song name via the edit button at the bottom of the song list page. If you try to use a / (or other special chars) in the song name edit box of the create song dialog, or in the rename song dialog launched via the pencil icon on the loop studio page, the keyboard rejects the use of special charcters, i.e. they never end up in the edit box.

Now software forbidding slashes or other special characters in strings that may end up as filenames is not uncommon, for obvious reasons, and the behavior I describe above makes it likely that / are illegal chars in a song name, i.e. the / is properly rejected unless you are editing song names from the song list page.

If all that’s right, and / can’t be supported, there might be two minor bugs here:

  • The keyboard letting you enter a / when editing names from the song list page.
  • If you do manage to get a / into the name, the error you get is misleading.

There’s also an enhancement opportunity:

  • Losing everything you’ve typed when you okay an error in the song rename dialog.

For that last one, ideally the song name edit dialog would remain open - with all the chars a user has entered - after okaying an error. The user can always cancel the edit directly if they’d like, and typing names in is a bit onerous, so it’s a poor experience to have to do it twice (which with the misleading “song already exists error”, happened to me before I decided it was the slash causing the problem.

None of the above is a big deal, of course - I’m brand new to the aeros but quite satisfied so far.

The Aeros needs an internal directory which sits between the name the user chooses and the name used on the filesystem.

So much effort to avoid these types of errors over the years versus adding a tad more metadata.

1 Like

Thank you for reporting this is a known bug and we may do something about it but likely will not

The time for abstracting the files was a long time ago, at this point it’s more work than we believe is worth the effort

Hindsight is 20/20!

Thanks for reporting and I will tag this as not-a-bug because it technically is meant to work this way, limiting tho it is, allowing these characters and using mixed case causes real bugs that we cannot do away with without abstraction of the file name from the name in the Aeros.

Thanks for the feedback!