Tempo Knob Stops Working

Hi Folks,

It’s happened twice now and I can’t see it mentioned in the forum so I thought I’d mention it here.
At some point my tempo button stops working when you spin it. Pressing down works fine.
Unfortunately I haven’t yet pin pointed when it stops and then at some point it starts to work again.
Although, atm, I cannot get it to work. Fingers crossed.
I’ll post again when it starts up and I know what I pressed or if I workout the sequence of presses that causes it…

Have you tried removing the knob and turning the pot without it? There is a tiny screw that holds it on, maybe it needs tightening. I am aware of one person mentioning this on facebook once where one of the pots was loose.

Good point but I have checked the grub screw and all is ok. I can feel the steps of the pot operating as I turn it.

Time to contact support.

… at contact@mybeatbuddy.com

This problem can very likely be one of three things:

  1. Faulty SD card content - meaning that the actual files loaded on the SD card are in some way defective, or lacking in certain content
  2. Faulty SD card - some SD cards are themselves defective
  3. Hardware issue

Many issues that seem to be unexplainable on the surface level many times originate from one of the first two options. We had one case where someone had a very annoying ‘hissing’ noise come out of the speakers every time he would use his BeatBuddy. Of course, this sounds very much like a hardware issue more than anything, so we replaced his BeatBuddy (after ensuring that there was nothing wrong with his speakers/cables/power supply/etc of course). On the replacement unit, he had the exact same issue again, which was very strange, because these were the only two reports ever of such an issue. He replaced the content on the SD card he had (that came with his first unit) with the SD Card Backup files, and the issue still remained. Then he bought a new SD card, and placed the backup files on that card, and in an instant all the issues disappeared!

In many cases option 1 is the source of the issue, and other times it is option 2. In cases where the origin of the issue is unknown, and the suspicion is that it is a hardware issue, we always suggest to obtain a new and unused SD card, and place the SD Card Backup content on it, just to “kill two birds with one stone” and knock out options 1 and 2 as the source of the issue. If the issue still remains after applying the aforementioned steps, then it is most likely option 3, in which case the unit probably needs to be replaced (of course, only after we ensure that the accompanying cables/power supply/etc are okay, and if the BeatBuddy is on a daisy chain, to ensure that it is receiving 300mA+ at all times).

So for now, @Neild321 here’s what I suggest you do (if the issue remains even after following these steps, send an email to contact@mybeatbuddy.com):

  1. Obtain a NEW and unused SD card.

  2. Download the ‘SD Card Backup’ file from http://mybeatbuddy.com/downloads/

  3. Unzip all the content, and put the extracted files onto the clean SD card. In the SD card you should now see 5 folders - DRUMSETS, EFFECTS, PARAMS, SONGS and MIDI loops - content 1.2. (If you do not have an unzipping program, you may download a free one here: http://www.7-zip.org/)

  4. Download the NEW firmware from https://www.dropbox.com/s/eqxsjnxrtlwsa0c/HW2xx_FW128.rar?dl=0

  5. Extract it onto an SD card together with the content. In the root of SD card you should now see 6 new files added.

  6. Insert the SD card into the BeatBuddy, and then connect the power supply to the unit so that it turns on. [IMPORTANT: While your BeatBuddy is updating its firmware, do NOT unplug the power supply from the unit.]

  7. The firmware will update itself, and once it is finished, your BeatBuddy should be fully functional.

Please make sure you have both firmware AND the unzipped ‘SD Card Backup’ content unpacked on the SD card! (if you followed all the above steps, then you have)

Wow. That’s a comprehensive reply. Thanks BeatBuddy. I’m off to buy a new SD card then.
I’ll report back once I’ve tried the new one.

Sorry it has taken so long to reply but, good news…

The new SD card has solved it.