Toggle function still not working in IOS

I just updated the MM firmware after doing so on the BB. I saw in this forum where the toggle function was apparently working for IOS now, so I spent a couple of hours trying to get it to work.

Per the manual I upgraded MM firmware, then the default modes, then wrote the new custom mode to the app then sent it to the MM. The new custom mode transferred every time but the Toggle function is definitely not working for me. I tried several times on an iPhone and a iPad. I tried writing the commands myself using the latest MIDI commands spread sheet as someone on the forum suggested. I searched the forum for help.

My first clue should have been that the text for the toggle function didn’t appear in the button display. When I looked at the MIDI command page Singular Sound MIDI Commands - Google Sheets I saw firmware versions listed far above the latest version on this forum and on my MM of 1.1.7 Which confused me even more.

Is anyone else have toggle issues with IOS and MM and are there any solutions other than the workaround of redirecting to another page and having the 2nd command there?

Hi there,

A question, did you download the mode and/or commands you are using or were they created by you on the new version (or even on an older version)? We have had issues with downloading content (which we are working on now).

Please reach out to, they could definitely help you here

These firmware version numbers refer to the version of the BeatBuddy or Aeros that the command is working on, it has no relevance to the MIDI Maestro firmware version. 1.1.7 is the most recent version and all commands work for it.

Please forward your issues to so we can pinpoint the issue and fix it.

Thanks for your patience!