Trouble Making Beats - Midi File

#1

Ok so here is an interesting one…
I created a simple midi file with a drum beat on it.
I go into the BB Manager and create a new song then insert the midi file into the first track…
The first time I select the midi file, I get an error stating:
Error while parsing midi file… and midi file wont load…
Then I try a second time and it loads fine and works…
I don’t understand why this is happening… Why do I get the error the first time around?

Honestly it would be really nice since the BB works off of these midi files if there was a tutorial that could help everyone to create these files in the first place. It just seems elementary to better understand this.
There have been a lot of questions by users on this subject and I have as of yet seen any acceptable reply or help given.

Would really appreciate it…
See midi file attached…

Thanks in advance for the help…

#2

Your MIDI file appears to be totally valid.

Check out some videos by Psalm40 if you want to see some user guide videos. Otherwise, watch the official ones. They are here on the forum.

#3

If that is the case then why do I get the parsing error when I attempt to load it the first time? Perhaps an issue with BB manager SW?

#4

You know what - that’s indeed a question…

Thanks a lot for this. This should get moved to Bug Reports. I am able to reproduce the bug you say. Every other time I try to load the file, it displays the error message in question. Even when there is no message, this sample produces a really weird loop - a bit more than 4 complete bars. It sounds like 4 drum bars and a quarter of a fifth bar, then the last 3/4-rd of a fifth bar is silent. Beat indicator is really weird as well.

This should definitely be looked into!

#5

Will you move it into the bug section?
Would really like to know whats going on…

#6

I’ve reported about this problem so the team can figure it out. Most likely we’ll see some sort of a bugfix added to the new release :slight_smile: