Unpause Delay with Midi

I have a delay when I unpause a BB song. START BEAT is set to Press in settings. The action is a definite delay so stoping BB during song breaks and restarting just doesn’t work as there is not way to anticipate the start. I usually come in before the beat. I am controlling with a Morningstar MC6. I have a single switch programmed with LONG PRESS to start song and PRESS to toggle between pause / unpause.
Not sure what I am missing…?

Seems like it may be an issue with your MIDI controller or connection, there is no noticeable delay currently reported otherwise for the unit. Are you on the latest BB firmware 4.0.1? At least you must be on the earliest stable version 3.8.0.

Thanks for the question let me know

Brennan, wow… fast response, much appreciated. Yes, I’m using 4.0.1. I tested the pause / unpause setting using a 2 button momentary footswitch and delay issue goes away. So, at least I know the midi command is the issue, either on the BB or MC6 side. Also that a remote footswitch can do the job for me if needed. I have posted the same issue on the Morningstar forum to see if I can get feedback there. I plan on doing a reset on the controller if possible and reload my settings. If I resolve, I will post the how and why.

1 Like

Regarding this, the issue is fixed. Within the MC6 there are options to reduce latency to zero. In the event anyone stumbles over this… here is the fix:

  • Set switch sensitivity to 5 – this would usally fix issue
  • Update Bank with “Looper Mode” on enter (note this does eliminate the option of using two switches simultaneously to send message as with zero latency, only one switch is acknowledged.
  • Most important - if you require zero latency within a preset, do not include any double tap actions. In Looper mode the messages gets sent as soon as the switch is pressed. Unless you have a double tap action in the preset.

Awesome, thanks for getting back!