Using Beat Buddy as Backing Track Player - Problem


After using the BB in the traditional way for a while now I’ve recently started using it as a backing track player for songs I’ve written myself where I cut up the songs then trigger transitions to move to intro, verse, chorus etc.

I didn’t think this would work but it did - almost. What I did was create a drum kit for each song with each piece (a .wav file) assigned to midi 0,1,2,3 etc, then trigger these in the songs using single note midi files (0n 0,1,2 & 3)

Works a treat. No problem at all in BB manager. Works on BB too fine except for one thing: If you turn the BB on with the song you want to play everything is fine, but when you go to another song the 2nd part (in my case midi 1 triggering a wav on midi 1 in the drumkit) won’t play - but then transition to the next part and it will.

If I pull the power out or take sd card out and reinsert that song will play fine, but then the next song will do the same as above.

So to get it to work I have to restart the BB for every song which isn’t good

Any ideas?



I think you’re going to need a null section in the outro in BBM. That way, after your last written section plays, you can double tap to trigger the null, which should end the song.

Phil is probably correct because he is the resident MIDI guru. however , one thought came to me when you explained your set up, maybe you need a “note off” at the beginning of each section to stop the previous section. I hope this helps. I could be way off here.

Actually, in thinking about it more, I’m not sure a null outro is needed. But, there definitely needs to be a user action, i.e. the double tap, to end the song. To me, it sounds like the song is not getting the user cues to properly move through the song. A fill will play in full when triggered. A transition only plays as long as the pedal is held. Cue fill settings will affect when the parts trigger. With the setup described, I think you want the cue fill settings as “immediately.” I’d probably need to see one of the songs in action to troubleshoot it.

Hi guys, thanks for the input

To clarify I have no intros or outros in the manager and they’re turned off in bb too. I use double tap to end all the songs and for most transitions fills there are no fills created, it just moves to the next part without a fill. I I dont have any drum fills sets up.

With the setup described, I think you want the cue fill settings as “immediately.
Yeah it was already set to this

I think I already have a null section - basically nothing set for the outro. Is that right?

Maybe you need a “note off” at the beginning of each section to stop the previous section
How do I do that? Do I add that to the current midi file in my midi editor

What’s weird is turning BB off and on will make a song that was stopping at the 2nd part play properly, but then the next song it will stop at the 2nd part (but the rest of the parts will play OK) So it’s always 2nd song (from the one it was switched on at), 2nd part that doesnt work

Many thanks