Using Third Party DAWs - question on inserting rests

Okay, I have jumped into the deep pool of learning how to use Reaper and create my own beats using a third party DAW.

I have a question. For example, let’s say I have a song where in the first verse, all that is happening with the drums is a snare hitting on the backbeat. When I create this beat in Reaper and import into BB Manager, BeatBuddy doesn’t see the rest on beat 1 and changes the beat such that the snare is hitting on the 1 and the 3.

So, does the BeatBuddy need to have a note that it recognizes on the 1? I have been experimenting with just throwing in a random MIDI event on beat 1, but that didn’t work and BeatBuddy skipped the rest. But when I put just one kick in on beat one of the first measure, Beatbuddy pushed everything back a beat in all the measures.

pay attention to your reaper exports… if you have notes close to the end of the measure, sometimes it will add extra time to your measure, and cause the beatbuddy to get confused. after you export any midi, always reimport it, and make sure it’s what you want. I use Reaper alot, and it is notorious for trying to outguess your midi.

also, the beatbuddy doesn’t like measures that have no notes. if all else fails, put an invalid note in each measure.

Thanks man, I will take a look at that.

I am seeing exactly what you mean on this situation. And furthermore the BB also does not like measures that don’t have a beat on the one. For empty measures I am just inserting MIDI notes for “cross stick” on at least the 1 of every measure and that takes care of all problems.

But after much messing about, I am finding that the ultimate way to solve this is issue is just to make sure there is some note on the 1 of every measure - and to be absolutely sure the BB doesn’t get out of sync it should be a note that’s MIDI mapped to an instrument in the BB kit.

I use Reaper as well to make custom beats. Here’s a few tips…

  1. You can hook up the beat buddy to your PC with any USB2MIDI cable or via Midi on your audio device. Then on your track, create a hardware output to this device and plug it into the beat buddy; you’ll be able to hear your beats directly played on the beat buddy without having to export them via the beat buddy manager. This is great for tweaking velocities and making minor refinements.

  2. If you have some MIDI beats already but the don’t play correctly on the beat buddy, you may need to move some of the notes around to ones that the beat buddy recognizes. To do this, double click on the midi part to open the midi editor, right click the note name (left column) then press CTRL Up/Down arrow to move the entire row to one that works. It helps if you load the beat buddy note mapping, I’ve attached it to to this post.

  3. Press CTRL + ALT then click and drag midi directly from reaper into the beat buddy manager.

  4. If you have EZ Drummer 2, you can add your Beat Buddy library to the library path list. This allows it to be searchable. Using the ‘Tap to find’ in EZDrummer 2, you can quickly tap a beat and it will search your entire library for similar beats.
    Honestly, this the only way I work right now. I play covers in a 2 piece band, so I need to find beats close to the original material. I use my AKAI LPD8 to tap a kick and snare pattern into the ‘tap to find’ and generally try find a default beat buddy beat that’s a close match.

Awesome suggestion - I will definitely try this. I have not tweaked velocities on my midi drum beats yet, aside from humanizing the velocity randomly by 20% which sounds pretty nice. I am adding bass lines to my files and have found that bringing the bass way down to a velocity of 40 before humanizing sounds quite nice and eliminates any clipping noise from the notes.

I’m happy to report that I figured this one out on my own, created my .txt file for BB instrument mappings along with bass note mappings, and I import that into Reaper each time I edit a new MIDI file. I wish there was a way to make that instrument mapping file stay in Reaper by default for all new files.

Awesome, will try, I’ve been using Reaper to export MIDI files to a folder and then import them into BBM.

I’ve been using MT Power Drums as a Reaper plug-in because it’s free. I honestly rarely even bother to assign the FX plug-ins to a drum track; I just export the MDI file and see how it sounds in BB Manager. This is because the bass guitar plug-in I’m using also sounds horrid so I need to test out what I made in the BB Manager directly. And I figure with the trick you gave me above for plugging the BB directly into the computer and using the BB itself as an FX plug-in I will no longer have any need for Reaper VSTi plug-ins. So I’m sure I can save the cash and avoid buying EZ Drummer unless you know of any other time saving tricks that make buying EZ Drummer worth it?

Thanks much for posting this info - helps me out a lot. Hopefully we are also helping out the BB community with this open discourse.

And to anyone reading this and feeling overwhelmed by the process - I’m really glad I taught myself how to do all this and definitely think it was worth the time investment. It basically took me a full day to learn how to do all this stuff with Reaper and MIDI files.

I use the 4front bass module, and it seems ok for the job:

I am pretty much good to go on making my own files with Reaper, but I’m having one small problem: I’m getting a slight bit of audio clipping on my bass notes. I’ve attached an example - slight bass note clipping is audible when the verse starts and the bass comes in on bar 9. I’m not sure what I’m doing wrong - I’m setting the velocity of all bass notes to 40 in Reaper before humanizing. I’m using Guitar Stu’s “Rock With Bass” drumset in BB Manager.

This is a known issue that we’ve not figured out yet. The issue is that the wav file is being abruptly terminated, and if the wav form isn’t at zero when it is terminated, you get a noticable clicking sound, depending on how far the wave form is from zero when it is cut off. Ideally instead of cutting off the wav abruptly, there would be some kind of decay time to cut off the song in 5 ms or 10 ms or whatever. There isn’t a solution to it, at the moment.

Thanks for the info man! I can live it and will just wait for upgrades down the road. Now that I can make song files in MIDI the BB now serves its purpose for me very well and helps me get songs completely nailed before band rehearsal. It’s a valuable tool in my arsenal!

As far as the clipping on the bass notes, I find that if they are close together or played at a fast tempo, they click. I have also had songs that the bass sounds as if it is ringing or sounding like low feedback. When I eliminate every other bass note, it alleviates the ringing and the clicking. Some of the clicking, I have found, is caused when silent midi notes are used to help arpeggio-ify the notes. I don’t know, maybe I’m all wet.
I use the free midi editor. Works pretty good. I have found some nice shortcuts but I’m sure that there is a better way to do a lot of these things with a better editor. But it’s free and I’m poor… Sooo… If you figure It out I’d be interested in the solution. Regards, Jim

Does anyone have a .sng file that I can download to replicate the problem - something with a significant amount of clipping. I’d just like to have a look for my own curiosity.

It’s pretty clear in this one:

Hey aashideacon, I had a listen and I can hear the clicks. I opened the SuperBassG kit in the drum set editor and spammed the play button on a couple of the notes and I can hear audible click; which is a tell tale sign that the wav files were not chopped at 0. But from what I’ve read above, you’re aware of this so I got to assume that you’ve chopped them at 0 but despite that, when they’re played through beat buddy, it still clips. Is this correct?

I’ve done quite a bit of testing on this today and I’m fairly certain the clicking is caused by the choke group cutting out the WAV without fading it to 0. So I updated the SuperBassG drumkit with a new set of bass wav files with short lengths better suited to songs like dragging the line and also removed the choke group as it was no longer needed. This stopped the clipping and sounds pretty darn good if I do say so myself. You can download the updated kit here:

I’d suggest creating the bass kit to have a chromatic scale for both short and long bass notes and reworking the bass lines a little. This might help get around the clipping issue for now.