Virtual machine shows 'RTU' in beatbuddy manager

The virtual machine seems to play ok, it changes colours appropriately and shows the beat marker moving across the screen, but doesnt show the name of the beat or the tempo, just ‘RTU’ which I assume means ‘Ready to use’. I’ve tried a virgin SD card with default configuration, and also reinstalled the current version of BB manager. I’ve also synced to my beatbuddy. Same thing whether physical beatbuddy is attached via USB or not. Any thoughts on what I’m missing here? (edit: I’m on windows 10)

This is something I’ve not previously seen reported. Try this first and if it doesn’t solve your issue, then contact Support,

Disconnect your pedal from your computer. Does it still happen with the pedal disconnected from your computer? If not, problem solved.

If you still see RFU on the Virtual Machine with the USB disconnected Here’s what I’d suggest you provide Support.


  • a link to this thread
  • the version number of the BeatBuddy Manager (BBM) you’re using
  • the firmware version for the pedal
  • if possible, a screen print (picture) of the BBM Virtual Machine
  • does the BeatBuddy (BB) pedal also display RFU?

Please let us know what it turns out to be along with the solution.

A couple of other suggestions:

  • store your project on your computer; when installing the BBM, it should have created a bbworkspace folder (BBW) in your user/Documents folder. Your project work should be performed in the BBM and stored in your BBW.
  • avoid connecting and transferring data between your pedal and the BBM; instead, use your computer’s SD slot reader; if you don’t have a built-in one. Some—but not all—users have reported inconsistent data transfers between the BBM and the pedal when connected via USB.
  • if you have not read the BBM Quick Start Guide, you might find it helpful.

Ok figured it out. The 'rtu" is just part of viRTUal machine. Somehow the font got screwed up on the virtual beatbuddy and was way too large. Not sure how i fixed it other than changing the resolution on my graphics card! Thanks for the suggestions and prompt response btw!