Visual Metronome starts out of sync with MIDI


I seems that the new (firmware 1.85) visual metronome is out of sync with MIDI clock.

When I start BeatBuddy and TC Electronic DITTO X4 the DITTO blink is out of sync with the BeatBuddy visual metronome, after starting a song on the BeatBuddy they will be in sync. It seems that the visual metronome is in sync after stopping a song, but, I have tested for an hour and it seems that the visual metronome is going out of sync again. (visual not scientific test).

Is this a bug or is there a menu item that I have to change to get the visual metronome in sync with MIDI clock from start?

(The reasons that I think, that the problem is at the BeatBuddy, and not the DITTO, is that the BeatBuddy supply MIDI clock to the DITTO, and providing visual metronome)

Best regards

Welcome, Henrik. Some loopers sync pretty quickly and others take a measure before they are in sync with the BB visual metronome.

Does it do this on all songs or any particular song? If it’s one of the default songs or songs in Resources, could you provide the name, please? When this was happening with a previous version of the firmware, the developers were aware of the issue. I’ll try to reproduce the your observation with my looper (not a Ditto X4, though).


This is not related to a song, I just start the BeatBuddy and my Ditto X4, and the visual metronome and the Ditto x4 is out of sync, if I then start a song and stops it again, they comes into sync.

Best regards

Not sure that this isn’t the way it’s supposed to work, Henrik. I may be wrong but doesn’t the looper need a beat (or signal) to synchronize the midi?

Do you have another looper you can try syncing the BeatBuddy with? From what it seems so far, this is likely to be a problem on the X4’s end or possibly an issue with the setup/settings between the two. If everything is configured correctly (physically and in the settings) then syncing the BB to another device will let us know whether the issue originates from the BB’s end or the looper’s end.

You should also have this setting enabled MIDI-OUT > Sync > Always On. Is it enabled?

Is there anyway to roll the firm ware back? I am using a Pigtronix Infinity that was rock solid until upgraded and now the BB is telling it the 2 is the 1 so all of my loops are out, and laggy …

Which f/w version are you using on the BeatBuddy and which version for the Infinity? You should be able to revert to 1.8.5 or to 1.4.1, both available from here on the forum.

Using version 2 for the Infinity, and 1.8.5 for the Buddy …

Thanks. Couple of things to try before you roll back to 1.4.1:

  • download and install Infinity f/w 2.1.0
  • check your 1.8.5 midi settings on the BB pedal to see if they had changed when you updated

Ok so tried rolling back to 1.4, epic fail, that firmware doesn’t have half the things I need, so back to 1.8 … BUT, I have worked out that this issue, and its recent, is with the intro’s. The Infinity gives you a visual beat count, highlighting the “1” where the loop will start recording so you can hit the record switch early and get the loop dead perfect. However in the intro, the midi clock is telling it that the 2 or the 3 is the 1, so if you start your loop in the intro phase, when the screen goes green and the main part starts, your loop is badly out of sync.

If you wait until the entire intro finishes and then loop over the main part, it works, but until yesterday, I was able to loop on the intro seamlessly, I hadn’t done anything to change it, it just started misfiring all of a sudden.

Up until then, my sync worked perfectly, I am a full time player and have been using the BB 4 nights a week no problem. The issue does seem to happen more with full songs, both user created and purchased, but is also happening with beats. The guy above ( Henrik ) same problem with different looper. I use the Pig because it has the BEST midi clock sync going around, but now it also is glitching. Its the BB midi clock in the intro’s ( and no the looper doesn’t need a bit of time to sync, as soon as you set the tempo on the BB it knows what the count is. ) Please help !!!

If you use an iPad for lyrics and song lists you can use Set List Maker to control both the BB and the Pig perhaps. You could send the midi on different channels and maybe even kick off the BB after the 1 in the clock cycle so that the first beat of the main BB loop falls on the 1 or even start the clock after the intro. I am not sure of all the possible controls available in SLM and I don’t have it with me at the moment. With the midi automation in SLM you could even kick off the start and end of a loop. Worth looking into if you have an iPad or equivalent.

Hi, is SLM an Onsong feature ?? or a separate app, I use Onsong for my charts, but my ipad (2) only has a usb out ( and headphones of course ) so not sure how I would run midi out - and in separate channels … Thanks for wading in, its frustrating …

SLM is a separate app and has many of the features of OnSong too. I prefer OnSong for lyrics etc. but SLM has much better management of midi commands and automation. Automation in this context allows you to record events against a backing track that can be played back in sync with the backing track and can be used to send midi to the BB to effect a transition for example. Or you could send midi to a compatible effects pedal to turn it on or off. I send commands to the VoiceLive3 to turn on harmonies, guitar boost etc. at the appropriate places in a song. I think this is possible in OnSong too but it is a little more difficult to manage there. As for the midi links between iPad and other devices I use the iRig Midi 2 ( which can work with a power supply from IK Multimedia to keep the iPad powered up ( - this setup is a little expensive but works well. You can then feed the midi out from the iPad to whatever device(s) you have. The separate channels can be set up In SLM (or OnSOng I think). And then you specify the channel to receive on the BB in the settings menu. I am not sure this will solve you issue but it provides a number of additional options to look at and gives you more flexibility . SLM will send out a midi clock and I have managed to get the BB to sync to it. Do you play to backing tracks and if so what device do you play the tracks on?

Hi, thanks for all of that, very interesting. No, I don’t use any backing, I don’t even use the bass tracks on the BB, I change that kit straight away, I loop like crazy, hence the need for everything to be super tight, and I have an electric duo with a bass player , so with the looper we sound like a 4-5 piece ( we both also play keys ) …So its just getting the BB in sync with the Infinity, and it was until yesterday, I didn’t actually change anything, just all of a sudden the looper started reading the 2 or 3 as the 1 ( same as Hendrik above - who is using a different looper so its not the loop device its the midi signal ) … Its weird when it does it too. Very frustrating with important gigs in new rooms this weekend.