WAV files are slightly too long when put in DAW

When I move the audio clips from my Aeros loop studio to my DAW with an SD Card, they show up at a slightly different tempo than I had originally on my Aeros. For example, I had some loops that were at 92 BPM on the Aeros, and they were 92.7 BPM in Logic pro X and they would not line up correctly in Ableton Live 10 either. This happens even when I turn off smart tempo settings, and warping. I am trying to figure out how to get the audio clip length to be exact without having to stretch the audio. I have been trying to figure this out for a couple of days. Does anyone have the same problem or any idea how to fix this?

2 Likes

You can do something like this… https://www.youtube.com/watch?v=tlsRVC72hx4

While a fix-up like warping my might work in the short term, I wonder if there’s a fundamental bug with how Aeros handles bpm that needs fixing?

1 Like

Thanks for the replies. I made a couple of samples at 120 bpm in Aeros Loop Studio, and in both Logic Pro X and Ableton Live 10, the imported loop samples are off by the same amount. So its not the DAWs that are causing this problem. I think this is a bug like Quad mentioned. I can’t get it to line up with time stretching in either Live or Logic, but it is only off by a very small amount, so it is subtle, but it still doesn’t work. I think the tempo is different by .11 BPM (at 120) because in Live it says the clip is at 119.89 BPM instead of 120 when warped.

2 Likes

One of the main reasons I purchased this pedal is to work on loops in DAWs afterwards. I currently am not able to do this because the timing isn’t right on playback. It seems to be a bug like Quad talked about. Is this a problem for anyone else?

3 Likes

This is one of the features I am most excited about too. I haven’t used the Aeros with my daw yet because I don’t have an SD reader on my studio Comp. I plan on doing so in the near future. Has anyone else duplicated this issue? Any word from SS on this issue Brian?

Hi lash. I haven’t heard anything from SS. I am hoping this will be fixed soon if it is a problem that other people are having. Even if it isn’t I am anxious to find a solution.

2 Likes

Or have something to do with the way the Aeros crossfades the loops?

I also plan to utilize loops in my DAW, will test that later and give feedback. :slight_smile:

1 Like

Just buy a USB SD card reader.

Of course and I’m sure I will… but there isn’t much point in me doing so now, if the wave files are too long, I wouldn’t use an SD card for anything else. I can always use a laptop to transfer files. That’s not really the issue I just meant to say that I was looking forward to using the feature but haven’t gotten around to it.

Hey there!

No, you’re not crazy we actually had to add a bit to every recording to keep pops from happening, if you remove exactly 360 samples/frames from the end of the file at 44.1kHz, you will be good!

I’m going to go pull out all of my hair now.

edit: Ok I’m back and I don’t look as good as David with my new hair cut. Is it possible we could see an option to make a song Daw export friendly, even if it is destructive?

Wow. At least now I can blame that instead of my timing when I blow the take on the seam. :wink:

Altering the duration of the loop seems like a bad design decision for the exact reason that the OP ran into … as well as this leading to drift in quantized (and presumably unquantized mode). In general, better to not modify anything that the user records.

Whether or not you modify the audio, can you not save those changes to the file system? Do it at load time, on the fly, or worst case save it some place other than the source loop (perhaps creating a very small “seam” file that is used in place the equivalent bits in the song track file).

3 Likes

Ok, what’s an easy way of doing this in Ableton Live and Logic Pro? Is there a way to move samples over from the Aeros minus the extra 360 frames, and if not can you add this feature in the next update?

2 Likes

I use Sound Designer for simple audio manipulation.

In Sound Designer:
Select All
Edit > Set Selection…
Set the second dropdown to “samples” to view the End value in samples.
Subtract 360 from that value and enter the new value.
Click OK
Edit > Crop

Your file is now 360 samples shorter.

In Logic Pro X:
Import audio file on a new track.
Double-click audio region to open Audio Track Editor
Zoom in to the end of the audio, enough that you can see individual frame/sample measures at the top of the Audio Region ruler.
Using the resize tool, drag the right side of the audio region to the left to shorten the audio.

1 Like

I don’t think you’re interpreting this “extra time” correctly for a live scenario. The loop is not lengthened because the extra 360 samples are used for a crossfade. This affects DAW users but not the looper’s timing (otherwise the extra samples would be pointless).

Hey all,

This will not affect playback on the Aeros, it just helps out with creating fades with adequate amount of audio information to avoid all pops. It is of minor inconvenience when loading into a DAW, but there are ways to streamline the trimming process, I wouldn’t have too much issue in a ProTools session for example, but Ableton I’m positive there’s a way to change the timeline to be in samples/frames.

There may be ways to deal with this issue and improve the experience for our users exporting to a DAW, but that is not currently a priority, so that will likely be in the future.

Thanks for all your feedback!

1 Like

Ok so that affects me as well then. I have Reaper, and I was just shrinking the end of the tracks down, but that’s not good if there is some extra stuff on the end that I need to get rid of. How do you edit sample length in Reaper?

Haven’t seen an obvious way to do this in Studio One yet either. I have figured it out in Cakewalk. This isn’t a minor inconvenience, it’s tedious as hell.

1 Like