When Aeros is set as transmitter, BeatBuddy make infinite unwanted transitions

I have a problem, when the Aeros is set as transmitter (master), if I change part it will normally trigger the transition on the Beatbuddy 1 mesure before the end of the loop, but then it immediatly the BB triggers an other transition from the first mesure of the second part and it force Aeros to go to the next part, and again, it immediatly trigger an other transition… to the infinite…
The only way to stop it is to hit the main pedal footswitch of the BB as soon as possible in order to cancel the unwanted transition…

Yes, I linked the BB and the Aeros with 2 midi cables. BB out to Aeros in and Aeros out to BB in.
Why ? Because I need the Aeros to be sometimes master and sometimes slave, depending on the song.
When I want to first record a loop and then start the rythm, I want the Aeros to be the master. But when I pre-record a loop and I want to play the intro of the BB before to play the loop + rythm , then I want the BB to be the master.

I have the latest firmware on both BeatBuddy (4.1) and Aeros (5.1) so with the parameter “settings template” in the song menu of the Aeros I can configure the midi behavior of each song (master or slave) without changing the setting of the looper each time. I load the song and depending on that particular song the Aeros will be master or slave (transmitter or receiver)

When The Aeros is the slave, it works perfectly. But when it’s the master, the BB make crazy infinite transitions…
An other way I found to kind of resolve that, is to select a different channel for the midi out of the BB and the midi in of the Aeros. If I do so, the BB make the correct transition from part 1 to part 2 without immediatly do an other unwanted transition.
Unfortunatly, the midi channel is not affected by the "settings template. It is set for every songs and it cannot be set differently on each song…

Do you have any idea ?
Thanks !

Hi there, could you please forward a video of what you are seeing with details to support@singularsound.com?

We want to make sure we fully can see what is going on here

Please make sure that the BeatBuddy has the Transition Forgiveness (Main Pedal > Transition Forgiveness) setting enabled and that you are using version 4.1.6

Let us know, thanks for reporting!