When I plug the midi out cable from BB into aeros should they automatically sync? Mine don't

When I plug my BB midi breakout cable OUT into the midi in on Aeros the Aeros continues to say MidiSync-Off and nothing happens in Aeros when I start BB. I’ve put all the settings on both boxes to the ones the manual and instructional videos suggest. Should I be expecting it to change its midi status when I plug them together or is there some manual way to set the midi sync? It worked one time for me and then, without me changing anything I’m aware of, it quit. Everything else works fine.

What version of BB firmware do you have?

I just downloaded the latest one. 3.8.0. And I’m running the new beta on my Aeros.

Ok, double check the settings on your BB:

  1. Press both Tempo and Drum Set knobs at once to enter settings menu
  2. Go to Main Pedal> MIDI Settings> MIDI Out> Sync
  3. Make sure it is set to “Always On” (or to whatever setting works though always on is advisable for Aeros connection, as long as it is not disabled).

If you do this and there is still an issue please let us know!

I have the same issue. I followed your instructions above and it is set to “always on.” Here is background on issue:

Everything has been working well until today. Only change was I downloaded and moved to my sd drive the June Premium download (I always download the whole thing - and have never had problems). When I put the sd card back in BB, Aeros would no longer Midi sync.

To diagnose possible problems I looked on the web, youtube, and in comments, but did not see any relevant threads.

So, I reupdated BB firmware to 3.8.0 - which I already had done but why not try again).

I reset all settings in BB according to instructions for midi setup. And I reset Aeros to factory settings. I have most recent download on Aeros.

To test if it is a hardware problem, I ordered a new midi-cable from your site and a 5-pin cable from Amazon. It will be a couple days. But this seems extremely unlikely as the only thing that changed was downloading and using June update.

So - I switched back to the April Premium download. Now, the midi sync no longer works with that download either.

Please help. I use the BB and Aeros together everyday. Thanks!

Hey there, definitely reach out to support@singularsound.com with your issue and they will work with you to resolve it.

Ok thanks.

I am having this exact same problem . Was an actual answer ever sorted out ? I set my Beatbuddy as suggested above with no success. The 2 units used to sync but at some point sync seems to have stopped working. Is there a switch to control midi sync on the Aeros ? Mine either says OFF or on some programs says N/A. I couldn’t find any useful info about it in the manual . My Beatbuddy is running firmware 3.8.0 and my Aeros is running 3.1.18.
Thanks

I had this issue and solved it by getting a new midi cable.

I will try that .
Thanks

EDIT :slight_smile:
After I changed the MIDI cable I noticed that at some point I had unplugged the MIDI in on the Aeros and had been trying to run the MIDI out from the Beatbuddy into the MIDI out on the Aeros … pure user error .
Thanks again

1 Like