Accent hit delay

I have this problem: even if my footswitch (the original two button pedal) is detected, the accent hit is played when I raise my fooot, not when I push the button… why?

If you have the original remote foot switch, it probably still has the latching switches and you need the momentary switches. You can verify this with the foot switch detection or configuration setting on the pedal.

You can change the release setting in the settings.

Ok, I’ll try again but I didn’t find where I can change from latching to momentary in the settings…

The detection identifies the type of switches you have in your remote. If the detection identifies them as latching, that is something that the firmware cannot change since they are mechanical. You would have to physically replace the switches with new momentary switches. You can contact Support and ask them if they still offer to exchange the remote foot switch for a modest fee. Or, if you’re handy with a soldering iron, you can buy the new switches and replace them yourself.

On firmware version 2.7, the detection/configuration setting prompts you to press the left and then the right switches.

Ok, now I got it… I get prompted to press both switches as you’re saying. But I’m quite sure that before the upgrade the accent hit was on time, and now it is played a little after I press the switch. But maybe I’m wrong…

Upgrades reset all settings to the default, so if you had custom settings, like Start on Press (Default is Start on Release), you’ll have to reset all of them. Switch detection defaults to momentary, so you have to reset that as well, as Persist has said.

Good luck!

From the former reply, I understand that the momentary/latching option is a hardware one, not possibl via setup…

It absolutely is possible. I’ve been using the original latching buttons since the Kickstarter shipped. The BB defaults to momentary switches, so you have to go to the pedal setup and use the option to detect the pedal. After that, you should be fine.

I hope you’re right, because this can solve my problem… But when I detect the pedal, i can’t find where is the setting to momentary/latching…

Press the middle and right knobs on the BB to get to Settings
Scroll down (one click) to Footswitch. It opens on Footswitch Detector. Select that and follow the prompts.

And that should be it.

ok… when i press Detect, it prompts me to press left and right switches, and that’s it… no other prompts…


So, press them.

That’s what I do… after that, no option between momentary/latching can be found

The display should say “LATCHING BUTTONS DETECTED” or something like that.

Ok, but you’re saying that I can change it to momentary, or am I wrong? Where can I do that? Because persist says I can’t…

You can’t change what hardware you have attached without physically changing the hardware. But, as I understand it, your original problem was that, after the upgrade, accents that used to happen on press now happen on release. That happens because the BB thinks you have (defaults to) the momentary switches, but you actually have latching switches. I think Persist said as much and suggested you upgrade to the newer momentary.

It’s important to note that this is a hardware change, because momentary vs. latching are physical attributes of the switch hardware, and are not software definable. So you can’t just declare you have momentary switches when you actually have latching switches.

Regardless of which switch type you own, you follow the same steps so BB knows what you have. What’s important is that your Beat Buddy knows what’s attached to it, and you can get back to business as usual.

EDIT: I have latching switches, and I go through this exercise every time I update firmware or create a new project, because both of those things reset the pedal to factory defaults.

Joe, I appreciate your help, but there’s one thing I still can’t undertand (my fault…): can I have the accent hit on time when I press my (latching) pedal switch? I think I could do that before, and now I can’t, and I can’t find where can I set this option in the menu…

If you set your pedal type to Latching, it should now work, otherwise, it’s a bug.

Does that make sense?

Maybe it’s because of my poor english, but where is located the pedal type setting? I can’t find it|