Aeros 5.0 midi sync w/BB 4.1.3 and OnSong

I have just updated to the latest Aeros firmware 5.0.3 and no longer have a synced tempo between the Aeros and the BB.

Aeros General Settings:
Midi In - Midi Mode = Receiver
Midi Out - Midi Mode = Receiver

Song Settings:
Sync tracks = start & length
Song Grid Mode = Quantized
Count in = 0

Please help…


Hi, could you please write to with a video of what you mean so we can better assist you?

Thanks for reporting

Hi, just checking in, any news on this front?

I had the same problem. Had to go back to version 4.1.3 to get things to work again. Getting pretty ******off at “customer support” for wanting me to go back to v5, make them a video of it not working, then make another video of everything working after I again reload v4.1.3 and send it to them……….WT I am a full time working musician. I bought their products to use as tools to use so I can pay my bills, feed my family. Now they release “upgrades” that totaly **** up my way of making a living, and they expect me to take another week of my time to help them figure out where they ****** up? Really? Without even a hint of an apology? To be honest, I think thier products are outstanding…….WHEN they work as promised. Fine. But…….I am a CUSTOMER….not a product DEVELOPER. When I plunk down hard earned cash to buy a product that promises the moon….it better **** well deliver the moon! If you can’t deliver, then don’t say you can. I will keep using the products that I have, as they work, for now. But…I will never trust another “upgrade” until it has been proven to me that it works, and for now, and the future, until it has been proven to me otherwise, I will no longer recommend any Singular Sound products to my fellow musicians. Very sorry to reach this point, but after several unanswered questions to customer “support”, the only response I have recieved has been one reply where they wanted me to do something for them, and absolutely nothing to help me solve MY problem. Good luck guys……. You have a lot to learn

To be sure.
Are the cables good connected
Beatbuddy Out to Aeros Midi in (nothing on the Aeros out)
Is the tempo indicated to both gear the same ?
If you turn the tempo on the Beatbuddy is it changing on the Aeros ?
I mean with 5.0.3

Yes to all. Everything was working perfect until I downloaded v5. The ONLY thing I changed to get everything working again was to reload v4.Sorry if I offended anyone with my previous comments, but after losing an entire week because of a faulty update, I was not a happy camper!

Nothing yet. I was able to send a video a few days ago to tech support but have not heard anything back.

Was hoping to get a fix by tomorrow as I have two shows this weekend.

Go back to v4 so you can do your gigs this weekend. That was all I had to do to get my system working again

Yeah, I’m trying but now I"m getting some sort of Office365 error for downloads… Saying Onedrive. something or other is not available right now. Trying to reset the default download folder but it’s not working either… I even tried to download the last firmware update I had saved on my computer but it doesn’t seem to do anything when I load it in the Aeros. I’m not having very good luck right now.

BeatBuddy Firmware (427.9 KB)

Thanks but I already have BB firmware 4.1.3.

Trying go back to the previous Aeros firmware before 5.0.

I got the same type of messages when I downloaded 4.1.3. Ignore them and download/install anyway. That worked for me, hope it does for you.
I find it extremely irritating and disgusting the total lack of help that people like you and I are getting from customer “support”. This gear isn’t cheap, and we use these products to make our living. We paid them our hard earned money, and put our trust in their products, and this is the thanks we get

Just to be clear, you’re using the BB as the master and Aeros as the slave, and when you create a new song on the Aeros, the tempo you set on the BB is not being relayed to the Aeros?

BB is Master, Aeros is slave. I can visually see the tempo on BB is 75 and Aeros will fluxuate from 75 to 74 (in red font) and back to 75. When playing, I see it on both as 75. I can see the little blue arrow pointing to the left under “Tempo” on the “Loop Studio” screen.
After recording the first loop, the playback is not in sync with the BB and each repeated playback is progressively worse.

Ok, I believe I have figured out the issue. It looks to be an issue with the midi codes coming from Onsong. I have Onsong set up to select the BB song and tempo. I think Onsong was sending constant tempo messages instead of just one at the beginning.

So I’m going to work through my entire 500 songs before I use it live again. I’ll post my findings here.

I had this issue before the upgrade. I basically had to set the loop up, record and save it. Go back into and fix it so the first first loop was in sync.

Tell me this, if you start the BB and looper with the foot switch, is it out of sync on part 1? Can you stop play on the Aeros only, then restart the loop on the next measure and it’s in sync?

I was wrong, it is still messed up…

I don’t have the footswitch but I do use a midi pedal. When I start a loop and the BB, the first loop seems in sync. It takes about 4 measures to notice the loop is not in sync.

When I stop the loop and leave the BB playing, sometimes it will play at the next measure and sometimes it will play back immediately. Not sure of why it is different for different BB songs but using the same Aeros song.

I did figure out that if I hit the midi pause button and pause BB and Aeros, upon unpause of both, everything starts back in time but slowly creeps out of sync after about 4 measures.

Do you have it set to quantize to measure?

With the new firmware, it is not setup that way.

The options are:


  • OFF


  • AUTO

I have options “START & LENGTH” and “QUANTIZED” selected.