Aeros firmware 3.1.x

What’s the “design” for when BPM is updated via midi clock changes?

Is the following correct if midi sync is on?

  • Before first track is recorded, adjusts to midi clock BPM changes
  • After track is recorded, the BPM doesn’t change.

If that is true, it would be nice to:

  • Update the documentation

  • Change the Tempo indicator from “100 BPM” to “100 BPM (Warning: MIDI at 120BPM)” if the midi bpm and the song bpm are not the same.

    • Bonus points for making locked be a icon, red text, or something very obvious.
    • IMHO this is a good way to handle “alerting without getting in the way with a popup message”
    • Same warning for time signature (although there are some good uses cases where time signature sync would need to be disabled by user preference per song)
  • Change the Tempo indicator from "100 BPM to “100 BPM (Locked)” if the BPM will never change due to MIDI.

  • Note: There is a roadmap feature to allow stretching recorded tracks. I’m guessing that this feature will take quite some time to ship … and even when it does, many will not want/like the (sonic or other) tradeoffs that are likely.

1 Like

Does MIDI Time Signature change work?

I tried a few tests and have not seen the time signature change when loading new songs on the BB. Using the latest BB firmware.

FYI, it might be useful (when this does work) to to allow this to be disabled per song. Not a priority for me though.

So, I was able to control the Aeros (Mute, Solo, Change Parts, Play, Stop) with a korg nanokontrol studio controller through iPad+iRig Pro i/o. After some MIDI cc settings, I’m very happy with the results.
A couple of questions/observations:

  • Is there any MIDI messages for Track Levels? If is not, is there any plan to add it soon?
  • Having the Aeros as MIDI clock slave, when I change the bpm on my iPad, it doesn’t show up on the stop screen of the Aeros, but the Aeros actually change the tempo, but it’s not showing up as a BPM Value on the Aeros.
  • I don’t see any control for MIDI Clock on the Aeros, that’d be really useful (for not say necessary)
1 Like

Please help! I followed instructions for trying Beta 3.1x. Downloaded to my Mac. Renamed to aeros.bin. Transferred to SD card and inserted into the Aeros and turned on. Doesn’t change firmware. Went to updates section - no way to update.

I’d like to have a global setting to ignore a bpm mismatch. Or, even better, have Aeros as master only for bpm when loading a saved song. Or a quick toggle for that setting when loading a saved song. I’m not too familiar with midi so I’m in the dark as to what is possible.

The warning feature would be handy and was brought up by one of the devs in another thread but that still doesn’t prevent having to hand-sync the BB to every saved song that is loaded.

I also did the same procedure on a Windows 10 PC and no way to update. What am I doing wrong?

Which file format is the SD card?

Quick note as you’re working on next functionality: would be great to have mixer level and pan controls over the dry audio input, as well as the looper tracks. That would also give you dry kill functionality, as requested elsewhere, by setting dry volume to 0.

Reiterating that ideally we’d see MIDI functionality for every command being implemented going forward. Thanks!

Screen Shot 2020-06-23 at 7.17.29 AM

Make sure your card is not locked. Your SD card should be formatted as MS-DOS (FAT32)

I don’t see any mention of a facility to have songs displayed in order on the selection screen. This a real disappointment. To be honest, I’m close to giving up on the Aeros because it’s becoming impossible to use live when you can’t quickly locate the next number in your set.

1 Like

Sounds exciting… Will try that ASAP. So regarding my requests, it should fix:

Apart from that, still no file hash… ¯\(ツ)/¯ :anger: why ?

Maybe something like a document to keep track of the releases, that you could “watch” (with the “watching button” displayed at the bottom of a topic)…

1 Like

There is a click when you loop. I do the same loops with a jamman and I can’t hear the connection between the end and the beginning of my loops. With the air it is a disaster.
Are you planning to do something?

1 Like


This is a UX issue, not to worry the audio is not affected by this, we are working on optimizing the waveform the Aeros makes, but it’s handling quite a few levels adaptively, and that gets more complicated to show accurately as you add more and more overdubs, we’re working on that.

This is related to something that we believe we’ve found the problem for, hopefully there will be a solution soon and this may be related to the length of the crossfade as well.

Stay tuned on that!

  1. I don’t understand this question could you re-phrase this for me, please?
  2. You can’t have the cake and eat it too, so to speak,

Yes you will have to tap twice to convert the overdub to a play command, but don’t confuse that for a double-tap.

What I mean by that is that the Aeros reads any second tap within 500ms (it may be 300ms now, but I’m positive it’s 500) as a double-tap which is a mute command.

Because of this, if you double-tap too quickly, the Aeros won’t register the second tap since muting at that point is not allowed.

While writing this I realized this could possibly be improved by creating a corner-case logic for a double-tap that it instead causes a change of state for the upcoming command. I can ask dev about that. For now, time your taps with a small (half-second) pause, if possible, to change an upcoming overdub to a play command. Obviously, this is only possible if you have at least Sync Length on, if in freeform mode.

We have found the issue causing this and are working on a solution, stay tuned.

Thank you for reminding me let me ask.

This is correct

How so? To specify that BPM only changes once before recording something? Do you mean on the Aeros manual?

We do plan on making a visual system for this that includes red flashing as well as separate internal and external BPM and time signatures.

That’s a thought, we could do something like that

It will most likely not be any time soon, especially given the difficulty of not compromising audio like you say, we will get there when we get there, so to speak.

Depends when you change the time signature, if the song is blank and you open a song different than the one currently open on the BB, it will send a time signature message, we hope to optimize this at some point.

No, but we have gotten requests, so it may be in there eventually, stay tuned on that.

Interesting what app are you using on you iPad?

We have plans to implement this, it is on the dev list

We plan on making a simple touchscreen button that can turn off and on sync for both CC and clock independently, stay tuned on that


This is true, but our soundscaper guys benefit from seamlessness, I agree with you however that most instrument signals are not devastatingly affected by this. We have found the problem, and are working on a solution.

Yes, we are aware of this I answered this above^

We’d hate to see you go, but please know it’s on the dev list, we can only focus on so much, we hear your issue, too


Yes. Would also be good to update the release notes in the first posting here (perhaps the one on the device as well)

Ooh. That reminds me, some of the flashing in the UI is pretty “strong”. Would be great to soften that and have limits as to the speed (If you create a very, very short loop …watch out for seizures).

Please add to docs and changelog in the first post in this thread…

The true test is if there aren’t similar artifacts when you take the separate signals and put them into a professional DAW. The Aeros shouldn’t be held to a higher standard than that (and not much lower).


I believe its in docs now, but I’ll ask David about editing the thread

Is this with the BB or on its own?

I’m trying to replicate this, but I’m not hearing any click unless there’s a count in

You have the click routed to neither output and the click after recording first track setting is off?

With the BB and with the the routing to nowhere and click after recording off as well.

This is pretty disturbing as either of those settings should override anything that ever happens elsewhere in the code. Is this code messy? Just saying…

  • Record a track with BB running (I’m using a 6/8 if that matters)
  • Stop Aeros
  • Press Overdub with time left in the pattern on the BB.

Recorded waveform started reading zero signal before the end of the first loop. By that I mean the display looked just like nothing was being recorded. But upon playback of first track the audio was there and the zero reading showed up at the same point. Same for overdub. This was 2x2 in 6/8 with BB running.

Pretty sure when the display dropped out on recording was much earlier than the l 1.25 measures it showed upon replay.

Upon recording the last overdub, I saw the live recording drift to the left off screen as time went on!

I also saw the white bars between the two tracks not lined up.

This seems to be a new issue for this beta release?

IMHO, 2D layout can be deceptively simple, and pretty buggy without the right representation.

I have no way to reproduce this. I had been playing around with the above stuff trying to break it then cleared it and started playing. I think I changed from 4/4 to 6/8 after clearing the song and started via the BB midi after I saw the time signature update.

Bug: The scroll wheel doesn’t work in the song list any more.

Feels like the Play/Stop button is active in more places in the UI. Haven’t found a place where its felt off.

1 Like