Aeros firmware 3.4.x

Ok, freeform and 6x6?

One thing I’ll ask is to downgrade to 3.3.0 and make sure it is not still there, just want to make sure there wasn’t a possible file corruption. Thanks!

Or if you can send me the files I can run that test as well,


No checksum test when loading updates from SD card?

Might be simpler to ask him to report the MD5 or SHA “checksum” for you to compare.

  • Windows: CertUtil -hashfile <file to check> MD5
  • Mac: md5 <file to check>

If file corruption is a concern, this would be a good trick to have up your sleeve (and arguably downgrading is the modern version of “please reformat and reinstall Windows”)

Hi @BrennanSingularSound

I just opened a bug report about the point 3 in my previous remark, now that I have been able to reproduce.

And I didn’t even have to switch of part…

Aeros Wouldn’t Save A Song. Updated to 3.4.2. Everything downloaded and rebooted fine. Created a new song, named it, and pressed Save. Everything on the screen then disappeared except the “Aeros” title screen. Waited a while - nothing. Finally turned the unit off and turned it back on. My newly created tune had vanished. Went and recreated the whole tune and this time it allowed me to save it. Have no clue why this happened but it was not fun nor inspiring.

1 Like

Hey, that’s odd, was it by any chance Song_1? Or a renamed version of what was Song_1? We have some things to clean with that song file, because it is ‘special’ in the code as of right now.

Some questions:
Can you reproduce this? Does it ever save?
This sounds to me like a crash, did you save to internal or SD? Was there an SD present when it potentially crashed? You could send me the crash log from the SD (it may have saved one) and I could send that to the Dev team to look into.

You can send it to me via private message as a compressed (zipped) file


Thanks for the response Brennan. I do remember that when i wanted to create the new song and I opened Aeros it showed up as Song 1. That surprised me because i have 30+ songs on the hard drive and wondered - why the hell is it saying Song 1.

Anyway i just went forward with my recording and have already described what happened. I also seem to remember that when i shut Aeros off and then restarted it, the new blank recording said Song 33. I’ve since renamed it so it doesn’t say this anymore.

At this point i don’t have an SD card installed and only recording to the hard drive.

Just recorded a new song to test it out. Once again “Song 1” showed up. Recorded a track on it, went in and renamed it, and it saved with no problem and did not cause the unit to shut down.

That’s all i know but i have a sneaking suspicion that the “special” nature of Track 1 might be a little too “special.” Good luck!

Symbols Not Allowed In Song Title

This is not a huge issue but unless i’m doing something wrong there is a potentially annoying glitch. In 3.4.2 - i recorded a song and went to change its name. The name required an “&” symbol so i went to that screen with the symbols. Neither the “&” or any other character i tried from that screen would show up in my title when i pressed it. Went back to “letter” screen and used the word “and.” Worked fine, but what about the symbols???

They disabled special characters in song names as a workaround to a file corruption issue i believe. It was several versions ago so this isn’t a new issue but I think they said allowing special characters is on their list of improvements.

My MC6, just like a little brother would do went crying

1 Like

We hope to improve this

We have removed symbols, we will likely revisit the design to reflect these limitations.

Thank you!

I’m considering buying the Aeros Loop Studio, but read that it currently does NOT send (nor respond to?) MIDI Start/Stop messages – which would be essential for me to synchronize it with other loop pedals I have. Will you add MIDI Start/Stop support in the next update?


Midi expansion won’t come until after the extending recording time firmware… my guess is we won’t see the new midi implementation until at least May at the earliest.


It doesn’t send MIDI transport, but it does respond reasonably well to those messages. It has to to work well with BeatBuddy.

The lacking parts you’ve picked up on is that there is very little MIDI control support. There’s a lot of things that either can’t be done or require use of the on-device buttons or screen. So… Changing mix, locks, mutes, arming the next part, or song, etc, are all lacking. The core MIDI sync is pretty good (although the latest firmware seems to desychronise more than it used to).

If all you’re after as midi synchronization, then it’s relatively good at that. There are a few YouTube videos that will show you that in action.

1 Like

We have found that these were caused by “Loop Forgiveness” edge cases and have been fixed in current tested version.

Like said above, Aeros can already do this, it does not generate the messages itself however. We do plan on incorporating Master capabilities soon. Thanks for the question.

1 Like

Thanks a lot for all your replies. Sync leader functionality is crucial for me, but good to know that it’s on your agenda.

1 Like

I am recording over an existing loop with a new loop, but 1 bar before the end of the loop I get the “Warning out of memory” which interrupts recording and does not record the last bar of the loop, then after I confirm the warning message the whole track is muted.

  1. Why is memory limited per song, when I have plenty of memory on the Aeros and on the card?
  2. Why allow me to record right up to the point where there is no more memory left and then kill the magic and inspiration I just recorded but just cutting it off with an error? Why not only let me use 90% of the memory then tell me I can’t record anymore. This would would be better than letting me record until I am out of memory and then interrupting and truncating my work?

I believe this is going to be fixed in the very next update, so hang tight buddy. I’m still excited for an auto quantized to bar mode but believe that got pushed back to address the very complaint you are expressing.

This was a limitation decision that we have (clearly) rethought as the very next release will fix this issue!

There will still be one caviot, we have not created a “smart” out of memory action, meaning if you see the memory warnings and keep recording and hit the 20 min (10 in stereo) mark, you will not be able to record more and recordings that could not be finished to comply with sync rules (break the song) will be undone and will not be redoable. The file is salvageable from the optional SD card in this state.

We plan on soon having better ways of handling this but first we just wanted to build an adequate system that doesn’t crash the looper or lose content when maximum is hit. The user is warned twice at 90 and 95% full. The idea is to have a way for Aeros to “know” when to commit a recording to avoid this but that may be tricky. Once we have different limits, this may not be the primary issue anymore, however.

Basically, we’re working on it, and will continue to improve on it! Thank you for the feedback!

Definitely! We’re excited, too!

1 Like

Any update on the ETA?

New firmware has been posted: Aeros firmware 3.5.x