Aeros Firmware 5.0.x

Jay at support sent me the flash file and instructions to re-flash the operating system. Easily done and the 5.0.3 went through via Wi-Fi without a hitch.

Thanks Brennan and SIngular.

1 Like

Hi. Just installed 5.0.3. I see an Aeros behavior change that I think is a bug. I would be happy if there is a workaround.

With the previous software version, I had implemented a “Play Aeros Loop Once - with a single press” of my MIDI controller pedal. This was implemented by sending :

1. CC-43 with Value=1 (Start Song)
2. Waiting 100msec. and then sending CC-43 with Value=0 (Stop Song) which would result in the loop stopping when it reach its end and not repeating

With 5.0.3, this sequence of MIDI commands results in the loop starting to play and then stopping immediately. If I send the Stop command even 1.0 sec. after the first command, I still have this problem. If I send the Stop command much later - say 10 sec. then it has the result I want, but my midi controller cannot support such a long wait time.

Can this be fixed - ie, reverted to the behavior pre-5.0 ?

Or, is there a better way for me to send a “Play Loop Once” command to the Aeros ?

Regarding the small text on the screen, I just posted in the Feature Request some thoughts on making the UI more readable. Example (my crude UI mockup):

Here is the Feature Requewt:

Wonder if this is related to your stop settings no longer being set to “end of loop”?

Related, I want a way to play part once and then go back to prior part (or next part). This is for a chorus or bridge and then going back to the A (or B) section. Would be nice if this was a feature of the part, but maybe a set of midi commands can do it. Would also need a way to transition back upon ending the recording of the part.

Hi Quad. No, the problem exists if the global Stop Song setting to “end of loop” or "end of “measure”. In either case, if the CC-43 with Value=0 (Stop Song) is sent a bit later than 1 sec. after the “Start Song”, then it works as expected.

Therefore, I may need to revert to an older Aeros software version where this problem did not exist.

Again, a workaround or a better way to send a “Play loop once” midi instruction would be great.

Hi, Brennan. Great job on 5.0. One suggestion/request for future versions would be to add a gesture, such as a long button hold to return to the number 1 song part. If one records a lot of tracks in a part, it can get unwieldy quickly to navigate around the parts. Might have to get the Maestro. I wish there was a Gold edition of it with silent buttons.

Download links for Aeros 5.0 Manual PDFs:

Aeros Manual
Printer Friendly Aeros Manual (less dark colors for less ink use)

These links have also been posted in the original post :point_up_2:

1 Like

Maybe it’s just me, hmm? :disappointed:

“Upgraded” Aeros to 5.0.3. Made sure all of my songs were on the card.

Two issues so far:

  1. When I stomp the songs knob on the Midi Maestro I get the master folder on the Aeros and had to finger the Card icon and then finger the “songs” folder icon before getting to my songs. I hope that doesn’t mean that the songs button on the Midi Maestro is unusable or needs reprogramming.

  2. The first song I tried, it played first 8 bars and then SILENCE for the rest of the song even though it showed complete waveforms.

Then I quit for now. Bigger problems in my cosmos.

Haven’t a gig till later in the month so upgrade Aeros to the new version. Maestro takes me to songs but my scroll up and down buttons no longer work. [Sorted: the channel had changed!] But now I can’t read the song titles without bending down. Is there a way to make text bigger?

1 Like

How can I silently erase the current recordings when the Aeros is stopped ?

With the handsfree (need the last version 5.0.3)

*I have 5.03. installed …… how do I use it to do what I asked ? Thanks

Aeros settings Handfree icon set to ON when stopped
You can select and reorganize what you want later
go back to the loop screen
Hold down the bottom left switch
A menu go open and use the schroll wheel
Select with the right bottom switch

1 Like

I got it . Thanks again.

Can anyone tell me how to get songs onto my SD card. I used to be able to move songs from drive to SD but can’t see how to do it now. Thought I’d sussed it. Used the complicated (now) move. But it’s still not visible on card via PC. [Gotta be the most unintuitive and awkward way of moving a file. So much easier before. Now if you’re a bit sensitive with your fingers it’ll select the file (load) so you can’t move it. What a palaver!!

Brennan thanks for the great support very helpful. i fixed a couple issues.

  1. Fade to Mute i fixed by just reinstalling the update works perfectly now.

  2. The power issue with the Zuma i fixed by just plugging in the power every time rather than turning the power on with the power plugged in. If the power is already plugged in it doesn’t work and needs the OEM power. Maybe it needs a bigger burst to get it going? Have no idea but this seems to fix it. If it had an issue i usually just leave it off for a few minutes and it can power on with the Zuma. Basically a power cycle.

Just to recap plug in the Zuma with the power turned on the Aeros

Really love the Aeros. I can do a lot with it!


Do you mean turning on the Aeros’s power switch after turning on the Zuma?

If not, that might be better than pulling the plug in and out all the time.

Aeros Loop Studio V5 Beta. Create albums,copy, move, songs from Sdcard to internal memory (FR/ENG) - YouTube

1 Like

I bought a new sd card to try to add backing tracks, however it does not show up on my pc when it is connected to the aeros. it only shows the internal memory. how do i get my pc to show the sd card when its connected to the aeros?