Aeros midi sync problem

Some times the Aeors is not in time with the midi clock, or the the loop wich is playing is not in time the midi clock.

For example im using 2x2 mode and have the aeros as midi receiver connected with my drummachine. I played in a guitar loop over 32 bars on one track and another more softer guitarloop on the second track. So im trying to build an arrangement.

The first loop is muted for the intro over 32 bars, the second loop is playing during the intro.
After the the intro i unmute the first track and there is the problem i cant solve. Sometimes the first track is right on point and often it is behind or in front of the beat. I tried a lot of times and each time it is slightly different. I tried a lot, recorded the loop again and again, but everytime i am ending with the same problem.

Is this a midi problem, is the aeros only useable with the Beat Buddy? That would be a real pity.
I tried a lot of differnet settings but can´t solve this problem.

(And there is still the problem withe the autorecord in midi receiver mode, i described this problem
in a different post, but nobody answered.)
MOD ADDED LINK: Midi Sync Auto-Record Delay

Hopefully someone here can help me.

Thank you.

I still have this problem and it driving me nuts. I don’t know what i am doing wrong.

Hopefully someone can give me a tip how to solve this problem.

I can’t believe I’m the only one with this problem.


Here are my three cents, all which might appear obvious and which you most likely already know:

1: If you are changing the tempo within the same song for different parts it will glitch the Aeros. It can only handle one tempo per song.

2: Before recording, have you tried changing the tempo with whatever device is controlling the clock on your board to ensure the Aeros is tracking? If not, midi settings in Aeros?

3: The best route, if you haven’t already done this, is to send an email to In the few instances when I have contacted them regarding a seemingly unique problem, they have been responsive, thoroughly helpful, professional and surprisingly personable.



Thank you Bill.
I tried all you proposed already a lot of
times but with no success.
So will try the support.

Great! They have responded to my inquiries within 36 hours.

Just in case someone else finds themselves in a similar bind, I post Singular’s response under my heading of the same topic.

Best of luck in your continuing quest to avoid the niggling details that distract us from actually playing music! :sunglasses:

1 Like

I wrote to the support 6 days ago. Unfortunately, I have not received an answer so far. A little disappointing.

Wow. That’s rude and, I’m sure frustrating.

Did you see this thread?

Support is usually responsive. Are you sure their reply didn’t end up in your email spam or junk folders?

They will usually ask for your firmware version and to try the latest available version if you are not using it. They may also ask for a video that shows the symptoms you are reporting.

1 Like

Thank you. This sounds like a similar problem. But when read this post correctly they already have fixed the bug in an earlier update.

Unfortunately the have not yet replied. I’m looking every day into my spam folder, but there was nothing.

I have an answer from the support. They wrote that they are overloaded with requests for a support so it took longer. Now I try to work on a solution. I will do some video to show my problem as precise as possible.