Beatbuddy firmware update does not complete - need help urgently

I downloaded the latest firmware update, copied it to the SD card, disconnected my beatbuddy from my computer and restarted my Beatbuddy. The Beatbuddy is not saying “UPDATING BEATBUDDY FIRMWARE”, and it has been like that for the last 5-10 minutes. What should I do?

If you were already on 1.85, it wouldn’t be updating anything since it was already there. If you weren’t on 1.85, then you have an issue. I noticed that the Singular firmware update page did not have the version number listed on it last time I went there. When I downloaded the firmware, I was surprised to see that it was good old 1.85. I had hoped they had finally released something new.

Is the Beat Buddy just looking like it is ready to play, or it there some other screen or no screen?

They announced that they released 2.0.4 today. I have downloaded it, but haven’t tried to install yet. I may hold off a bit to make sure there isn’t an issue like blackfs is reporting.

Oh, well that changes things. Thank you for that.

Update: I just downloaded the 2.04 and the update went smoothly.

Blackfs - I am not sure why it would make any difference, but the preferred install method (according the install instructions) is to insert the SD card into your computer and copy the files to them, then put it back into the BeatBuddy (turned off). I recall reading a post about that as well somewhere.

Do not use the USB cable to update the firmware! Plug your SD card into your computer’s SD slot reader and copy the firmware to the SD card and then try to update the pedal.

Yeah, pretty much what it says here, as Persist says .

Just updated mine, and the Unit is reporting 2.0.4 :slight_smile:

This is not a new issue.
If your pedal won’t power up after the failed f/w update attempt, you may contact me via PM or Support at

Hello there! I’m sure I’m not the most experienced BB and Infinity looper user, but the troubles I’ve got seems to be the same as the most users. Yesterday I update the firmware on both, and now they don’t sync at all. Even the two arrows indicating the midi connection disappear. OH MY GOD! What have I done wrong??? You are all the angels that can give me answers! So I hope and wish my self good luck with that

  • Power both pedals off
  • Reseat the MIDI cable between the BB and the looper
  • Power on to both pedals
  • Check and reset the settings on both pedals as needed
  • Let me know if this worked.

Just a quick update. The screen was continuing to show “UPDATING BEATBUDDY FIRMWARE”. In the end up, I had no choice but to unplug the Beatbuddy from the power supply, even though everything was warning me not to do that. I have since removed the SD card, and recopied the files onto the SD card, put the SD card back into the BB with the power supply disconnected, and then connected the power. This time, the update went through the process and updated successfully. Thanks everyone for your help. Fred.

Glad you got it working

I no longer have access to the menu from the BB that I made the update.
Can someone help me fix the problem?

I have copied the files in the BB via USB cable as mentioned in the following video:

The pedal clearly indicated that it was updating. Once finished everything works as before, except that I do not have access to the menu (drumset and tempo pressed).
I saw in this thread of discussion that it was necessary to do the updating clearly on the card, without going through the usb wire (unlike the video). So I have done the update this way. Again, the update was done, but still no access to the menu.

Hi, Jean-François. Try one more time except this time, you are going to go back to version 1.8.5 of the firmware.

  • insert SD card to computer slot reader and delete all files from the SD card
  • copy the five 1.8.5 firmware files to the SD card; eject the SD card from your computer
  • with power off to your pedal, insert the SD card and plug pedal in; wait for update to complete
  • check to see which version of the firmware is on the pedal; if everything works, you can update to 2.0.4; check again to see if it works and if it does, you are going to restore the project; insert SD card to computer and from the BBM File > Export > Project to SD Card
  • if this still does not work, you will probably have to either try with a new SD card or try to format your old SD card using the computer slot reader; make sure the format is set to MS-DOS (FAT-32)

Ok thank you, I try this tonight.

Where can I find the 1.8.5 firmware?


Hello Persist,
This does not work, so I suspect the tempo pushbutton. Perhaps the problem was there before the update and that I just noticed.
I am an electronics technician, I will open the BB to check if it is the button that is in problem. But before, is there a way to access the BB menu via a computer? That might suit me.
And thank you for your help.