Beatbuddy + Pigtronix Infinity = unpredictable pitch change solved!

Both are with the last firmware (3.6.0 beatbuddy, 218 infinity)
I use two amps for two independent loops so input split is always on.
The problems:

  1. Record loop 1 and press stop before ending: the loop’s pitch is completely change, slower or faster (unpredictable)
  2. Record loop 1 and switch to record loop 2 have the same issue.

I tried to reformat the sd card but the problems is still there.

Pigtronix alone works fine. The problems is with beatbuddy synced.

Please guys I really need some help because I can’t use it…

Thank you

There may be other Infinity related threads on the forum.

Thank you Persist.
Before posting here I searched google “pigtronix infinity varispeed” and I found only one 2016 thread on singular sound forum about that problem. Anyway I try to search on your suggested link, I really hope to find some answers and solutions there…

I saw the thread you linked persist but… if I disabled the sync then I can’t have the loop play along perfectly with beatbuddy, I don’t understand…

Another thing: I can’t arm the loop 1 and 2, I mean everytime I switch the recorded loop he start directly, no arming, no red led before, just the loop start to play directly…

Try setting the BB to only export it’s clock when playing. I’m not sure about the Pigtronix looper, but this fixes the synch issues with the Ditto X4.

1 Like

Hi Adaptive, thanks. That’s funny, this is exatcly what I tried yesterday evening and it works! No pitch change on Pigtronix too but other new bugs arise though… lol

Is it normal that in series mode I can’t arm the loops?
They play the loop directly so, for example, when I want to delete the loop I push the related footswitch and for a moment the loop start before I quickly stop it and then delete it.
In parallel mode I can arm the loops so everything’s fine.

Anyway now the looper is synced well and there’s no pictch change so is a pure bliss play and compose with both beatbuddy and infinity! lol

1 Like

Awesome. Enjoy!

1 Like

maybe it will help you
In All mode, the STOP foot switch will stop playback on both loops. The ALL function also applies to the clear command. After selecting ALL, long holding the STOP switch will remove both loops. The ALL function also applies to the Play command. When the loop stops, pressing any footswitch will resume playback on both loops.
In the ARM mode, the STOP footswitch will only stop playback in the armed loop. The ARM function also applies to the delete command. (to stop both loops in ARM mode, press the Stop foot switch twice within 1 second). The ARM function also applies to the PLAY command. When the loops are stopped, pressing the loop footswitch will only resume playback of the current loop.

1 Like

Hi Rysio, thank you. Yeah, I can keep playing in ARM mode and, at the end, I can switch to ALL mode and delete everything :slight_smile:

The issue IMO is that there is a bug in how the Infinity Looper treats the STOP when synced to MIDI vs. when it is not. It behaves as you expect when not synced, i.e. you are recording a loop and hit STOP because you want to end the loop without playing it. Then when you play the loop, pitch is normal. That is NOT what happens when you sync to midi AND (here’s the important part) the stop mode is set to TRAIL. In this case, I don’t know what Pigtronix thought anyone would use this for, but it’s worse than useless, which is why I think it is a bug. What you have to do is set “stop mode” to FULL; then it will behave as you want it to. it’s also a good idea to disable the clock from the BeatBuddy when it is stopped so that you can use the looper for songs that you want to loop on without the BB.

To recap:
Using MIDI sync: set “stop mode” on Infinity to FULL.
Not using MIDI sync: use any stop mode you need.

Johnny

2 Likes

Hi John, thanks! That’s nice, I didn’t try yet the different behaviour of stop mode when synced. I hope FADE is without bug as FULL…

Hi,
It looks like pitch is preserved only for FULL stop mode when synced to MIDI.

Johnny