Can't access the settings menu!

I have read through all the relevant threads and have done everything that was suggested on those threads and still can’t get the settings menu to come up by pushing the drum set and tempo buttons together.I have the latest firmware and it was installed using the proper method.When I push the drum set button it pulls up the sets just as it should. When I push the tempo button nothing happens. I push them together and the drum sets come up. I just got a midi foot controller and can not do a thing with it until I can pull up the settings menu.Been using the beatbuddy for years without issue, but this one has me baffled. Someone please help me. Thanks.

Has the tempo switch ever worked before? It sounds like you’ve done all you can and that you might have a bad switch. Before you contact Support, and if you have not done so already, download the firmware, unzip and copy the files to your SD card using your computer SD slot reader. You’re doing this on the offhand chance that the previous firmware download was somehow incomplete. With the pedal off, insert the SD card and plug the power adaptor back in to the pedal. After the update, does the tempo button work? If not, contact

Thanks. I Did the update 3 times in the manner you described. And yes the switch did work in the past up until I did the latest update.

If you want to try a couple of other things, you can download and install 1.8.5 to see if that makes a difference however, I suspect it won’t. The other thing you can try (if you haven’t already done so) is to disconnect all connections from your pedal and gently tap/shake it several times on each of the pedal’s 6 sides. You can also use compressed air to try cleaning out the inside of the pedal and all of the switch shafts. If you have DeOxit, you can apply a little bit to the shaft of the tempo pot and work it in.

Does the rotary part of the tempo knob work? With a song selected (doesn’t have to be playing) does the tempo change as you turn the knob? If it doesn’t, it’s another possible indicator of a problem with the tempo switch/rotary portion of the knob.

Yes it does control the tempo when turning the knob.

I tried everything you suggested short of spraying chemicals into it and still nothing. I don’t think my unit is still under warranty, pretty sure we got it in '15. If there was another way to access the settings I would not be in such a quandary…The pedal functions flawlessly but for this one button. I am at a loss…don’t know what to do next.

As persist suggested, the DeOxit may bring the switch back. The stuff has worked well for me to get switches and contacts back to working order. I have a Tascam 2488NEO DAW that over time had developed problems with some of the pushbuttons and a careful shot with the DeOxit brought them back to functioning the way they should be. Not much is used for a quick squirt, so it will last a long time.


Thanks, I will get some and try it. At this point I’ll try anything.

Ok I got the Deoxit ya’ll recommended and I used it to no avail. Switch is still no workie… is there anything else I can do that has not yet been mentioned?

The Drum Set and Tempo knobs are what is know as ‘Rotary Encoders’. They send digital pulses to their respective circuits, rather use ‘resistance’ like the Volume knob to control the electronics . They are generally pretty well sealed so as to keep out dirt and other contaminants. Getting the contact cleaner into the switch may be difficult or impossible, but sometimes letting some time pass may allow the DeOxit to work its way in. The best way to ensure the DeOxit may get into the switch is removing the black knob to expose where the shaft (see below) enters the body of the encoder. The knobs ‘generally’ pull off with some effort, but I have not tried this with mine (if it ain’t broke, don’t use your own as a guinea pig for someone else).
Had you tried rolling back the firmware as persist suggested?
I hesitate to suggest, but sometimes a couple rapid finger tip taps delivered to a switch can get it working.

I hope SS used some quality rotary encoders (ALPS brand for example) in their products. Of some older gear I’ve got (Yamaha and Alesis) the encoders have gotten wonky and erratic in operation and will not select data correctly. Fortunately I was able to replace them myself.


1 Like

Sorry to hear that the DeOxit didn’t work out for you. I’ve exhausted all of the suggestions I could come up with and would have to go back to my original reply above which is to contact Support. Yes, I realize that you’re well out of the warranty period but it certainly would not hurt to ask Singular Sound if they can offer any special consideration for your situation.

I think MarkF48 made some pretty good suggestions. I’ve found that working the DeOxit in and immediately (because the DeOxit evaporates quickly if it hasn’t worked it’s way down the shaft) rotating the shaft several full turns and then allowing it to penetrate overnight helps in some cases. I’ve had scratchy sounding pots on amplifiers and guitar knobs that benefited from MarkF48’s advice. A while back and somewhere else on this forum I posted how to get DeOxit down into a mis-behaving pot. Cleaning Volume Knob

“Well, why not try to get it repaired by an electronics technician?” you might ask. I suppose you could but if you go that route, there could be 2 (maybe more) issues: assuming that the repair shop is willing to tackle such a job, they would have to find the exact replacement part; and, some users have reported that the contacts from the rotary encoder are soldered to the board (which further complicates and extends the time and risk involved trying to replace the switch—but I don’t know this to be a fact. Get estimates and ask if they will guarantee and warrantee their work. Costs may range from $85 to $200+ per hour to repair (not including the part). Hate to say it, but if following the suggestions made in this thread don’t help, your last resort is to contact Support.

1 Like

Thank you guys I really appreciate all your help and suggestions. I did remove the knob and tried to get the Deoxit down into the guts of the pot. I twisted and turned it several times and depressed it many times trying to work the Deoxit in to the internals. Been doing this for a couple days now off and on with no results. I have contacted Support and now just waiting for them to reply back. At this point there is little else I can do.

Hi Tucopeat, any updates on your issue? I am facing the exact same issue as you (Broken Tempo button, unable to access settings) and I’m wondering whether support provided any useful response/remedy for your situation?? Thanks!

No I’m afraid, they gave me several suggestions to remedy the issue, none worked. They made no indication that they could repair the unit, and I asked. The only thing they offered was a 20% off coupon to purchase another unit(mine was out of warranty). I have considered taking mine apart and trying to fix the switch or maybe replace it but I gig with mine a lot and don’t want to screw something up that I can’t fix. My only resort is to leave it as is until it is no longer usable then replace it with a new unit.

I am facing the same issue with mine today unfortunately. I haven’t tried contact cleaner yet but will before i contact support. Just wondering did support offer to sell you a replacement pot? I could have it installed if i could get my hands on a replacement if thats the issue.

No they only offered to sell me a new unit at 30% off. I asked about a replacement pot but got no response.

Just for clarification, the ‘Drum Set’ and ‘Tempo’ controls are not ‘pots’ (potentiometers) which are resistive devices, but are rotary encoders which creates a digital information by way of pulses from a set of contacts. Good explanation of how they work in this link…

Over the years I’ve replaced rotary encoders in several pieces of equipment when turning the encoder resulted in settings I was attempting to scroll through were jumping all over the place. Usually this occurred in equipment I didn’t use much, so I’m not sure if some kind of tarnish had developed on the contacts which caused a poor contact. The switch in the encoder may fail or become erratic in the same way. Contact cleaner can sometimes work to ‘fix’ the problem temporarily and many good quality encoders are sealed well that makes penetration of contact cleaner difficult to impossible. With some luck sometimes the manufacturers information can be found on the body of an encoder and used to find a suitable replacement matching the size and specs (detents and number of pulses). The BB’s encoders are under a main circuit board and I’m not sure how easy they are to access. If you can find ALPS brand encoders, these are probably one of the better quality ones that are out there.

1 Like

That’s helpful information - thanks!