Cue fill settings ?

Can someone explain the proper settings for the cue fill tap …
I’ve experimented w everything from 10% to 100 %
I’ve counting the visual ‘metronome’ from 1 to 4
& I’m still having a problem ‘hitting’ the right screen beat for the outro’s on ‘time’
I’m getting ‘puck shy’ figuring this one out …
I just turned my volume pedal down & play over a tag.

Any suggestions ?

I set mine to 50% So, when I’m doing Keep Your Hands to Yourself, the fill is the last two beats of the measure, so you have to hit the fill in the first two beats. If you set it bigger, I think you can hit the fill later, and it still inserts the fill in “this” measure.

So I think in the extreme, if you set it to 100%, it will do the fill whenever you press it regardless. If you set it to 0%, it will always finish the current measure, then do the fill.

I’m not 100% sure I’m right… I might have it all completely opposite!

I set my fill measure to 75%. The reason I set it to this is I have some fills which I trigger when they start on the first beat. If set to 100% and I trigger the fill just before the first beat it will miss out the first bar of the fill. With 75% I can trigger just before the first beat and it will start the fill on the first beat.

With other fills I trigger them anywhere up to 75% and they will play out the rest of that bar.

I program my fill depending on the song and weather I want to start the fill (when I program a fill it is not normally just a one bar drum fill but will be a whole part of a song like a chorus, bridge etc) on the beat or anywhere in the bar before. Normally when I am busy singing will determine this.

thanks guys, I’ll start @ 75% & work up …
I lose about 1/2 beat on the outro …
( eg, Memphis. the ending of the 1st outro lick, just playing along in time)
not sure what my settings are even at …25% I think (pedal @ gig)
Even my own bebop alula makes me nervous.
I can’t even b.s my way to catch it & I just cringe … & put it into ‘witness protection mode’
… deny deny/blame the ‘drunk’ drummer lol… ;(
( onepress is not in my plans … I like more flexibility .) … but ! :frowning:

I tried 75% tonight …& missed it by __that much …lol
tomorrow … 50 % :wink:

We were high fivin’ @ 50% tonight …lol
live experimenting …gotta love it . :slight_smile:

A better way to maybe understand this is at 100% the fill will start immediately. As you decrease the amount, you have less time to think about it. In other words, at 50% you will only get 50% of the fill in the same measure. At 25% which is closer to the end of the measure, it will play a very short part of the fill or just probably move to the next measure before playing the fill and of course at 0% it will definitely wait til the next measure to play the fill all the way. aashideacon has it right.
Sincerely, Fingerstylepicker.

Nice :wink:

I tend to look where I am on the pedal metronome now,
when I approach a fill or just keep my foot on the transition …
setting my sights on 1 or 2 beats b4 the fill is needed !


I have my “Cue Fill Tap” set at 50% and if I catch the last two beats, it will trigger to start in the next measure which works OK for me. It gives plenty of room for the “Push and Hold” movement.
Sincerely, Fingerstylepicker.

50% seems to work best for me too. I have the option to trigger for the last two beats of the current measure or wait until the next measure for a full measure of fill.

I’m pretty new to the BB - just got mine recently and began to dive in a little tonight, including a firmware upgrade to 1.85. This cue fill feature is confusing and this description above is exactly the opposite of what’s listed on the firmware page, which says
“At 0%, when the pedal is pressed, the drum fill and transition always trigger immediately. At 100%, the player always waits until the next bar, before launching the drum fill and transition. The default is 0%, so that fills and transitions are always triggered immediately”

I think the page is actually wrong and fingerstylepicker is right however I’m getting some odd behavior or at least it sure seems odd and I’d like to verify it’s normal and my pedal is working correctly.

With cue fill set to 100% it definitely seems fills play immediately but what I’m finding is they only play until the end of the current bar. So if I hit it the pedal very late in the bar and I may get nothing more than a single beat of the fill.

With cue fill set to 0% the display changes immediately when the pedal is pressed but the fill does not play at the start of the next bar, rather mine waits; it doesn’t start with next bar but several beats after I press the pedal. Sometimes it’s 3 beats after pressing the pedal, sometimes it’s 5 and sometimes if I press the pedal in beat four it does actually play the fill in beat one of the next bar. So what it looks like it’s doing is waiting until the next bar and playing the fill so that it ends with that bar. Neither of these scenarios is ideal nor very usable, which is maybe why so many are favoring 50% but is this even normal behavior?

Nice! a very philosophical discussion of how the beatbuddy works!

The idea is pretty simple, though, but it depends on how many measures the fill is. I just had to revisit this whole thing while implementing the “auto pilot” feature, which I think will simpllfy the behavior.

The way autopilot works is this: if there are fills (or transitions if we’re on the last loop), when we reach the beginning of the last measure of the loop, make a decision. Fill or not? If there is a fill there, we DO IT. However, we count how many beats are in that last measure, vs the fill.

Lets say we are 4/4, and the fill is two beats. Autopilot triggers the fill, then plays 2 measures more of the main loop, and finishes with the 2 beats of the fill.

If the cue fill is > 50 it will do that same thing, but if the cue fill is < 50, it will play the rest of the measure and THEN play the fill.

See? It’s current measure vs next measure.

The example I would use is Keep Your Hands To Yourself, in which the fill is two beats of the last measure where the fill is mainly silence. You have to trigger it in the first two beats of the last measure, in order to make sure the fill happens in the current measure. (You do NOT want it to happen in the NEXT measure!)

If your cue fill is set 0-50 and you hit it in beats 1 or 2 the correct thing will happen. If in the extreme your cue fill is set to 90, the silent fill will happen in the next measure (unless you triggered it waaaay early). Make sense?

I’m so glad this is being discussed. I’ve been struggling with this but refrained from posting anything until I fully played all the options for myself. I think I’m starting to understand the concept.

The Autopilot feature sounds so great. cant wait to try it out

I played around with the settings (just 0 and 100%) more last night after my post to fully come to grips with what it does and how best to use this. One thing is certain, the “official” description on the BB firmware page is wrong :rolleyes:.

That settled I finally came to understand what happens at these two settings for Fills (assume behavior is identical for Transitions):
100% - Fill plays immediately upon pedal press and ends in current bar. Meaning the fill is cut short if triggered with insufficient beats remaining in current bar.
0% - Fill plays in its entirety in the next bar, timed to end with the 4th beat of the bar.

This is basically already said here in the thread but I was getting tripped up by the unique behaviors of these two extreme settings, that the fill gets cut short if triggered too late at 100%, while plays completely but timed to the end of the subsequent bar at 0%. As I was experimenting with a song that has 6 different (and different length) fills, the behavior seemed erratic with both settings and I couldn’t figure out what the heck was going on. :confused:

aashideacon, I’m thinking you meant to say plays for two beats more? Otherwise I’m not sure I understand but then again I’ve only just begun and haven’t looked at Autopilot at all.

JN99, it doesn’t sound quite right! What I would do if I were you is to reload everything and set it up again. There might be a glitch or error in the commands as far as the fills are concerned. At 100% percent the fill should start immediately and will play for as long as what’s left in the measure and go back to the “Beat”. If however, the value is set at 25% or less, it will wait til the next measure. It should never start 2 or 3 measures later. This is not right. If you’re using the original SD Card, it might be corrupt and not be correctable. I would purchase a new SD card at least with 2GB or bigger and “Format” it, then download the original contents from the forum which should always be available.
Hope this helps.
Sincerely, Fingerstylepicker.

Thanks for the reply, I goofed any typed in bars in my original post when I meant to say beats. That behavior is consistent with what I now understand is the the way the feature is supposed to behave as noted in my 2nd post above. It didn’t help matters that I was trying all this out with a song containing 6 fills of varying lengths. Let that be a lesson!

As I said before, I have mine set at 50%. This way at the point where there is a couple of Beats left, I trigger the fill and then I have plenty of time to get my mind back to my playing before the fill comes in which allows me to be way ahead of myself which is necessary especially for a lead guitar player who needs to be ahead of everything anyway. It works out great and I don’t have to concentrate on getting it exact. Same goes for the Outro. You have time to figure in the lick for the end of the song. Works for me.
Sincerely, Fingerstylepicker.

Got the point. A little advice. Keep the Fills, Outros, and Intros all the same lengths and this will help to keep the timing right. The Outro’s can be as long as you want them to be but only after the correct timing is played first and then you can accentuate the great ending. This helps keep everything together and you don’t have to think about. You’ll have enough to do just playing the song.
Sincerely, Fingerstylepicker.