Difficulty connecting BeatBuddy to Infinity Looper

I just got the Infinity Looper and am having issues with the looper recognizing the BeatBuddy (i.e., there is no connection between the two). The looper isn’t flashing to the beat of the BeatBuddy once I start the BeatBuddy and let it run (I’ve tried letting it run for a while). I’ve read through A LOT of posts on this forum and elsewhere and have tried many things. Looking for help!

I believe the looper has the latest firmware as I tried to update it and when I rebooted the looper it didn’t show an “F”. When I looked on the SD Card in (I think) the recovery directory or something like that, it had the firmware file with a 218 at the end. When I boot up the looper it flashes 2 1 8. The only oddity is that the software on my MAC says 210 at the top. Is this a problem???

I also updated the BeatBuddy with 3.8 firmware. I changed Midi Out settings per some other posts, e.g., Sync Disabled.

They both appear to be using Midi channel 1.

I am using Singular’s Midi out Y cable to a regular midi cable into the looper.

I tried resetting the factory settings on the BeatBuddy as well. I can’t see how to reset factory settings on the looper - although I just got it and not sure how I could have messed anything up.

Any ideas? It is a shame there isn’t a video tutorial on how to do this as so many people have issues with it.

Thank you in advance!

Do you mean you set it to sync disabled?

If you haven’t already, you can try these settings provided by Uncle Tape a while back on your BeatBuddy (BB) pedal. Let us know if this helps.

  • BB MIDI-OUT Settings:
  • Output type: MIDI-OUT √
  • Channel: 1 √
  • Sync: Always On √
  • Start: Main Beat √
  • Stop: Pause and End √
  • Notes: Disabled √
  • Next Part: Enabled √
  • Time Signature: Enabled √

Thank you for the reply! Yes, these are all the settings on the BB.

Thx for the reply. Yes - it is set to Disabled.

Wait a second. You’re replying to my post that Sync is Always On but in the next post you said that Sync is Disable.

Not sure you can have Sync Always On and Disable at the same time. :thinking:

1 Like

Your Start sync should be set to Main Beat for the sync to start after the intro. If it’s disabled no signal will be sent to the looper.

Sorry about the confusion. I have actually tried both settings for Sync (Disabled and Always On) and neither worked to my dismay…

Yes - Start Sync is set to Main Beat.

Is it possible that I have a bad Singular Sound Adapter cable or a bad midi cable? Both were brand new. Is there a way to test them? Unfortunately I don’t have any other midi devices where I’m at. I do have a Kemper at another location…

One thing I noticed is that when I first tried to connect the midi cable to the Y cable I accidentally tried plugging it into the Midi In on the Y cable. The connection doesn’t go in all the way, which is kind of weird I thought. Then I noticed the issue and I plugged it into the Midi Out of the Y cable and it plugged in all the way. Both the ends of the Y cable are female and look identical. Not sure if it is relevant, but just something strange I noticed.

A MIDI cable should of plugged into either end. They are the same.

And yes, try it with another device if possible. I don’t know about the Infinity Looper but I gather that is set correctly to receive from the BB?

I will try another midi cable to see if there is a problem with that cable. A little hard to try another Y cable…I may contact Singular support to see if I can exchange if I can’t figure anything out as it is odd that the mid cable doesn’t plug the same way into the in vs. out of the Y cable.

I haven’t seen anything on the PIgtronix side that really had to be configured in all of the forums I looked at. I saw a few screenshots of the Pigtronix software and how it was set up for a particular user and I copied that just in case it mattered. But no luck.

I guess there is always the chance it is a bad midi port on either the looper or the BB as well…Unless I get any other tips that wind up working, I’ll try and connect the BB and Pigtronix to my Kemper to see if there is at least Midi being sent from the BB and received by the Pigtronix. Not sure how simple that will be, but will be a fun experiment at least :slight_smile:

Hmm…I’m still thinking it’s a setting causing the issue but not being familiar with the Pigtronix I couldn’t say. I run my BB into the Aeros and then into a HX Stomp and all 3 talk seamlessly. But try the BB out direct to the Kemper and see if it recognises the signal through MIDI first.

I tried various Pigtronix global and Blank/Preset settings and nothing is helping. I will give the Kemper a try tomorrow when I am with it if I can’t solve by then.

As a test to see if the Pigtronix is receiving any Midi information from the BB, I tried changing my BB midi channel to two. I then rebooted the looper while holding Stop Mode down. The LED flashes “C” “1” and stays there until I hit a button on the looper. I tried playing the BB while it was flashing but nothing happens on the looper. I assume the looper should change the “1” to a “2” shouldn’t it?

No. You would have to change the channel on the Pigtronix yourself. Another midi device (the BB) won’t be able to change it. If the BB is sending on channel 2 and your looper is receiving on channel 1, nothing should happen.

The way to test whether BB is sending is to connect it to another device on the same channel. If you only have 1 other midi device to test against, it will be hard to conclude whether either device is at fault. I suggest using a computer or iPad app and USB interface to see what is going on.

If you set your Main Pedal > Midi Settings > Midi-Out > Sync > Disable your Infinity will not display the flashing midi sync light in the bottom right of the Infinity (as it does when the BB is set to Sync > While Playing).

Are you relying solely on the Infinity flashing light as the indicator for whether MIDI sync is working or not? If you have, reset both pedal settings to default factory settings and play with the connected pedals to see if pressing the BB pedal starts to play your loop back in sync with the BB. Long time ago I got an email from Pigtronix stating that updating or reinstalling the firmware resets the Infinity to factory default settings.

It seems like you’re now just throwing stuff on the wall to see what sticks and I know you have to be frustrated. Other users have provided pretty good advice on troubleshooting which is no more than identifying what is the source of the problem.

You will have to isolate and identify whether or not each of the component parts of your rig work as designed. Those components are the

  • BeatBuddy (BB) pedal
  • Singular Sound MIDI Sync Adapter
  • MIDI patch cables
  • Infinity Looper

To add just a little more to what BlueSkyIS suggested, you can use the steps from https://noterepeat.com/articles/pc-troubleshooting/794-using-a-midi-monitor-to-test-a-midi-device to identify which part is working. Before you start, I’d again suggest you reset the default settings on both the BB and the Infinity.

When problems such as yours happen, I usually start troubleshooting the cables. Sometimes easier to swap the MIDI patch cables when you have a spare.

1 Like

Thanks for all the advice! I tried resetting defaults and no luck. Going to put on hold until I can test with my Kemper to see if it sees any output from the BB. If it does see output, then perhaps there is a problem with Pigtronix. I’ll probably return and ask for a new one unfortunately.

As users are reporting MIDI sync issues from their BeatBuddy (BB) pedal using firmware 3.9.0 to other loopers, you could try reverting to BB firmware version ≤3.8.0 and see if that helps.

So I finally had a chance to try both the BB and Looper with my Kemper. Here is what I found:

BB:

  • I can connect the BB Midi Out to the Kemper Midi In and the Kemper sees the midi clock. I can adjust the tempo on the BB and the Kemper adjusts. I can change BB Midi Out Sync to while playing, and the Kemper indicates it receives the midi signal when I start the BB. If I set Midi Out Sync to Always, then the Kemper recognizes it regardless of the BB state.

  • I then connected Kemper Midi Out to BB Midi In and I could control the BB temp through the Kemper’s tap tempo. I changed Midi In on the BB to be Channel #1 (as defaults is Omni) to make sure Kemper is transmitting on Midi Channel #1 (Kemper is Omni by default). Can still control BB through Kemper tp tempo.

Conclusion: the cables appear to be working!

Pigtronix:

  • I connect the Kemper Midi Out to the Looper and I don’t see anything flashing on the looper. I try to record a loop on #1 and the loop immediately stops recording. I get the same immediate stop if I try to record a loop on #2. Don’t know why this would be happening…

I haven’t figured out a way to reset factory settings on the Pigtronix. I tried putting them all back to what I thought was normal, but perhaps there is something else screwed up in it. Somebody mentioned updating the firmware, but I already have 3.8 and it doesn’t update firmware if I try and re-install the firmware.

Does a firmware update reset the factory settings? If there is no other way to reset factory settings, how can I get an older version of the firmware so I can go backwards and then forwards to the current firmware?

Other ideas based on what I found? I really appreciate it!