Eeprom invalid

got the MM today. updated BB to 3.8.
downloaded the MM app. opened it and it said I needed to update the firmware in the MM.
update look as if it went ok.
then got message on the app to update to default mode. said OK.
MM reset and now the top 3 displays say, “EEPROM INVALID”
can not coned by BT anymore to do a firmware update.
can it be done with midi cable? or is it a Brick?
Documentation on the MM is a joke. will be sending it back for a Full refund.

We had that for awhile with one of the betas. I would suggest waiting for the Maestro devs to chime in. They’ve been super helpful and responsive.

Hey there, sorry about this, it is because the MM requires you to update firmware, then the default modes, then the custom modes in that order. We are working on a streamlined updating process for this. We are also drafting the Manual for both the MM and the app, so that will be ready very soon, we agree our documenting is a little bare on it atm. If you are not able to fix the issue after doing this, or it seems more complicated, please contact for assistance. Thanks!

I will also notify @iajrz maybe he can find a specific resolve here

Hello @Hubert_Leigh !

Not a brick!

You need to follow a process similar to the Firmware update, where you press the Bluetooth button til the blue LED blinks, then open the left hand side menu, and press “Update Default Mode”. When that runs, you should have your device up and running.

Please, let me know as soon as you try.

We’re working on simplifying the update process so that this part is not necessary.

I know the “EEPROM INVALID” is scary. I’m sorry for the inconvenience – and really paying attention to this, do keep me in the loop please.

That was a Fix. Thought I had bricked my MM.
It’s up and working now with the BB


1 Like

Thank you for coming into the forums and bringing your issue to our attention.

As I said, and Brennan before me, we’re working on improving the update experience so that this kind of situation doesn’t happen anymore – and if it does happen, that it’s not as scary-looking anymore.

:heart: I hope you enjoy the MM as much as we enjoy making it the best MIDI controller ever.

will after working with the Midi Maestro for awhile, I was hoping to do a custom button setup.
I went through the app and set everything the way I wanted it to work. It was Not intuitive at all. (took quite some time).
and it would never upload to the MM. The app needs some serious going over. at this point in time there is no way to make custom setting. I was looking to get the AEROS to add with the MM and my BB. but in till the software is stable and works as promise I will be holding out.

Have you tried the latest beta? Everything is working great for me, and I have a custom mode running to control the tracks of the Aeros (running the latest beta for Aeros).

I think the only weird thing for people is that you must create and name midi commands separately from configuring the buttons. After you get that down, things start moving pretty fast.

Is there a step by step guide for this? I will admit I’m not the sharpest knife in the drawer. How do I creat the midi command. Then assign it to the button?

Hey there, we are working on documentation for this, if you’d like one on one definitely reach out to and they could help you out.

It would be a benefit, to see what the commands in the BB mode look like in the MM app.
even a text version. that was we could see if we were in putting things right. and maybe even duplicate the command on another button. I would like to move the start/stop to the bottom row. as well as other commands.

Is this a change from the e-mail address, or are both valid now?

Ok, just found out, if I am in BB mode I get a status in MIDI OX that the MM has powered on.
if in Custom mode I do not get any input to MIDI OX. would be nice to be able to do a Syex dump in to the MIDI OX. I do get input to MIDI OX in custom mode, if I have No Custom mode setting in the MM.

just FYI.

Hey there. I tried this fix and get a message that says “error writing characteristic” and then stops. Im stuck on Eeprom invalid. Is there a way to do a factory reset?

I did it the way suggested.

  1. turn on the MM press blue tooth button till blue light is on.
  2. open app on your device
  3. select Update Firmware, let it do it’s thing.
  4. turn off MM, then back on.
  5. repeate step 1.
  6. select Update Default Modes. let it do it’s thing.
  7. restart MM. all should be back to factory settings.

Thanks for this but unfortunately it didn’t work. I’ve been going back and forth with support and hopefully they can help

This is an error we don’t often encounter. Sometimes it’s happened when we move the phone is too far from the MM, or when we have eg: changed apps while the process is ongoing. Arguably it could also happen if you have a lot of wireless spectrum interference.

well, I think we might have a case for that situation on iOS also :slight_smile:

I’ve tried all these steps on alpha iOS app, yet i’m stuck on EEPROM INVALID message.

It looks like it can connect to the app so all hope is not lost :))

Hey – a few people have had issues with the Alpha. I’ll make time this week to work things through with every one of you one way or the other. This will be a good time to exercise our support setup, too, so we’ll try it that way.

More on this later Today.

1 Like