Eeprom invalid

Please, confirm that you tried updating the Default Modes (and saw the light stop blinking, then resume blinking at the end).

I confirm that I’ve tried updating default modes, the light stopped blinking, then BLE connected appeared on the display. Soon the text was replaced by EEPROM invalid with no lights blinking again.

If it helps, I can make a video

Same problem for me.

I tried updating my maestro. I’m getting the eeprom invalid message.

Probably because I tried to update the default mode first.

NoW I connect to Bluetooth and irrespective whether I try to update firmware or default mode Maestro is terminating the Bluetooth connection and giving me the eeprom error message.

Suggestions?

Well just got into the betas , updating the firmware … eeprom stuff coming … midi maestro out of order … sorry to say but looks like a joke … there should be a turn on button push to reset to factory … gig on Friday I m so happy …

A week has passed already. Any news? I’m not in a hurry to reconvert my beautiful door stopper, after all I’ve waited patiently for almost 2 years now. :slight_smile:

Thanks for the new firmware , it works could get back to factory base setup :wink: :metal:t2:
Be aware that sending custom button gets you back the eeprom invalid.
Cheers

Hey did you update the default modes first? Always do firmware > Default Modes> custom mode in that order, we will eventually streamline this process in a later version, for now it is best to do so. Let me know if you still have this issue after doing so, thank you.

Having the same problem here.

Are you using the Android or iOS version?

iOS

Did you do it in order, firmware> default modes> custom mode? If so make sure you are letting the FW update finish, it is a known bug that if your phone closes mid update it will stop the firmware upload.

Also please check on your testflight app that you have the latest version of the alpha app.

Ah, now it looks like it works! :slight_smile:

Showing: “Sending xx%”

Finally succesful. Thanks!

1 Like

Glad to read that you got it working. For other iOS users running into the same issue, here’s a little more detail and what to do if the first step fails.

Before you try to update the MM app, you need to temporarily change your iPad screen so that it does not time out. Go to Settings - Display & Brightness - Auto-Lock and set to Never.
Also, don’t try to perform any other task on your iPad such as check e-mail or reply to a text; don’t try to perform any task within the MM app during the updates.

I was able to restore the app and complete the update. Here’s how I suggest you try to restore your MIDI Maestro. This is the first step and it follows what Brennan mentions but with a little more detail:

  • make sure you have the current Test Flight app updated on your iPad
  • power off your Maestro pedal for 30 seconds and then power it back on
  • press the Pairing button on the back of the pedal; the light should start to flash
  • launch the MM app
  • press the hamburger button in the upper left
  • select Update Firmware (you’ll know it’s the latest version if there’s a percentage display); let it complete and the blue light changes from either goes solid or stops blinking
  • wait at least 30 seconds once the percentage display disappears
  • you may still have EEPROM INVALID displayed—if so, don’t worry, proceed to
  • use the MM app to select Update Default Modes
  • the blue light will probably stay solid blue and there’s not feedback so let it run for 15-20 minutes—the blue light will stay solid
  • power down the MM pedal; let it set for 30 seconds
  • power the MM pedal on
  • does the Custom Mode screen now appear on the pedal display and does v1.1.4 show in the bottom left panel of the pedal display?
  • you should be good. NOTE: since I don’t have any Custom stuff yet, I did not follow that step as Brennan suggested.

So what to do if the EEPROM INVALID is still showing? This second step is a little more complicated but you should still be able to recover your pedal.

  • Searched my e-mail inbox for messages with Test Flight and went to the first message and used the link to get to the iOS 1.0a version in the App Store; installed it (it replaced the current version on my iPhone with the older version
  • I powered the MM pedal on and let it sit for a couple of minutes with the EEPROM INVALID screen.

I then pretty much followed the same general process as above:

  • Updated the Firmware; after 10-11 minutes, BLE light went out; EEPROM INVALID screen remained. NOTE: you will not see the percentage countdown displayed with the older Test Flight version.
  • Updated the Default Modes; BLE light never went out; after 10 minutes, I powered the MM down; I let it rest for a couple of minutes.
  • Powered it back up and the screens displayed correctly. At this point I was so happy that I forgot to check the firmware version :grinning: But wait, you’ve got some more to do:

Update app and firmware to the latest version from 1.0.7a

  • I went back to my e-mail and got the link to the 2d iOS Test Flight notification and installed the app.
  • Followed the general steps above for updating the Firmware and Default Modes.
  • The firmware update displayed the percentage time but it took about 10 minutes to complete—the blue light went out;
  • Updated the Default Modes and let the process run for 10 minutes—the BLE light never went out again so I again powered the MM down and quit the MM app.
  • Upon powering the MM on, the version displays v1.1.4

Don’t forget to restore your iOS Display & Brightness settings.

2 Likes

This was a life saver. I was freaking out a little bit. All good now. Thank you for the clear instructions @persist!

3 Likes

How about if all you get is “Reached Timeout For Scan” no matter what you do? (in Android as I STILL have not go the beta link for Testflight - and I have asked!)

Hey, I invited you a bit earlier. Check your e-mail.

It’s weird that you’re getting “Reached Timeout for Scan” no matter what you do. Please test with your iOS device and let us know how it goes. I am looking at this – if you reply to me I will also get an email.

:slight_smile:

Cooly, thanks - got the message. About to launch into the Testflight version soon :slight_smile:

Stuck on Eprom Invalid - followed the procedure above and still eprom invalid. I don’t have a link to any previous versions, so at this stage my MM is bricked!

Tried an experiment and turned on the MM while holding down both bluetooth and mode buttons…got the display back, it shows version 1.1.5 (which I assume is latest?) do we might be good to go again…

1 Like