Eeprom invalid

Yes indeed 1.1.5 is latest, glad things are moving along

I’m having the same issue here, fumbling thru this with no documentation is no bueno lol.
Running Android app v5 (latest), trying to update MM from 1.1.4 to 1.1.5 (latest). App connects, when I select update I get a progress window but the bar never moves. I’ve been doing this now for about 5 hours and I always give it 20-30 min but nada and after rebooting the MM now I have the EEPROM INVALID display. Also tried the update default process and the same thing, starts but never does anything or shows any progress. Is there any hope, or should I just box it up and go back to my Boomerang rig?

Hello everyone, I also have problem with eeprom. Used MM with BB all summer gigging without problem.
A few weeks ago - Eeprom. Tried everything except what Persist included as solution.
Did this dozens of times:
turn on the MM press blue tooth button till blue light is on.
open app on your device
select Update Firmware, let it do it’s thing.
turn off MM, then back on.
repeate step 1.
select Update Default Modes. let it do it’s thing.
restart MM. all should be back to factory settings.

I don’t understand this error, and really dont understand from above posts where problem really is.

Especially dont understand why I have to turn off MM, wait 10 min then turn on, update again, wait for 20-30 min, then let it sit for awhile, then turn it on again. It sounds like cooking recipe for some Indian complex specialty. :slight_smile: .
We are talking about 21st century piece of equipment, not Commodore 64 with cassette tape player, for which, by the way I waited 2 min to load the game and it worked!!!
And with MM I rebooted it dozen of times following the procedure and: Eeprom invalid!!!

When there will be some constructive universal solution? I would really want to solve this unnecessary problem easily not by spending hours waiting for MM to cool down after updating anything.

try this - turn on the MM while holding down the bluetooth and mode buttons at the same time…when I got eeprom message I did that and got the display back.

Thank you I already tried that and also every combination: solo bluetooth - turn on, solo mode - turn on etc. Nothing works. I will try above methods a few more times. Although I am not sure if something I tried 10 times and don’t work will work eleventh.
Please is there any other way?

Maybe your 11th time will do the trick :thinking: :. You don’t say whether you’re using the Android or iOS app however, try this.

  • Delete the app from your device
  • Redownload the app and install
  • Power on to the MIDI Maestro
  • Launch the app
  • Get the MM blue light flashing
  • Update the firmware
  • When complete and if the blue light stops flashing, get the blue light flashing again
  • Update the Default Modes
  • When I update the Default Modes, the blue light stays steady blue and I turn the MM off and after 10-30 seconds, I turn the MM back on. I usually get the proper display and I’m in business
  • If I don’t get the display indicating that the pedal is operational, I press the Mode button on the back of the pedal and that’s when it displays properly
  • If this doesn’t work, try pressing both the BT and the Mode button at the same time and release
  • If this still doesn’t work, contact both @iajrz and @BeatBuddy_Support for help

Please let us know however you get it working again as it might help another user having similar problems.

1 Like

Thanks persist, you just thought me how to be persistant, :slight_smile: although it was twelfth time.
Eleventh I just updated application. So i guess its important to do step two correctly.
And in step 9 after updating Default modes, blue light wasn’t steady but blinking but anyway worked.
Thank you very much for everything.

3 Likes

My experience.
MM out of the box, update via mobile application.
Connect via BT, press Update Firmware, transmission is 100%.
Connection is terminated, blue light goes out, result - Invalid EEPROM.
Then connect via BT, press Update Default Mode, transmission is 100%, blue light stays on.
Then press Update Firmware, transmit 100%.
Success.

Just got this now. I was able to update my firmware to 1.6 yesterday but when I tried updating Default modes, my Samsung dropped the connection midway.

Did you try once more?

Yeah everything was working fine until yesterday…when it just decided to quit working. No error messages. It just doesn’t respond. Tried hooking it up with just my BB…no go…tried with just the Aeros…no go. My MIDI cables are fine as my BB to Aeros sync perfectly so it’s definitely the MM.

Please contact support@singularsound.com, there may be another issue, they may be best equipped to assist.

New User Update to EEPROM INVALID error code

History so far:

BB new about 2 weeks ago. also have footswitch + so using BB on a mic stand tray. Basically I needed 3 buttons: Start, Pause and Outro. More would be a bonus but, one step at a time.

MM received yesterday. Updated firmware and default modes per user manual. Did reboot as directed in manual. Did a bit of programing via IOS app. Sure would be nice to be able to make a toggle button that works for pause. An alternative would be: redirect to page 2 with that button being an un-pause and redirect to page one but haven’t been able to make that happen.

Started practice with my group and saw EEPROM INVALID message. Finished practice w/o BB. Found this conversation on forum and was able to restart MM by just updating the default mode. I don’t know if this will remain stable or be something that I will have to do during a gig…OUCH!

Constructive Criticism:

  1. Manual is out of date. Doesn’t have current firmware number and I downloaded it yesterday. Any firmware updates numbers should be pushed to the user group (don’t make us pull/search for them) and reflected in the manual. It shouldn’t be hard to have the app issue a notification of any messages SS want’s to get out as long as the app owners enable notifications. Error messages and fixes should be in the manual as well as in forum post.

  2. Stability issues day one don’t bode well.

  3. Theses issues should be front and center in the user manual, an package insert and forum pages.

  4. IOS bugs in app need to be fixed to allow full functionality of MM.

I hope this fit guidelines. It fit my online publishing guidelines of: True, Necessary and Kind.

All the best,

Dr. G.

1 Like

iOS 1.4.1 is now out and working functionally, thank you for all your feedback

An updated manual is coming soon!

Hello. Just received MM, and got this “eeprom invalid” problem with official firmware, still, in 2022.
I managed to fix it with steps from this thread, but this is not exactly a good first impression.
This feedback is merely so that others might not have to experience this frustration and confusion in the future.
Change the message at least, add some more instructions or something, “eeprom invalid” immediately makes one fear the unit is bricked.

Peace

I had this problem when setting mine up today.

Im using an android. It tells me the firmware is updated, but it wont let me update default modes saying 'error writing characteristic".

Changed over to my iPad and reran everything as per xel’s solution post

Please write to support@singularsound.com for further assistance.