Eeprom invalid

Are you using the Android or iOS version?


Did you do it in order, firmware> default modes> custom mode? If so make sure you are letting the FW update finish, it is a known bug that if your phone closes mid update it will stop the firmware upload.

Also please check on your testflight app that you have the latest version of the alpha app.

Ah, now it looks like it works! :slight_smile:

Showing: “Sending xx%”

Finally succesful. Thanks!

1 Like

Glad to read that you got it working. For other iOS users running into the same issue, here’s a little more detail and what to do if the first step fails.

Before you try to update the MM app, you need to temporarily change your iPad screen so that it does not time out. Go to Settings - Display & Brightness - Auto-Lock and set to Never.
Also, don’t try to perform any other task on your iPad such as check e-mail or reply to a text; don’t try to perform any task within the MM app during the updates.

I was able to restore the app and complete the update. Here’s how I suggest you try to restore your MIDI Maestro. This is the first step and it follows what Brennan mentions but with a little more detail:

  • make sure you have the current Test Flight app updated on your iPad
  • power off your Maestro pedal for 30 seconds and then power it back on
  • press the Pairing button on the back of the pedal; the light should start to flash
  • launch the MM app
  • press the hamburger button in the upper left
  • select Update Firmware (you’ll know it’s the latest version if there’s a percentage display); let it complete and the blue light changes from either goes solid or stops blinking
  • wait at least 30 seconds once the percentage display disappears
  • you may still have EEPROM INVALID displayed—if so, don’t worry, proceed to
  • use the MM app to select Update Default Modes
  • the blue light will probably stay solid blue and there’s not feedback so let it run for 15-20 minutes—the blue light will stay solid
  • power down the MM pedal; let it set for 30 seconds
  • power the MM pedal on
  • does the Custom Mode screen now appear on the pedal display and does v1.1.4 show in the bottom left panel of the pedal display?
  • you should be good. NOTE: since I don’t have any Custom stuff yet, I did not follow that step as Brennan suggested.

So what to do if the EEPROM INVALID is still showing? This second step is a little more complicated but you should still be able to recover your pedal.

  • Searched my e-mail inbox for messages with Test Flight and went to the first message and used the link to get to the iOS 1.0a version in the App Store; installed it (it replaced the current version on my iPhone with the older version
  • I powered the MM pedal on and let it sit for a couple of minutes with the EEPROM INVALID screen.

I then pretty much followed the same general process as above:

  • Updated the Firmware; after 10-11 minutes, BLE light went out; EEPROM INVALID screen remained. NOTE: you will not see the percentage countdown displayed with the older Test Flight version.
  • Updated the Default Modes; BLE light never went out; after 10 minutes, I powered the MM down; I let it rest for a couple of minutes.
  • Powered it back up and the screens displayed correctly. At this point I was so happy that I forgot to check the firmware version :grinning: But wait, you’ve got some more to do:

Update app and firmware to the latest version from 1.0.7a

  • I went back to my e-mail and got the link to the 2d iOS Test Flight notification and installed the app.
  • Followed the general steps above for updating the Firmware and Default Modes.
  • The firmware update displayed the percentage time but it took about 10 minutes to complete—the blue light went out;
  • Updated the Default Modes and let the process run for 10 minutes—the BLE light never went out again so I again powered the MM down and quit the MM app.
  • Upon powering the MM on, the version displays v1.1.4

Don’t forget to restore your iOS Display & Brightness settings.


This was a life saver. I was freaking out a little bit. All good now. Thank you for the clear instructions @persist!


How about if all you get is “Reached Timeout For Scan” no matter what you do? (in Android as I STILL have not go the beta link for Testflight - and I have asked!)

Hey, I invited you a bit earlier. Check your e-mail.

It’s weird that you’re getting “Reached Timeout for Scan” no matter what you do. Please test with your iOS device and let us know how it goes. I am looking at this – if you reply to me I will also get an email.


Cooly, thanks - got the message. About to launch into the Testflight version soon :slight_smile:

Stuck on Eprom Invalid - followed the procedure above and still eprom invalid. I don’t have a link to any previous versions, so at this stage my MM is bricked!

Tried an experiment and turned on the MM while holding down both bluetooth and mode buttons…got the display back, it shows version 1.1.5 (which I assume is latest?) do we might be good to go again…

1 Like

Yes indeed 1.1.5 is latest, glad things are moving along

I’m having the same issue here, fumbling thru this with no documentation is no bueno lol.
Running Android app v5 (latest), trying to update MM from 1.1.4 to 1.1.5 (latest). App connects, when I select update I get a progress window but the bar never moves. I’ve been doing this now for about 5 hours and I always give it 20-30 min but nada and after rebooting the MM now I have the EEPROM INVALID display. Also tried the update default process and the same thing, starts but never does anything or shows any progress. Is there any hope, or should I just box it up and go back to my Boomerang rig?

Hello everyone, I also have problem with eeprom. Used MM with BB all summer gigging without problem.
A few weeks ago - Eeprom. Tried everything except what Persist included as solution.
Did this dozens of times:
turn on the MM press blue tooth button till blue light is on.
open app on your device
select Update Firmware, let it do it’s thing.
turn off MM, then back on.
repeate step 1.
select Update Default Modes. let it do it’s thing.
restart MM. all should be back to factory settings.

I don’t understand this error, and really dont understand from above posts where problem really is.

Especially dont understand why I have to turn off MM, wait 10 min then turn on, update again, wait for 20-30 min, then let it sit for awhile, then turn it on again. It sounds like cooking recipe for some Indian complex specialty. :slight_smile: .
We are talking about 21st century piece of equipment, not Commodore 64 with cassette tape player, for which, by the way I waited 2 min to load the game and it worked!!!
And with MM I rebooted it dozen of times following the procedure and: Eeprom invalid!!!

When there will be some constructive universal solution? I would really want to solve this unnecessary problem easily not by spending hours waiting for MM to cool down after updating anything.

try this - turn on the MM while holding down the bluetooth and mode buttons at the same time…when I got eeprom message I did that and got the display back.

Thank you I already tried that and also every combination: solo bluetooth - turn on, solo mode - turn on etc. Nothing works. I will try above methods a few more times. Although I am not sure if something I tried 10 times and don’t work will work eleventh.
Please is there any other way?

Maybe your 11th time will do the trick :thinking: :. You don’t say whether you’re using the Android or iOS app however, try this.

  • Delete the app from your device
  • Redownload the app and install
  • Power on to the MIDI Maestro
  • Launch the app
  • Get the MM blue light flashing
  • Update the firmware
  • When complete and if the blue light stops flashing, get the blue light flashing again
  • Update the Default Modes
  • When I update the Default Modes, the blue light stays steady blue and I turn the MM off and after 10-30 seconds, I turn the MM back on. I usually get the proper display and I’m in business
  • If I don’t get the display indicating that the pedal is operational, I press the Mode button on the back of the pedal and that’s when it displays properly
  • If this doesn’t work, try pressing both the BT and the Mode button at the same time and release
  • If this still doesn’t work, contact both @iajrz and @BeatBuddy_Support for help

Please let us know however you get it working again as it might help another user having similar problems.

1 Like

Thanks persist, you just thought me how to be persistant, :slight_smile: although it was twelfth time.
Eleventh I just updated application. So i guess its important to do step two correctly.
And in step 9 after updating Default modes, blue light wasn’t steady but blinking but anyway worked.
Thank you very much for everything.


My experience.
MM out of the box, update via mobile application.
Connect via BT, press Update Firmware, transmission is 100%.
Connection is terminated, blue light goes out, result - Invalid EEPROM.
Then connect via BT, press Update Default Mode, transmission is 100%, blue light stays on.
Then press Update Firmware, transmit 100%.