Getting the BeatBuddy to work with the Infinity looper

Thanks for sharing what you did to get it working.

Today I still decided to send the device back because it is just too complicated for me to realize everything that I did with the dittox4 via midi. I also think that the device, if controlled by midi, does not work reliably enough. I will continue to work with my dittox4, hoping to find a stereo looper that is midi-friendly and just syncs cleanly.
Nevertheless many thanks for the competent help in this forum.

@persist As you have been so helpful helping folks with the Infinity Looper sync issues, I am gonna check and see if you or another BB expert are able to assist me with my issue. Just got my BB and Infinity about one week ago. Updated the firmware on both of them (BB = 3.8.0 / Infinity = 218). The looper by itself is fantastic and works with no issues, however when I connect it to the BB via MIDI, I get nothing but frustrating results. I have recorded a YouTube video (here BeatBuddy and Infinity Looper Sync Issues ) . Please let me know if you have any insight on this issue that you can think of or if you need any further information from me. Thank you very much!!

I checked out your video (thanks for sharing) and what I hear is that you record a loop at one pitch and when you play the loop back, it plays in a different pitch. Is this the problem you’re trying to address? If so, this is what has worked for me as well as other users:

  1. Pigtronix suggested trying any one of the options below to improve the functionality of these two devices:
  • Turn off MIDI clock out on Beat Buddy. If you don’t want pitch change but you do want to trigger the START and STOP for the looper, BeatBuddy needs to stop sending MIDI clock and should only send MIDI start/stop commands in order to avoid pitch change in the Infinity. If you need BeatBuddy to send midi clock, then this is not your options (try one of the other 2 options).
    On the BeatBuddy pedal:
    – press Drum Set and Tempo to enter the settings menu
    – scroll to and select Main Pedal
    – scroll to and select MIDI Messages
    – select MIDI-OUT
    – scroll to and select Sync
    – change to Disable and back out of the settings
  • Using the Infinity app, you can actually set the Infinity to ignore incoming MIDI clock. Similar to above but done from the Infinity looper side.
  • Using the Infinity app, tell the looper exactly how many bars long the loop is. This can be done after a loop is uploaded or recorded. This way, the looper knows whats going on and does not try to correct/compensate for the incoming MIDI clock.
    In the Infinity application, enter the number of measures in loop 1 for the affected loops. There is a list on the left hand side displaying all the presets on the looper, whether they be filled or empty. When selecting a preset from the list, the user is able to change any of the given settings for that preset. The option to write in the measures is right below Split mode, between Arm Mode and MIDI Time Signature. If that does not solve the pitch issue, there are probably incoming MIDI notes to the Infinity (which can be disabled from either device) triggering the Varispeed function of the looper, which will cause the change in pitch.

@persist thank you for the prompt reply. Before bugging anyone with my issue I made sure to read every single post on this threat, so I became familiar with your suggested solutions.

Option 1 and 2 are not ideal for me. The reason I bought the infinity was the Mind Sync as Pigtronix claim that they “worked with singular sound to seamlessly integrate the BB and ILlnfinity”. There are other affordable loopers out there that take start/stop.
I will try option 3 today just to rule it out. However, if I need to use a computer to connect the looper via USB and use the app to update the time signature every time I use the looper with a different tempo, it sure defeats the purpose of having a stomp box style looper. In which case I am better of returning the two units and using software for both drums and looping.

But seeing that so many others have successfully made it work. I really want to make pedals to work for me. Thank you again for your response. Are there any other suggestions that you or others on the forum have?

@persist , thanks again for your support here. I have been tweaking these two pedals for several hours a day still to try to get them to work and I found a way (not a setting) which though it does not work for live gigs, allows me to synchronize them.

If I let the BB go through all measures of a song part once and engage the recording of the infinity in the middle of the last measure, I am able to sync every time. Does this tell you something in terms of what setting I could change to make it sync after the intro as it is intended?

I recorded a few loops and was able to go back to them and it is all in sync! But unfortunately I can’t have the crowd waiting for the whole song part to finish before I start looping. Any guidance would be greatly appreciated.


Hmmm. I’ve found that the looper usually settles in to the tempo of the BeatBuddy within 3-4 seconds of loading a song or beat.

Right now I’m experimenting with the Aeros and have loaned my Infinity out. I’ll get it back later on this week and hook the Infinity back up to time it.

Thank you @persist!

I have my Infinity back this afternoon and did some testing using the default multi-part beats that come with the BeatBuddy (BB). I’m using the same firmware versions as you on both pedals. When I select the song and almost as soon as it has loaded, the BB will begin to show the tempo scroll and within one bar, the Infinity light is flashing in tempo with the BB. Once the flashes on both pedals are in sync, I record my loop, stop it and then play it again and they remain in sync and in pitch. You shouldn’t have to let the entire beat play to get your looper to stay in sync and pitch.

I then tested a one-press song and it takes 2-3 bars scrolling on the BB to get the Infinity light to flash in sync.

Not sure what else to suggest other than to ask what settings you have on the MIDI-OUT for your BB and what are the settings on your Infinity. If it’s easier to take screen shots from your Infinity app, that might be helpful.

@persist, thank you so much for your support with this. Here is information you have requested:
BB MIDI-OUT Settings:
Output type: MIDI-OUT
Channel: 1
Sync: Always On
Start: Main Beat
Stop: Pause and End
Notes: Disabled
Next Part: Enabled

Time Signature: Enabled

Thank you for providing the screen shots and BeatBuddy (BB) MIDI-Out settings. Here’s a comparison of our settings:
The BeatBuddy (BB) MIDI-Out matches but there are a couple of differences in our Infinity app Main settings.

Shoot! @persist I have just saw this reply! Apologies for the delay. Will try this out this weekend! Thank you much!

John_Strobel pointed out “The issue IMO is that there is a bug in how the Infinity Looper treats the STOP when synced to MIDI vs. when it is not. It behaves as you expect when not synced, i.e. you are recording a loop and hit STOP because you want to end the loop without playing it. Then when you play the loop, pitch is normal. That is NOT what happens when you sync to midi AND (here’s the important part) the stop mode is set to TRAIL. In this case, I don’t know what Pigtronix thought anyone would use this for, but it’s worse than useless, which is why I think it is a bug. What you have to do is set “stop mode” to FULL; then it will behave as you want it to. it’s also a good idea to disable the clock from the BeatBuddy when it is stopped so that you can use the looper for songs that you want to loop on without the BB.
To recap:
Using MIDI sync: set “stop mode” on Infinity to FULL.
Not using MIDI sync: use any stop mode you need.”

1 Like

Hello, you want the infinity stop the loop on Outro and triple tap stop?

1 Like

Please post In English so that all forum users can understand and possibly help you. Thank you.

I just purchased the Pigtronix Infinity looper because people have said it synchs the tempo/loop really well to the BB, however, it’s not synching. I have the midi cords hooked up, BB and Infinity firmware updated (it says software 2.11000 while loading the Pigtronix application), and I believe the midi BB settings correct. I’ve read many posts on this but still cannot get them to synch. Not only does it not synch, but the start and stop commands from the BB do not do anything to the looper either. It’s like they are not even connected / talking to each other. Any suggestions?

Check in the settings of the Inifnity . And check like this pic. look at the Midi channel (on the left)!When ready, close the application, EJECT the usb with windows (don’t remove it). Power OFF the looper, remove the USB from the looper and PC.Reboot your looper. Go to Beatbuddy now, In the settings of the BB go to MAIN PEDAL>MIDI SETTINGS>MIDI OUT> Output Type= OUT> Channel (the same as the looper)> SYNC =Always ON> STOP=Pause & End> NOTES=Enable>Time signature=Enable. Now you have 2 way to stop the looper with Beatbuddy If you want to stop the looper when the BB is PAused or let the looper play when Beatbuddy is Paused, depend what you like to choose this go to BB settings>MUTE PAUSE >ENABLE= looper stay playing when BB is paused. DISABLE= Looper stop when BB is paused. AND don’t forget to put the midi cable into the OUT of the BB midi cable

I have matched the settings you provided and the looper is now producing a bad sound during playback. It sounds like it’s fighting for power / dying and kind of metallic. It also randomly stops the looper now (maybe after a measure or two?). I isolated the setting on the BeatBuddy which is causing this: Enabling midi notes. When I select disable midi notes, it does not cause the bad noise, but is still out of synch. I even tried two different 18V power supplies, but it seems to be the BeatBuddy enabling midi notes. I guess they are talking to each now, just not in a good way. Any further advice?

Is this a brand new Looper?
Are the midi cables ok?
Firmware updated? last one is 2.1.8.
You can try replace your microSD card inside the looper, but there is a way to do that
check here is easy to do, just take care for the little metal plate cover up the sd card, you need to slide this plate first, don’t try to remove the Sd card, FIRST unlock the metal cover

1 Like

I reached out to Pigtronix and they thought it was a bad midi resistor in the looper. I sent it to them to have the resistor replaced and it has worked great since it’s return. Pigtronix’s customer service was very helpful and responsive throughout the process.

1 Like