Difficulty connecting BeatBuddy to Infinity Looper

Is it possible that I have a bad Singular Sound Adapter cable or a bad midi cable? Both were brand new. Is there a way to test them? Unfortunately I don’t have any other midi devices where I’m at. I do have a Kemper at another location…

One thing I noticed is that when I first tried to connect the midi cable to the Y cable I accidentally tried plugging it into the Midi In on the Y cable. The connection doesn’t go in all the way, which is kind of weird I thought. Then I noticed the issue and I plugged it into the Midi Out of the Y cable and it plugged in all the way. Both the ends of the Y cable are female and look identical. Not sure if it is relevant, but just something strange I noticed.

A MIDI cable should of plugged into either end. They are the same.

And yes, try it with another device if possible. I don’t know about the Infinity Looper but I gather that is set correctly to receive from the BB?

I will try another midi cable to see if there is a problem with that cable. A little hard to try another Y cable…I may contact Singular support to see if I can exchange if I can’t figure anything out as it is odd that the mid cable doesn’t plug the same way into the in vs. out of the Y cable.

I haven’t seen anything on the PIgtronix side that really had to be configured in all of the forums I looked at. I saw a few screenshots of the Pigtronix software and how it was set up for a particular user and I copied that just in case it mattered. But no luck.

I guess there is always the chance it is a bad midi port on either the looper or the BB as well…Unless I get any other tips that wind up working, I’ll try and connect the BB and Pigtronix to my Kemper to see if there is at least Midi being sent from the BB and received by the Pigtronix. Not sure how simple that will be, but will be a fun experiment at least :slight_smile:

Hmm…I’m still thinking it’s a setting causing the issue but not being familiar with the Pigtronix I couldn’t say. I run my BB into the Aeros and then into a HX Stomp and all 3 talk seamlessly. But try the BB out direct to the Kemper and see if it recognises the signal through MIDI first.

I tried various Pigtronix global and Blank/Preset settings and nothing is helping. I will give the Kemper a try tomorrow when I am with it if I can’t solve by then.

As a test to see if the Pigtronix is receiving any Midi information from the BB, I tried changing my BB midi channel to two. I then rebooted the looper while holding Stop Mode down. The LED flashes “C” “1” and stays there until I hit a button on the looper. I tried playing the BB while it was flashing but nothing happens on the looper. I assume the looper should change the “1” to a “2” shouldn’t it?

No. You would have to change the channel on the Pigtronix yourself. Another midi device (the BB) won’t be able to change it. If the BB is sending on channel 2 and your looper is receiving on channel 1, nothing should happen.

The way to test whether BB is sending is to connect it to another device on the same channel. If you only have 1 other midi device to test against, it will be hard to conclude whether either device is at fault. I suggest using a computer or iPad app and USB interface to see what is going on.

If you set your Main Pedal > Midi Settings > Midi-Out > Sync > Disable your Infinity will not display the flashing midi sync light in the bottom right of the Infinity (as it does when the BB is set to Sync > While Playing).

Are you relying solely on the Infinity flashing light as the indicator for whether MIDI sync is working or not? If you have, reset both pedal settings to default factory settings and play with the connected pedals to see if pressing the BB pedal starts to play your loop back in sync with the BB. Long time ago I got an email from Pigtronix stating that updating or reinstalling the firmware resets the Infinity to factory default settings.

It seems like you’re now just throwing stuff on the wall to see what sticks and I know you have to be frustrated. Other users have provided pretty good advice on troubleshooting which is no more than identifying what is the source of the problem.

You will have to isolate and identify whether or not each of the component parts of your rig work as designed. Those components are the

  • BeatBuddy (BB) pedal
  • Singular Sound MIDI Sync Adapter
  • MIDI patch cables
  • Infinity Looper

To add just a little more to what BlueSkyIS suggested, you can use the steps from https://noterepeat.com/articles/pc-troubleshooting/794-using-a-midi-monitor-to-test-a-midi-device to identify which part is working. Before you start, I’d again suggest you reset the default settings on both the BB and the Infinity.

When problems such as yours happen, I usually start troubleshooting the cables. Sometimes easier to swap the MIDI patch cables when you have a spare.

1 Like

Thanks for all the advice! I tried resetting defaults and no luck. Going to put on hold until I can test with my Kemper to see if it sees any output from the BB. If it does see output, then perhaps there is a problem with Pigtronix. I’ll probably return and ask for a new one unfortunately.

As users are reporting MIDI sync issues from their BeatBuddy (BB) pedal using firmware 3.9.0 to other loopers, you could try reverting to BB firmware version ≤3.8.0 and see if that helps.

So I finally had a chance to try both the BB and Looper with my Kemper. Here is what I found:


  • I can connect the BB Midi Out to the Kemper Midi In and the Kemper sees the midi clock. I can adjust the tempo on the BB and the Kemper adjusts. I can change BB Midi Out Sync to while playing, and the Kemper indicates it receives the midi signal when I start the BB. If I set Midi Out Sync to Always, then the Kemper recognizes it regardless of the BB state.

  • I then connected Kemper Midi Out to BB Midi In and I could control the BB temp through the Kemper’s tap tempo. I changed Midi In on the BB to be Channel #1 (as defaults is Omni) to make sure Kemper is transmitting on Midi Channel #1 (Kemper is Omni by default). Can still control BB through Kemper tp tempo.

Conclusion: the cables appear to be working!


  • I connect the Kemper Midi Out to the Looper and I don’t see anything flashing on the looper. I try to record a loop on #1 and the loop immediately stops recording. I get the same immediate stop if I try to record a loop on #2. Don’t know why this would be happening…

I haven’t figured out a way to reset factory settings on the Pigtronix. I tried putting them all back to what I thought was normal, but perhaps there is something else screwed up in it. Somebody mentioned updating the firmware, but I already have 3.8 and it doesn’t update firmware if I try and re-install the firmware.

Does a firmware update reset the factory settings? If there is no other way to reset factory settings, how can I get an older version of the firmware so I can go backwards and then forwards to the current firmware?

Other ideas based on what I found? I really appreciate it!

Thank you for the warning! I thought about updating to 3.9, but I noticed there were some problems so I thought better of it as I’m having enough problems of my own right now :slight_smile:

One thing I noticed on my Mac software is that in Global Settings there is no “Midi Sync” box to toggle.

In this post, it appears that “Ignore Midi Clock” should be in Global Settings. Not sure if it is on the PC but not Mac version. I’m wondering if somehow this got turned on…

Maybe this will help:

if BeatBuddy
Sync: Always On

then Infinity
Stop Mode: FULL

if BeatBuddy
Sync: Disable

then Infinity
Stop Mode: any setting

Tried and no luck unfortunately…but thank you for the suggestion.

Spoke to Pigtronix today and they said I should send to them to fix, which they said should be simple. They already sent me a return label. Great support. They have discontinued the Looper and the Looper 3 should be coming out in the Fall. I’m still under warranty fortunately.

1 Like

Glad to hear they’re taking care of you.

Hi jim001,

Do you mind sharing the contact information for how you got in touch with Pigtronix?

I purchased a BeatBuddy and Infinity Looper a few weeks back and have been pulling my hair out trying almost everything you are describing to the same result and it appears I also have a faulty looper.

Would love to get in touch with them to resolve this issue.

Thanks in advance!

The loops I record with my BB and Infinity eventually become off-synch too. I have the midi cords hooked up and both pedals firmware updated (Infinity says software 2.110000 while loading the application and flashes 218 while powering on the pedal). I think the settings on both pedals are setup correctly. The Infinity doesn’t start or stop with the BeatBuddy either so it’s like they are not even connected / talking with each other. Sounds like the same boat as you. What did Pigtronix repair on your pedal?

Check in the settings of the Inifnity . And check like this pic. look at the Midi channel (on the left)!When ready, close the application, EJECT the usb with windows (don’t remove it). Power OFF the looper, remove the USB from the looper and PC.Reboot your looper. Go to Beatbuddy now, In the settings of the BB go to MAIN PEDAL>MIDI SETTINGS>MIDI OUT> Output Type= OUT> Channel (the same as the looper)> SYNC =Always ON> STOP=Pause & End> NOTES=Enable>Time signature=Enable. Now you have 2 way to stop the looper with Beatbuddy If you want to stop the looper when the BB is PAused or let the looper play when Beatbuddy is Paused, depend what you like to choose this go to BB settings>MUTE PAUSE >ENABLE= looper stay playing when BB is paused. DISABLE= Looper stop when BB is paused. AND don’t forget to put the midi cable into the OUT of the BB midi cable