Midi Maestro: Custom Mode doesn't work HELP!

Have set up custom mode using the BB default as a basis and moved the buttons to where I want them with varyingly different outcomes. None that I desire. Am I doing something wrong? For example, Start sometimes works but Stop never does, though does stop if I press Part 1. Scrolling delays and sometimes doesn’t work at all. Frustrated!

Hey there,

Yes this is a known bug, it should be fixed very soon, the developer is hopeful to get this fixed ASAP.

Stay tuned!

Thanks for the feedback. Will wait patiently, as waiting seems one of the few things we can do at the moment.

Just to update. Having some success editing the moved buttons. Still working on it.

As a new MM user I had to purchase a used Android phone to edit my MM since the iPhone app doesn’t work much at this point. It took days for me to discover it was the app and not my fault. (thanks forum)
I successfully created a custom mode with three pages that use "start, transitions, pause/unpause, tap tempo, tempo up and down +1 -1, outro and folders with scroll up and down. However, I have yet to find a way to stop the MM without it playing an outro.
At first I wanted to copy the factory BB template into the custom mode. It seems like others say it’s possible but when I create a custom mode it’s blank to begin with so I just made my own. I would love to take the factory BB mode and just edit it but so far no one has told me how that can happen.

I’m with you on this, but at a different place. Struggling to make custom settings work. Probably because I need a course on MIDI commands.

Stop command on MM is channel 1, command 39, and value 0. Haven’t been able to make it start so far, do that on the looper right now!

Our manual is very informative! You’ll find a lot of info on MIDI there.

This can be set on the BB, go to Main Pedal > Outro and disable the outro so outro fill is not played when stopping

I use Outro. I have it set on another button but there are times when I want to end the song with an abuptly. I don’t want to disable Outro. I just want a command that stops play when I send it. There are times when I might want to stop it on beat one or four etc.

Terry, what commands do you need and which one aren’t working. Are you using an Android or iPhone?

Android. And, like you, I’d like the option of plain stop or outro. Have tried transposing the default BB taps to other buttons on a custom mode with varied success.

I will be returning to the manual to dig deeper into the, what’s probably easy for many, MIDI quagmire. My logic seems to escape me as I get older. :frowning:

I tried this Stop command you mentioned 1 - 39 - 0 and it was unresponsive. However, my STOP command is set to redirect from page 2 to page 1 where the start page is located. I’m wondering if the redirect is causing it to miss the command. When I use Outro or any of the other Stop Command (found on the “browse commands” list) they’re using cc115 - value 1 or cc115 -value 0. I have not found cc 39 on the list they provide anywhere?
I’ve written to support a few times asking for this command and as of today no one has been able to help me with a working command.
I thought another way to “trick” it to stop would be to send a program change to have it look for a new drum pattern. When you switch drum songs to a different one than that which is playing it stops dead. We use Forscore for music charts and program it to send the proper drum folder/song etc. for each song so I don’t have to bend down. If my wife pages from one song to the next (resulting in sending a new drum song in the middle of us playing a song that isn’t finished) the result is the BB stops dead waiting for the start command to begin again.
The Android app doesn’t specifically show LSB MSB commands so even when I select “program change” from the drop down it doesn’t change the entry page from CC + value so I’m not certain how to send the LSB MSB and value. On my Forscore App it’s easy because it shows exactly that formula of LSB MSB + value.

Your plan to Stop the Beatbuddy by changing song should work. To get this to happen you will need 3 MM commands
Control Change 0 value = 0 (MSB)
Control Change 32 value = folder number -1
PC change = song number -1
You could set all values to 0 and it will select the first song in the library.

You then assign all 3 of them to a button.
The reason it is done this way is so you can name the commands in a meaningful way ie CC#32 Value 18 could be named Rock

Or you could use CC#119 Value 0, this is the scroll up function, which also stops the track immediately.

Thanks I believe this should work. I’ll give it a try

As far as the BB is concerned I’ve sussed the correct method for doing what I want, so thanks for the help (proving I’m pretty stupid at times:-) ).

I’ve set my Pigtronix Infinity to channel 3, but CC 3/24/0 or 3/24/1 or3/24/127 doesn’t start a loop.

Using the “next part” commands I’m not having success. Does it require two commands each?
Screen Shot 2021-01-11 at 3.11.55 PM
CC-113 command 2 does not start a transition and jump to the part 2 on exit for me nor do any of the commands 1-5 work as expected.
On the factory Beat Buddy they have a page set up to jump to any one part in a song you want which is what I’m trying to duplicate.

Thank you for the 119-0 scroll up side to STOP the song dead. That worked.

Try the settings in the following link

This worked for me today. I set up new commands rather than use the ‘bold’ font defaults. The examplre is part 5 but substitute the others numbers and it worked for me
Doesn’t matter what you call the commands. Whatever makes sense to you.

1 Like

You didn’t mention it but it’s a learning curve. I set the “End Transition” command for the button release.
It doesn’t work unless you do that (for me)


I’d like to be able to edit or delete default (bold) commands (when you set up a custom mode based on BB, and I guess Aeros). Even when the bugs are fixed and these commands actually work it would be good to be able change the names.