MIDI sync and pause function - BB w/ Infinity

#1

Hi, I’m using the Beat Buddy with an Infinity Looper. Beat Buddy is the master, Infinity is the slave.

If I never touch the pause function, things work great. The sync is perfect.

However, if I pause, when I restart, the Infinity waits a full measure before playing again. For some reason, I feel like this was not the case the first few times I tried this function. However, I could be wrong, and I have not been able to get the “correct” (or what I think should be the correct) behavior again (if I ever did).

Also, sometimes—and it’s totally irregular—there will be drift in the MIDI sync, and the Infinity will have lost its sync, starting not just a full measure late but a full measure and then some, and seems to be a little bit longer. Again, zero issues if I don’t touch the pause button—sync is perfect. But when I pause, the loop always starts a measure late, sometimes properly synced, other times not properly synced.

I’ll post a clip if I get a chance.

#2

First, please read this - http://mybeatbuddy.com/forum/viewtopic.php?f=11&t=238#p874.

Second, please take a look at this - http://mybeatbuddy.com/forum/viewtopic.php?f=18&t=582#p2095

#3

I skimmed both—I’m not sure those are the issues, I’ve played with the active pause/mute, but I will explore it on both counts. Thanks.

#4

Use any song that is not on the list of MIDI-bugged (like Metal 8) to make sure everything sync’s normally. If that’s not the case, I’d suspect Infinity (though I doubt such a costly product will fail miserably at such simple tasks). Most likely there are some settings in it to control the behavior you are describing. As I’ve already said, BeatBuddy offers only one such setting - Mute (Active) Pause.

#5

Well, like I said—if I don’t use pause/unpause, I haven’t had an issue and the sync is perfect. I’m not 100% sure that the syncing issues have only happened on this list of problematic songs, but I will definitely explore that when I get the chance (hopefully today).

As for full measure of drums I get after the unpause, I don’t think changing the settings solves that to my recollection. I think that is an issue of how the MIDI signal is getting sent and/or interpreted, so I don’t know if that is a BB or Infinity issue. Again, I will test today.

#6

Yeah, please test that, as I am really curious as to how it can be a BB issue though - my Boomerang III syncs very tight with my BB! Almost as if they were a single device.

#7

After some limited testing last night, it does appear that the “drifting” only happens when using one of the BB songs with known faulty intros (this hypothesis held on five or six songs, 50/50 mix of good/bad songs).

However, I still cannot get the Infinity to restart at the same time as the Beat Buddy—it always wants to wait a full measure. I played around with the mute pause function on the Beat Buddy, and that’s cool too, but the idea I have in my head is different than both options:

Mute pause:
Beat Buddy stops playing, loop continues playing, Beat Buddy tracks the beat and restarts “in time” with wherever the beat still is.

MIDI-enabled:
Beat Buddy and loop stop playing, on restart the Beat Buddy plays a full measure, then the Infinity loop comes in (synced properly on the good songs and improperly on the songs with intro issues)

What I want:
For the loop to restart with the Beat Buddy without that extra measure

Still not sure if this is a BB or Infinity issue. When you say your Boomerang works great, have you tested this specific scenario?

#8

The last thing I heard there were some technical difficulties implementing MIDI-enabled mode.

I’ve tested my Boomerang III kicks in without any pauses when Mute Pause is off.

#9

If the Boomerang III works fine, then it must be an Infinity issue. We’re sending a unit to Pigtronix so they can look into this.

#10

I have two questions:

(1) What is the Beat Buddy TRYING to do? Or put another way, when is it sending the “start” signal? Is it trying to send it immediately when it starts playing? (I’m guessing this is a yes from the responses, I just want to make sure I understand.) And is it different or the same on song intros (let the intro play a full measure) vs. restarting a paused signal (start immediately)?

If it’s TRYING to send the signal immediately (in either the intro case or restart case), then I’m wondering if it’s a matter of the Infinity interpreting it incorrectly somehow or if the issue is that there is some source lag, which is why the Infinity then feels compelled to wait the rest of the measure to start.

(2) I’m just curious on this one, I thought you guys had tested with an Infinity Looper—IIRC there was even talk of a demo video at some point. If so, no one ran across this problem? I’m the only person I know with both, but I’m still surprised it hasn’t popped up elsewhere.

#11

BeatBuddy is constantly sending MIDI quarter notes. As of current firmware, BeatBuddy sends MIDI Start as soon as it starts playing (e.g. when intro starts), but this behavior is about to change in the next firmware update.
When unpausing with Mute pause disabled, MIDI Start is sent immediately as well - just the same as when the song starts.

From what you describe, I’m starting to guess the problem you can be having there - you start BeatBuddy (MIDI Start command was sent, probably causing your Infinity to start recording), you wait for an intro to end to start playing (this usually takes 1 full bar), you record a loop (but it was already started recording a bar ago), you stop recording. When unpausing, BeatBuddy sends MIDI Start, that causes your Infinity to playback. It plays a bar of silence, then your loop.

Is it possible that I am correct here?

#12

No, that’s not what’s happening. I was concerned by the responses that my issue isn’t being quite understood. I’m quite confident of when my Infinity is and isn’t recording. The Infinity’s recording is not influenced by the BB start/stop commands.

The Infinity knows when the beginning of a measure is from the Beat Buddy. When I’m not playing or recording with the Infinity, the “armed” looped blinks at the beginning of each measure. When I hit “record” (on the Infinity) it will blink fast to let me know it’s about to record, but won’t do so until the beginning of the next measure. It’s the same thing when I stop—I hit the button (on the Infinity) in the middle of a measure to stop recording, but the loop won’t actually close until the end of the measure. When the loop repeats, there is no blank space.

It’s not the best example, but you might want to check this out:
http://www.talkbass.com/threads/pitchshifting-a-blind-shootout-for-your-perusal.1107262/

I used the BB and my Infinity for this test. I didn’t do anything fancy with the Beat Buddy. I recorded a loop on the Infinity, synced with the Beat Buddy, and then replayed it a bunch of times. If I load this loop on the Infinity and hit “play” with no Beat Buddy connected, the bass plays immediately. But notice what happens in the samples. ALL I do is hit “start” on the Beat Buddy. The whole intro plays before the Infinity loop starts, on its own, in response to the Beat Buddy. I didn’t tell it to do this, I assumed it was the natural functioning of the Beat Buddy. And frankly, I like that—for intros. BUT it does the same thing (which I don’t have a recorded example of) for the pause/unpause function. When I unpause the Beat Buddy, I get a full measure of Beat Buddy before the Infinity starts. It’s not because of blank space on the Infinity loop—I’m 100% sure of that.

Actually, I know you guys sort of ruled out the possibility that the Beat Buddy is at fault here, but I’m thinking about how it gets unsynced on the Beat Buddy songs where the intros are the wrong length. Well, my Infinity will get unsynced on these songs even using the pause/unpause when the Beat Buddy doesn’t play an intro—that indicates to me that the Beat Buddy is not sending the “start” command to the Infinity until “one intro length” after the Beat Buddy starts playing. What do you think?

#13

A wall of text. :slight_smile:
I feel this Infinity looper is so smart, it outsmarts itself…

Boomerang III is much more simple and much more reliable at the same time. It’s like an iron hammer that pretty much does what it is for. Infinity looper seems to me to be some sort of a hammer with integrated finger protection (so you won’t hurt yourself if you miss a nail), but now you start realizing it isn’t that convenient to actually hammer nails…

If I were you, I would search for some hidden and obscured setting somewhere in Infinity looper. I’ve already said all I knew about how MIDI sync most likely works (considering my own Boomerang III behavior). But I may be wrong, and I do not own Infinity.

#14

Well, this is why I’d really like 100% explicit confirmation of when the Beat Buddy is sending that signal and what it is TRYING to do. If I’m clear that Beat Buddy is sending the signal to restart right away, then maybe I can delve into the Infinity settings to explore this. But the Beat Buddy is doing something unconventional I’m not sure how much that is going to help.

#15

Here, these videos should help clearly demonstrate. They are kind of a two-part series, it’s best to watch them in this order.

With Rock 7 (no intro length issue):
https://www.youtube.com/watch?v=-jKHXgxYwA4

With Rock 1 (intro length issue):
https://www.youtube.com/watch?v=NRAeEWFBNkg

#16

This is very strange. I saw your first video, and I’m more than sure it’s the Infinity thing. It counts and aligns tracks to every fourth MIDI quarter note. Some BeatBuddy songs are 4/4 but contain 3/4 intro (like Pop 7 anticipated, that I really love). Try it and see your Infinity definitely fail to grasp the rhythm with its super-intelligent behavior :slight_smile:

But I am curious at what does that bright red light mean that turns on next to the left-most switch of Infinity when you pause (or stop) BeatBuddy? It is off before the loop is recorded. Probably that’s the indication of some mode?

My Boomerang III does exactly what you say in the end (you need not to time your press), but it aligns strictly to quarter notes. It kicks in immediately BEFORE the intro start (that’s when MIDI Start is sent), and it has no such issue with un-pause.

It was explicitly announced by David, that current firmware sends MIDI Start before the intro, and doesn’t send anything after. In the next firmware update this is about to be changed to an option to choose between old behavior we have now and send nothing before intro, send MIDI Start after the intro. Looks like after an update, your Infinity will wait for 1 full bar after unpause and 2 (!) full bars after song start then :slight_smile:

#17

Here’s a bunch of stuff from the Pigtronix Infinity manual that I finally dug up:

6.1 MIDI Sync
MIDI Sync is the normal default MIDI mode of the Infinity it’s always on.

When a MIDI Beat Clock is present, the Infinity Looper will synchronize its actions to the MIDI beat clock, acting as a slave device.

Once a loop has been recorded with a MIDI Beat Clock, the Infinity will constantly readjust the loop length to stay synchronized. This active MIDI synchronization prevents drift, and guarantees that all synchronized actions happen on time at the start of MIDI measures.

This active MIDI synchronization is designed to work with regular MIDI clock signals that don’t change tempo or time signature. If the MIDI clock signal does change tempo, the Infinity will react and adjust the sample rate gradually.

The MIDI actions of the Infinity are quantized to the measure when MIDI is running, by default in 4/4 time. Any action that is meant to obey MIDI clock will be applied at the beginning of the next measure (not necessarily the end of the loop cycle). So it’s best to cue the MIDI command within the bar/measure before you want it to occur, not right on the downbeat.

If a MIDI clock signal is present during recording and then stopped or disconnected, the Infinity will continue playback using its recorded length. Actions will continue to be quantized to an internal, approximate MIDI clock. However, this internal MIDI clock may drift or differ from the external MIDI clock that was disabled.

6.3 Commands That Sync to MIDI Clock
Start
Starts loop audio at the start of the next measure after the switch has been pressed. Switching between loops in Series mode will trigger which loop is playing back at the start of the next measure after the switch has been pressed.

So I’m now seeing how maybe that “waiting until the beginning of the next measure” means 1 full measure if the command is sent right at the beginning of a measure. If so, I guess there’s no workaround on the Beat Buddy side, and we would need Pigtronix to have an option to override with the command (start as soon as the command is received).

#18

I also use Infinity slaved to BB with a Midi Solutions midi thru device to split the midi clock to other devices. For live use want to use BB to control everything’s clock. Can BBManager or the firmware be modded to que clock change prior to each pattern change? If it doesn’t change from one to next no effect, otherwise the controlled device gets the heads up. Assuming the next patterns are being read and buffered prior to pedal push for a firmware solution.

#19

I am not sure I can understand how you want BeatBuddy to behave in this case.
What tempo change being queued are you talking about?

#20

I was looking at the comment above from the Infinity manual,

“The MIDI actions of the Infinity are quantized to the measure when MIDI is running, by default in 4/4 time. Any action that is meant to obey MIDI clock will be applied at the beginning of the next measure (not necessarily the end of the loop cycle). So it’s best to cue the MIDI command within the bar/measure before you want it to occur, not right on the downbeat.”

It seems that the tempo info 3/4 and others sent during a song from BB as master to control the Infinity is coming too late for the infinity to set the length of the record measure. For non-looping devices like keyboards etc. set to obey the midi clock from BB if tempo change were to occur at close to the end of the running BB pattern it wouldn’t matter to them.

There are a couple of topics in this thread. The start/stop on Infinity works if it is set to obey midi start/stop. For a single pedal all stop setup there is a problem because it also obeys the start and starts recording immediately. I thought about using a midi router to filter the start if needed but that’s another $150 and it would be nice if BB was more midi configurable sent only midi clock and the stop event as an option to save more one trick gear. Actually the BB needs much more midi enabling as I think it would be a killer pedal to replace Ableton/APC style loop control without needing a computer and four arms. Limiting it’s midi to start/top and tempo is not going to win fans of it as midi master.