Mute issue while switching between parts

Hi guys,

it’s been a while since I checked this forum as my request from Dec 2019 was solved fine for me with „double tapping“ for mute on the next measure. (implementing RPM would still be great though)
https://forum.singularsound.com/t/aeros-mute-with-only-one-click/16388

But now probably since one of the last firmware updates an issue with mute occured:

Recording/Playing part one → mute works fine.

Rocording/Playing part two → mute works fine

but while switching between boths parts (directly) → mute only works on second attempt.

I checked this for a while now: it has nothing to do with the speed of „double tapping“.

I already own two AEROS units and I checked them both. Same issue.

First one: firmware 3.4.2, second one: firmware 3.5.1

Can you please check as soon as possible?

Thanks
Alex

1 Like

Hi there,

I’m not sure if I was clear enough. Maybe this helps.
https://drive.google.com/file/d/1pR24rTI-RcrAZOv_dRSIhZ9BqIiFr9nZ/view?usp=sharing

I wonder no one had realized this yet. I can hardly imagine both of my units have the same hardware problem.

@lash: any experience with this?

Ok… woke up got your notification, Coffee first…

Alright after trying this, at first I couldn’t duplicate then I realized I should get my settings as close to yours as possible… I did exactly as you the best I could with the info in the video. 2x2, 4/4 (count in at 90bpm) without my usual locked first track, and did exactly like you did except I used my roland handsonic instead of guitar.

Absolutely can confirm. laydown track one in part one, mute works laydown track one in part 2 mute works, switch back to part one and mute only works on the second attempt.

I don’t have time to keep experimenting this morning but, is it possible that after switching back to part one the loop needs to play One full time before mute can work?

I don’t know, but I can duplicate your mute situation. (uhg… so many little frustrations, this seems like a small deal but on stage you need immediate access to a mute function when using multiple tracks.) Hopefully @BrennanSingularSound will see this.

3 Likes

Hi lash,

thanks for checking and reproducing this!

Actually I did not try it in 6x6 mode yet but in 2x2, 4/4 and 6/8 and different bpm. Seems it has nothing to do with settings. I just found out it also happens in the freeform mode.
https://drive.google.com/file/d/1oRxVicc7zrARrQciuUfduNLLkqOF_trW/view?usp=sharing

The loop does not have to be played completely. It always works on the secod attempt if switching between parts.

Absolutely agree with the „stage situation“. I found a video from Aug 2020 where you can see me kind of stumbling around before finally getting the double tap in the very last second at 2:27. :sweat_smile: (still hope for the RPM function)
https://drive.google.com/file/d/1nMV8lQbFMiAV8qogJ4MAz3_jrKFgIdKB/view?usp=sharing

But that also means that mute had been working properly at that time.

I’m using here two parts for verse and chorus. After the short licks which I play over the first part I have to mute it for the 3rd verse.

Anyway hope SingularSound will take this up soon.

Yeah I think I got used to having my first track locked in 6x6 mode lately and … well the coffee was kicking in.

Yup the bug is across all play forms. I’m with ya, I hope someone @ SS takes notice. I can work around it for the time being because as of late I have been working with a locked track 1. This should be addressed.

Awesome little beachside show there. You guys sound great!

Thanks!

Hey there, yes this is a known issue that has been there for some time.

We are moving towards creating behavior that will solve for this error in the next 1-2 releases with an expanded logic:

If the user has not started a transition and sets up a mute/unmute that is set to enact and has not been completed (at the transition point or after the transition point) and then transitions, that track should mute/unmute within the part they transitioned from. If the user returns to this part, the track should still be muted/unmuted.

However, if the user starts a transition first and then sends a mute/unmute command, the incoming track of the part you’re transitioning to will be muted/unmuted at the start of the new part.

This should cover your case and add a little more possibility as well.

This is just going in to developers so we’ll see what they say about time needed to accomplish this.

For this reason I will tag #in-dev-timeline

Thanks!

Thank you.

My pleasure :slight_smile:

1 Like

Thanks a lot!
Please keep an eye on this as this mute bug really is a pain when you think about the stage situation.

By the way: Is the RPM (Record/Play/Mute) function somewhere on the schedule? David liked that idea.
https://forum.singularsound.com/t/aeros-mute-with-only-one-click/16388/12?u=bigal

It is not something we are currently working on but it is something I know we are interested in finding solutions for soon, it is best to keep topics focused so if you have further questions you should forward them to the dedicated RPM request

Thanks!