Pause/Unpause Sync issue with Boomerang

I’ve noticed something with my BeatBuddy and Boomerang III. I’ve started working on Like a Stone by Audioslave, and there’s a part where I pause using the ext pedal (pauses the loop and the beat). At the end of the part I unpause, which should start the beat and the chorus loop up again. only it’s off. It’s almost like the tempo sync is off by an 1/8 beat or something. I can’t get it to be “on time” without stopping the drum pedal.

I think maybe it’s because of the way the tempo sync signal gets sent. There are MIDI Out settings to for Sync:

  • Always On - (This always sends the tempo, which prevents me from using the looper when I’m NOT using the beat buddy because it’ll just be tempo syncing with whatever last song I played)
  • While Playing - (Transmits the tempo If the BB is playing a song (including when paused). This is what I normally have it set on, but sometimes exhibits the behavior above.
  • While Playing (Not Paused) - Does NOT tempo sync when paused. This made the issue worse/100% reproducible

Shouldn’t I be able to pause a song indefinitely with the extension pedal and then restart it? Is it getting confused when it’s getting a steady tempo and then I “disrupt” it by starting the track again and it doesn’t line up with a quarter note tempo signal? Has anyone else ran into this issue?

I have a Boomerang and BB also…this setup should work flawlessly. I believe there is a setting in the BB that sends a start/stop MIDI message (sorry thinking off the top of my head, I don’t have the BB in front of me). So what you’ll see is the sync in tempo between the 2 devices, however once you hit the external switch to resume the drums and loop they should both be on the “1” of the measure. There should be no issue with this.

Hi there, I believe the user above is correct, what version of the BeatBuddy are you currently using?

Let me know, thanks!

I am on normal BB (Not mini) with the latest firmware.

Check in the Midi In settings of the BB
The pause/Unpause must be enable
In the Midi OUT settings
The STOP must be on Pause & End

Can you confirm you are on version 4.0.1? I only confirm because some users are not aware it is out.

If so all you have to do is make sure the MIDI Start is being sent when restarting BB. I believe you may not be able to make this work if the BB is set to mute pause. The BeatBuddy should use a normal pause to send the Start command right as it unpauses and stay in sync.

Can you confirm you are not currently using mute pause?

Let me know thanks