"Program Device" is missing in 1.1.5

I just updated MM to 1.1.5. There is no Program Device command, so I can’t update my custom modes, and my prior custom mode is no longer on the MM (“CUSTOM MODE EMPTY - DOWNLOAD APP TO CUSTOMIZE” displayed on MM)

I updated firmware, then default modes. powered MM off/on. stopped and restarted the MM app.
NOT going to uninstall / reinstall the app unless you can promise me this won’t lose my custom mode programming (7 full screens)

I am dead in the water on MM custom mode programming/troubleshooting.


MM 1.1.5 menu|243x500

OK, I found the greyed out icon for programming the device, next to the name of my custom mode. So, no longer blocked.

Hey there,

I’m glad this is no longer an issue, still here is a very good step-by-step process for what to do when you see issues with uploading your custom modes, updating firmware or default modes.

To be perfectly clear, are you saying that the program to device button on the app is not working correctly? Does it still not work/ did it ever work?

I’ll double check this if that’s what you’re saying.

Let me know, thanks!

i am using the droid app, not ios.
the Program Device command is missing from the command list, see the screen shot i sent previously.
i stumbled into the download/program icon on the Custom Modes screen. hard to see, it appears greyed out. so that worked.
was this documented somewhere?

Oh, I see what you mean, yes we removed that, because the download to MIDI Maestro icon is meant to handle that command. We are very close to finishing the documentation, apologies for that.