Removing unused custom mode pages

Hi. This is a problem I found after creating several custom pages. The pages won’t blank. I want to remove 3 pages of unused commands and go back to just scrolling 7 pages. It’s bugged. Thank you.

Hi there, sorry for the late response, what version of the app are you using, and are you on iOS or Android?

Thank you!

Hi Brennan. I am using Android version 1.3.9. I can save anything except a blank page. I mean, I can blank a page in the app and upload it to the Midi maestro, but the Midi maestro continues to hold the page that I had blanked after the upload, including any commands. Is there some kind of trick I’m missing? I have 3 pages of Jim is cool!

This happens when you use a footswitch to change pages. The App doesn’t erase the unused pages.

To overcome this, create a new custom mode, call it “Blank All” choose the blank template. On each page 1-10 on the top left button name the top and bottom as " ". Upload this “Blank All” custom mode to MM, this should set all the pages to Blanks. You can now upload your intended custom mode and the unused pages will be blank.

Do not do as above, MM doesn’t like partially completed pages and it could affect the default modes. Although if they are, the default modes can be fixed by updating them. The best way is to start a new custom mode from scratch.

I am using midi maestro version v1.1.6. I can also confirm that the method of creating a blanker custom mode to overwrite and blank all my page’s does not work. It blanked page 1, kinda. If it had fully blanked the page…I would not have seen a blank page. It should simply have skipped page 1. I’ll continue to experiment with a blanking template. What I wouldn’t give to be able to reset this device to defaults. I would probably be able to get my expression pedal to work too.

The MM will display all pages, even if they are blank, it does not have the functionality (yet) to recognise a page is blank and to automatically skip to the next non blank page. Create a new custom mode from scratch, fill in the buttons you want and upload this to MM, rather than trying to erase a previous effort. It’s a pain, but it will give you less headaches.
I’ve not had much luck with the expression pedal, the functionality is still hit and miss with custom mode.
The App version is displayed at the bottom of the menu, in grey, currently mine is 1.4.2.

I can confirm that this also does not work. The very first thing I tried after cussing was to create a new custom mode. If there was previously text in the window, loading a whole new custom mode will not remove it. The Midi maestro appears to ignore blank pages when uploading.

I am running the latest version of the app (android v1.3.9) and the latest firmware (v1.1.6). My expression pedal does not work in any of the modes, not just custom, even though you can clearly see it manipulating variables in clutch mode.

I believe having a way to default the device could help with both problems.

Uploading a blank custom page will do not nothing, as you have confirmed. You must rebuild your custom mode, with no blank pages and start from page 1. It will take a while with your remaining 7 pages, but currently it’s the only way to do it. I find writing the custom mode out in a table helps me. See my templates for Katana Librarian and FiveLoop.

Good luck

I really appreciate all of your help SytRep. My problem here is that I only have 7 pages worth of commands that I have/need. I am controlling the aeros, the beat buddy, and my acoustic guitar. I also have a stereo guitar multi effects processor, but it is receiving no midi commands. I created this custom mode because I needed a much more streamlined way to control the Aeros and the beat buddy simultaneously as switching between default modes was an excruciatingly long process taking upwards of 20 clicks or more just to change songs. This would be much less necessary if the expression pedal worked as intended. Long story a tiny bit shorter, the custom mode I have created (multiple times) only has 7 pages of commands. When I upload it, it changes nothing on the 3 pages without commands.

You also said that you are using Android version 1.4.2. I’m not sure where to get that. I looked through the play store and it tells me I am running the latest version, with autoupdate enabled. The link on the midi maestro portion of the singularsound website takes you directly to version 1.3.9. Not too sure where to go from here.

Can you upload your custom mode, I’ll have a look at it and make some suggestions.

It has been uploaded from within the app. It is under browse custom modes called
Aeros-BB-Lag.