With the latest update the Aeros is really showing its potential – thank you for your work!

A couple of suggestions to further updates that would make it even better:

  • it’s a bit annoying that it wants to save everything all the time. When you used a lot of time to set up a great song with backing tracks – different parts and so on – it only takes one wrong click to mess it all up – especially when playing live it would be nice if it didn’t keep asking to save every new recording. Would be wonderful with an option to “lock” an entire song, so it only would be possible to loop on top of the basic tracks but NOT record on top of them. Would be so valuable live and then I wouldn’t have to keep backups pf everything in case I accidently pushes the wrong button in the middle of a song.

  • when looping on top of a backing track the volume of the loops follows the volume of the backing track which is annoying. Sometimes you have to lower the volume of a very loud backing track, but then the loops gets lowered too. So, if the backing track is at 60% volume, the loop you record afterwards is automatically also at 60% volume. It would make much more sense if the loop was at 100% from the start (yes I know you can just make the loop on another tracks, but for some songs it makes sense to loop on top of the backing track so that the loop follows into the next part of the song).

  • it don’t know if its possible to make the display work better in sunlight. Very difficult to read as it is now – and a problem when you have gigs outside in the summer.

  • maybe you could make a Song Dashboard “light” – I really don’t use any of the many things listed on the dashboard as it is now, but it would be so nice if it could just display the title of the song loaded in big letters before you start the song. And please allow capitol letters and make it possible to use Scandinavian special letters like Æ Ø Å

  • I keep mesing up with the “Song Template” – the idea is really good but maybe its just not described well enough in the manual or not working properly – it keeps changing my settings even after I saved them.

Thanks - hope this makes sense


1 Like

Hi Marcus,

Thank you for your suggestions. I have forwarded them to the development team for consideration.

Regarding your suggestions:

  1. You can undo a recording using the Aeros Loop Studio or the MIDI Maestro.

  2. Noted. You can use the mixer to change the volume of the tracks.

      • Issues 3 and 4 have been addressed in the latest firmware update, available in beta. You can find more information at this link.

If you need help with any of the suggestions (song template for example), please send us an email at, and we will assist you in setting them up.

Thank you for your input, and we will be working on improvements to enhance your experience with the Aeros Loop Studio.

Thank you for your quick response -and happy to be part of the Aeros community – been quite a journey.

A bit difficult to describe these quite technical things – sorry if anything is hard to understand.

  1. I know you can undo a recording, it’s not that I’m trying to describe – I’m using the Aeros to play drumbeats and trigger samples when playing live – all those things are set up and saved before the show and live I loop guitar parts on top of that. But every time I’ve finished a song and loads the next song, the Aeros wants to save my live guitar loop on top of the backing tracks and all it takes is one click to mess up the backing tracks by saving something on top of it (and playing live errors happen – I have to talk to the audience and the band while managing the looper!). It would be extremely cool if it was possible to tell the Aeros “this is a backing tracks song that ONLY wants to loop upon and NEVER wants to save upon”. That feature shouldn’t be to difficult to add (I think😊)

  2. I know you can use the mixer to change the volume, but what I’m describing is when you overdub on top of a backing tracs that’s been turned down, the overdub is automatically also turned down, and that makes no sense. When I have a drumbeat set to 70% volume and then overdubs a guitar on top of that (for some of my songs this is usefull) the guitar is automatically also turned down to 70% volume. When you record the guitar it’s a full volume in the mix, but as soon as you starts the playback its suddenly much lower, making it quite useless. It should make the overdub at 100% no matter how low the backing track is set – at least that’s how it works with other loopers I’ve used.

3 and 4) im already using the latest update and the looper is still extremely hard to use in sunlight. Like I wrote earlier im not sure if its even possible to make the display work better outside – but I hope you can do something with the contrast and the brightness. The “dashboard light” with just the title of the song would be nice when playing live to make sure its the right tracks loaded before starting it (again things happen when playing live and suddenly you can get confussed about what tracks you did load).


Thank you for your feedback and suggestions, Marcus. We have received your request and will notify you once it has been reviewed.