Syncing BB with DAW

I am still struggling trying to sync my BB drum beats to my DAW (Bandlab Cakewalk) when trying to record drums. I am aware that one needs to drive the other but which is the preferred way? Should the DAW midi clock drive the BB or the other way around?

Thanks

If you are trying to record midi from the BB into a DAW, BB should be the master. If you want midi from you DAW to trigger BB drum kits, the DAW should be the master.

I am sure I am missing something here. I have my DAW set to send a MIDI sync. On the BB under MIDI Settings I have it set to MIDI-IN / System Real Time / Sync. However, when I start my DAW the BB doesn’t start. I’ve also tried MIDI-IN / System Real Time / Sync on the BB and that doesn’t work either.

It would help to know exactly what you are trying to do, and what you expect the BB to do. Do you want the BB to play a pattern on the SD card, or do you want the BB to act as a drum module and play its drums to midi notes it receives? Do you have STart and Stop enabled? Is the BB set to receive notes on the channel the DAW is sending on? Do you notes enabled? Sync alone just gets the clocks lined up.

I was trying to record both the MIDI and Audio events of a drum part I created into the DAW. Not quite sure what I did however, I was finally able to record the audio triggered by the DAW so it would line up to the beats per minute. But was never able to record the MIDI events.

There is probably an easier way. I’ll get to that in a minute. From what I gather, you want to record the Audio and Midi from you rBB into a DAW. It would be easiest then to have the BB set as the Master, and your DAW as a slave. If the DAW is the master, it is sending clock info into the BB. Midi gets finicky with same piece sending and receiving midi. I assume it might work, but if the BB is the master, then it definitely should work. With the BB set as Master, you would configure the midi OUT setting of the BB to handle your project. Set it as MIDI Out, match the channels, set sync while playing. Set the start to intro or main beat ,depending upon what you want, and set the Stop on Pause Only, Enable notes. Enable Time Signature. Your BB Audio gets sent to an armed Audio track in your DAW and the midi gets sent to an armed midi track.

But, you’ve already created the midi somewhere. Why are you wanting to record it again? IF you have the midi that you put into the BB, just copy and paste that into your DAW. If you used Singular’s parts to create a song, and you don’t have the midi files, you can download them from the Downloads link on the BB’s Product Page (bottom of page, SPECS, FAQ BB vs Competitiion, DOWNLOADS).

https://singularsound.com/product/beatbuddy/?ar_clx=yes&ar_campaign=1623020281&ar_ad=309982776611&ar_adgroup=60479890983&ar_channel=google&gclid=Cj0KCQjw38-DBhDpARIsADJ3kjl4LSzPoOG9B_InrPRhwwke4SwDg3xRgIepSC5meoaNqROOWLq5aP4aAtiaEALw_wcB

You should be able to Export midi from BB Manager, but I understand some versions of BB Manager do this incorrectly. On a Mac, you can control click the song part, and get an option to export midi file. I assume there is a right click function in PC.

I have a ROLAND VS 2480 and it runs several “gizmos” as midiclock MASTER. I’ve connected it’s MIDI OUT to the BB IN and tried many different parameter settings within the BB but the BB will not START when I START the VS****, I know there is a midi signal from the VS because if I connect a keyboard/sequencer IN to the BB OUT, starting the VS also starts the Sequencer. (this of course is when I have the BB parameter set to MIDI THRU. I realize that most of the BB Forum is of the consensus the BB is best as Master. I would be thrilled if I could START the VS with the BB and hopefully, other “gizmos” with extra INs and THRUs… ummm… what do you think? esp. @Phil_Flood

If your Roland is configured to send MMC, the BB should start when you start the Roland, provided that BB Midi Sync is enabled and Midi Start and Stop are enabled.

If you want the BB to send the Start command, and you want the Roland to respond to it, but you want the Roland to control tempo, and you have other gear? I think that’s going to be problematic without an investment in several splitter boxes, and even then it seems incorrect. You are saying BB controls start, Ok, that means we have a midi out from the BB to the midi in of the Roland. But, Roland controls tempo, so we have a midi out of the Roland to the mid in of the BB. Then the Roland is also controlling other gear, That involves having a splitter From the Roland out to your other gear, with one line going to the BB, and another to the other gear. Even then, I would be concerned about the confusion of the control versus tempo settings, but it does seem like the settings are there. I have not tried to have the BB send Start and Stop when it is not the tempo controller. I just think that loop back is going to foul up the works. There is probably some simpler device that can just send the MMC commands to the Roland, and the the BB can be a slave to its tempo and pick up the MMC commands from it.

2 Likes

Thanks for the reply Phil… I’m sorry I confused you with my orig. post. My goal is to have the BB start and control the VS. All the the other things that the VS was doing is incidental and not part of my problem at the moment. I have the VS config’d as SLAVE with the SysEx Rx Sw turned ON. I’m not sure if the BB’s SysEx Tx is enabled. In any case, I am not able to start the VS with the BB and having said that, I have also REVERSED this process and cannot start the BB (as SLAVE) with the VS (as MASTER) either. How do I find the SysEx Sw on the BB? Thanks in advance, Johnny R

It’s just the pedal Mid in and out settings. That’s all we have.

There have been some additions to the midi settings, but they have not updated the manual. Is should not affect what you are trying to do.

And its possible that the two devices are jut not compatible.

Thanks Phil_… I appreciate the MIDI Settings link… and, you may be right, the BB just may be incompatible with the VS. Gilda Radner said it best…“It’s always something”.