Time signature of 1/1 (aka start and stop on beat boundary)

I’m integrating my Aeros with a Eurorack synth. In the case at issue, the Eurorack is providing percussion and other parts while I loop bass, guitar or electronic keyboards along with it in real time. My Eurorack is providing the MIDI clock to Aeros.

My problem is that Aeros has no idea of where the start of a measure is and there doesn’t seem to be a way for the Eurorack’s CV/Gate-to-MIDI module to tell it. In other words, Aeros doesn’t know where beat one is. (Or rather, it thinks it does, but it may or may not coincide with where beat one is in the Eurorack.)

Of course, I know where beat one is, and I can press the Aeros record button at the right time. If Aeros is set to unquantized recording, the minuscule errors I inevitable make in hitting the button on the beat, while not immediately noticeable, accumulate over time and slowly cause the Aeros to get more and more out of sync with the Eurorack clock.

If I use quantized mode, the shortest measure I can specify is 2 beats (using time signature 1/2). The problem with this is that, again, Aeros doesn’t know which beat is 1 and there is a 50/50 chance that it will start recording one beat late when I accurately tap the button on what is beat one in the Eurorack world.

It seems to me that, if I was able to specify a time signature of 1/1, that my problem would be solved, essentially allowing me to make Aeros treat any beat as the start of a measure and stay synchronized to the Eurorack.

I apologize for the long-winded description. It’s hard to explain this stuff without a lot of words.

— time passes —

Okay, I was confused about time signatures, and this turned out to be a little more involved than I thought anyway.

My goal was to be able to start a sequence on my Eurorack, record a loop or loops to go with it, and then make changes in the Eurorack world, rinse and repeat, all the while remaining in sync.

Problem: Getting Aeros and the Eurorack to agree on where the beats are in the 24 ppqn MIDI clock stream.

Solution: Send a MIDI START command from the Eurorack to the Aeros. The next MIDI clock message identifies the first beat in both worlds, and they will stay in sync thereafter. Note this works even if Aeros is set to not start recording or playback when it receives the MIDI START message.

So my work flow is as follows:

  1. Set Aeros to not record or play on MIDI START. Quantized. MIDI sync on.
  2. Start Eurorack MIDI clock.
  3. Send MIDI START on beat 1 of a measure. I do this manually, by tapping on a button in the Eurorack.
  4. Start immediate recording of the first track by tapping the Aeros record button on beat 1 of a measure.

Ideally, for the first track, I would like the Aeros to start recording on the closest MIDI-synced beat to when I tapped the record button (closer to what happens without MIDI sync). What it seems to do is start recording on the next 4-beat boundary, regardless of the time signature set for the song in Aeros.

I’ve made a crude timing chart showing what I have observed with a song in 3/4 time:

This seems like it might actually be a bug, unless I’m again misunderstanding something.

Uh, 1/2 is a one beat measure. One beat per measure, with a half note getting one beat. 1/4 is one beat per measure with a quarter note getting one beat.

Thanks for correcting me. As I have done more testing, I realized I was confused in more ways than just this. But I’ve made some progress and I’ll post a description soon.

1 Like

There’s a bug, pretty sure. Others have reported it and I’ve verified their results, and they’ve also said that the problem you are describing didn’t used to exist in a prior version.

It was also reported that recent updates added new handling for how sync works with an external clock when the Aeros is stopped and restarted, so perhaps they’re seeing a side effect of that work.

Here’s how I get this kind of quantize sync to work with an external clock:

  1. Change the MIDI START setting in Aeros to “Playback” only (don’t have record selected)
  2. Send both the MIDI START command and Clock from your Euro rack. You should immediately see Aeros begin scrolling through the bars, but it’s not doing anything more than that. It’s in Playback mode, but there’s nothing to play, so it’s really just keeping track of the count. And it that, it is accurate.
  3. When you are ready to Record, just hit the Record button on Aeros and it will quantize/sync correctly to the first beat of the next bar (if that’s what you want it to do).

Another thing with Aeros that can make it slightly hard to integrate with other MIDI sync methods is that it will react to a MIDI START by actually starting. You say, “Wait, shouldn’t it start when it receives a start command?” Actually, no. That goes against the MIDI spec. Devices should react to MIDI START by waiting until the next clock pulse they receive, then start with that. That’s how devices truly align to each other. If they all just try to start as quickly as possible, you find that each device has different processing speeds for reacting to a command. A clock pulse is the only marker they can all agree on, which is why the MIDI spec is that way. (admittedly, I haven’t test this behavior in Aeros lately, but it was this way before and I haven’t seen anything come from SS to say that there was a change to it)

Wow! Thanks for this! I think the playback-start-mode trick is exactly what I’m looking for.

I put the Eurorack clock and the Aeros click track on a scope and after sending a MIDI START it looked like they lined up exactly — and it sounded right. I can’t verify that the beats were aligned on the correct MIDI 24ppm clock pulse, but it’s definitely close enough for my purposes.

1 Like

Thank you very much for your post, although we did not immediately reply we were watching it closely.

This issue should be fixed without the workaround now!

The reason this started happening is the Aeros was updated to never lose count to avoid a bug reported to us that Aeros would not always reliably start back following the right count if stopped and restarted many times while BB remains playing back.

The bug reported here is caused by the lack of a logic for devices sending only clock and not Start commands.

The Aeros will now start immediately and be synced to the incoming MIDI clock if no MIDI start was sent. The Aeros refers to the incoming clock, it does not “follow” the clock, this allows it to be started immediately without any lag even when receiving clock.

We understand this breaks from the MIDI convention, we are going to experiment soon with changing both the BB and Aeros to follow the general MIDI Start spec behavior.

Thank you for reporting and your patience!

You can try this out in the new beta 4.2.4

Are you also going to update midi maestro to include the ability to program start and stop commands?