Updating MM firmware

I’ve spent some time looking for the answer but can’t find it. When I try to update MM firmware (I’m currently at 1.06) through the app it hangs up on ‘in progress’. I’ve validated Bluetooth is connected. Am I doing something wrong?

1 Like

Hey there, is it totally stuck on in progress? It does take some time.

Also, what version of the app are you using?

The app says cadence-12 at the bottom, is that the version? It was stuck on in progress for 30 minutes at the longest without the bar moving when I finally closed it

@BossRotten Are you still having issues with the Maestro being stuck in the updating process? If so, please email me at support@singularsound.com and we will get your unit replaced. Please link this page’s discussion in the email so I can see the context. Thanks.

Thanks! I sent an email

I’m having the same issue here, App V5 (android) and trying to update MM v1.1.4 to v1.1.5. App hangs on progress but bar never moves, now I just get the EEPROM INVALID message in the top 3 displays. At 6 hours and counting I’m out of patience and ideas, going to give up until I hear back from support…

Same here. My Maestro is stuck on “EEPROM INVALID”.

I got this reply yesterday from Casey at Singular Sound, I only have Wi-Fi at work so have to wait until tomorrow to try again. It seems to go wonky if the process gets interrupted during an update, but I could be mistaken on that point…

Here is how you’d get rid of the EEPROM INVALID message and return back to the normal display:

  1. Press the Bluetooth button until the blue LED blinks, then open the left hand side menu of the mobile app, and press “Update Default Mode”.

  2. If the screen does not “update” to normal after doing this, turn off the unit and on again, it should be normal.

My MM is stuck in eprom invalid mode and won’t reset no matter what I try. I am using the Ios app and tried reloading the default update with the app. It goes through the process bit the MM stays bricked! Any ideas?

  • The iOS app should be 1.09; if not update it
  • Power MM pedal off and keep the iOS app closed
  • Power MM on
  • Press the BT button on the back of the pedal until the light starts flashing
  • Launch the iOS app
  • Press the hamburger button (upper left corner)
  • Select Update Firmware
  • Allow it to complete the update; if the countdown displays 100%, the light may or not continue to flash continuously; if it is flashing, proceed to the Update Default Update
  • It should display a countdown; once done, the light will probably stay steady; allow it to remain that way for a minute or two and then power the pedal down
  • Let it sit for 30 seconds
  • Power it back up
  • If it displays normally, change the mode to see if the firmware updated to 1.15

Ok problem resolved downloading the update using the app… thanks persist!

2 Likes

Hi. Kinda new here. My MM just arrived and based on some posts here the firmware update seems to be problematic at least for now. Is it all right to use the MM straight away without updating the firmware? Am I going to lose a lot without the update? Thanks.

Hi there,

You should not get that impression, as long as you follow the steps your update should work fine, please refer to the posts above made by Persist. If you follow all those steps and you still are having problems, feel free to come back here for assistance. As far as if you don’t need to update, that really depends what version you’re on, what version does your MM read?

Hi Brennan,

I just did the update to 1.15 because I noticed that the Scroll up, Scroll down, and the Enter/Exit Folder switches were not working. After the update, they’re still not working. Is there something I need to set on the Beat Buddy for these to work? I have a footswitch connected to the Beat Buddy as well that functions as Song Back/Pause (left switch) and Song Advance/Accent Hit (right switch). I thought maybe this confuses the BB, but the MM switches are still not functioning even when the footswitch is disconnected.

Thanks for the help.

Edwin

Hi Brennan,

Actually never mind. I figured it out. I upgraded the BB firmware to 3.8. That resolved the issue. Thanks.

Edwin

1 Like

Awesome, yeah usually updating all the units is a good idea, it will make sure everything works correctly. Glad you’re back to making music!

Hi. This is not working for me. I downloaded the iOS app today, but I can’t see where it says what app version number I have.

I power MM down, close iOS app, power MM on, get the BT light flashing, lacuna the iOS app, press hamburger button, select Update Firmware, and then it just takes me back to the “My First Configuration” start page.

One of the posters above says his app says “cadence-12” at the bottom. Mine does not say anything like that.

I’ve tried a few times now.

Any hints?

“Cadence-12” is the naming convention for the Android app. The iOS app does not presently follow.

  • Delete the MM iOS app from your device
  • Open the App Store and Install the app again
  • Launch the app, and
  • Try updating the firmware again; set the phone or iPad down next to your MM and leave the app in the foreground (in other words, don’t check your e-mail or other processes on your device) as this will booger up the update process (you may get an alert stating that the MIDI Maestro needs to use connect with Bluetooth and if so, approve it)
  • If you see the countdown (percentage) timer, it means the firmware is updating the MM pedal
  • If you get a “Finished” display on your screen, move on to the next step (Update Default Modes)
  • You should see the countdown timer again but you may not see the “Finished” alert and the blue light may still be lit (not blinking); allow it a few extra minutes after the 100% completion to process in the background
  • Power the MM off; wait 60-90 seconds
  • Power the MM back up
  • Press the mode button on the back of the pedal and in the bottom left pane of the MM, you should see 1.1.5 or greater displayed

If this still doesn’t work, please contact Support, support@singularsound.com for help

I did not know that TestFlight was involved. I downloaded the Singular Sound Midi Maestro app from the iOS store.

I have now deleted that app, and I have downloaded TestFlight. How do I get the MM TestFlight app?

Thanks,
Brian