Weird issue with an original song

Today, in BBM, I moved one of my songs to a new set list only to find an error popped up on saving. But. and however, everything else seemed okay. On rehearsing though the song refused to play. Back in BBM I realised it was the intro that was the problem. I found the original mid file I’d used from the POP file and it worked fine but when I changed the name to the intro of my song title and re-imported it it gave me the problem again. Ah, I thought, I’ll create a completely new song. Nope, same thing happened.

I’m guessing that the Inception-like file saving of BBM means it has some link to an instrument, or something, that isn’t where it expected it to be, deep in it’s unconscious. I’ve never had this problem before though and I rename, edit, export and recall parts all the time.

Left the POP intro as it is for now, but it’s irritating. Anyone else had this issue?

Do you have a period “.” in a title? Or any other special character?

No. It’s a song I’ve been playing for years. Moving it doesn’t usually cause this issue

Can you export it? If so, try to reimport after export, or post it here and I’ll take a look.

It might be helpful to know what the error message says. Perhaps you can take and upload a screenshot of the message.

Doesn’t seem to be creating an error message anymore though problem still exists with the original file. When the song is played in BBM it misses the intro and goes straight into the main part, on BB it doesn’t start and doesn’t display “stopped”, ie the central section is completely blank. Yet when the file has the original POP mid, without the name change, it’s fine.
This_Is_Love(1).sng (743.6 KB) which uses a custom drumkit.

Thanks for sharing the file. The reason it misses the intro is because there are no notes for it to play. I did a quick check in the BeatBuddy Manager (BBM) MIDI Editor and although there is one drum note present for each drum instrument and bass note, the BBM does not see them (represented by the “Notes Visible: 0”) in the enclosed screen shot. I exported the file to MIDI and opened it in my DAW and it sees only the C-2 note.

Somehow, your intro MIDI file has become corrupt. Are you using the USB to connect your pedal to your computer’s BBM? If so, use the computer SD slot reader or an external USB SD slot reader.

Fix that issue in the intro and your song should work again as expected. As to why this happened, I have no idea. I’m sure Phil_Flood can provide better resolution as to what might be happening in your intro. If you have the original MIDI file for the intro, you might want to zip and provide that so Phil can diagnose (he’s much better than I am with that).

The intro to the above song is actually POP-Fill 29-full kit exported, name changed and then re-entered with the new name. BBM has never done anything like this in any other song and continues to do this every time I try, even when I create from new. Leaving the name unchained is the solution I use at the moment but I’m curious as to why this has happened. If I try to edit the naughty file BBM crashes.

Edited another intro beat to POP-Fill 29-full kit, renamed it to what I wanted and it now works. (I’ve had a similar problem with a ZZ Top mid).

The detail you provided helps. Here’s my assessment of what’s causing your issue:

  • Using the BeatBuddy Manager (BBM) to Export to MIDI has been reported by several users as causing problems. The export process corrupts the file exported to MIDI. This is a known and reported bug.
  • Other users report having problems with some of the MIDI files in the default content but in this case, I don’t think it’s the cause of your problem.

I tested and can replicate your issue. I used a fresh copy of POP- Fill 29- full kit.

  • Using the MIDI Editor to examine the fresh copy, it shows 4 drum instruments.
  • Exporting to MIDI and examining the exported file in my DAW shows that there are now 10 instruments and that at least two of the instruments have notes that are outside where the MIDI file should start. This validates that the export to MIDI corrupted the file.

There is a workaround:

  • Don’t use the BBM to export to MIDI as it’s a hit-and-miss process
  • Instead, use the MIDI loops - content 1.2 provided by Singular Sound and avoid using the BBM MIDI Editor to edit the file; use a DAW.
  • In this particular scenario, the POP- Fill 29- full kit file that you want to use is in the POP/POP Song 6- straight 8’s folder.
  • I don’t know if the premium songs (ZZ Top songs) use any of the MIDI files from the MIDI loops - content 1.2 so YMMV.

Where to find that?

I use Reaper for recording but have yet to delve into MIDI manipulation. I like BBM because of it’s simple nature.

Link doesn’t work for me.

It’s a direct download link. Check your Downloads folder. It should be there.

I get “This site can’t be reached”. Nothing in Downloads.

Go to the bottom of this web page to Downloads where you can click on the MIDI Loops.

Same error message.

Couple of other errors on other links there too.

Working fine here. You might check that your firewall isn’t blocking it; maybe try another browser….

A task for tomorrow, but doesn’t work from my phone either.

Web admin has been notified.

Thanks for your input, persist. I use Reaper for recording, so I’m guessing that’s a decent DAW to edit midi with. Now I’d like to input my “instruments” (VST?) so I can actually hear what I’m editing. Most of my customised drumsets don’t necessarily conform to midi numbering. If using BBM drumsets with Reaper is possible how do I do it?