Why does my aeros record the drums from the BB?

Hi there
When I’m recording a loop the aeros is also recording the drums from the beatbuddy, but I only want it to record my guitar, is there a way to solve this ? I’m using the bb as the master connected by midi


You have to think of the midi chain and your audio chain as separate processes. The midi chain is syncing your Aeros to your BB. Your BB is the master. Therefore, you midi connection should go from the BB out to the Aeros midi in.

Your Audio chain is recording what you want to loop. You obviously want to hear your BB, but not record it. In an ideal situation, you would run your BB out directly into your PA board. You don’t need to connect your guitar to the BB. Your Aeros would go to a separate PA board input. Guitar to effects, if any, to Aeros to board.

Now, if you have no PA and you are connecting right to your amp, you will want to run a clean channel so the BB sounds good. In that case, the audio signal will go Guitar to effects to Aeros to BB to amp. This way, you are loop just your guitar, but you will hear the BB.

Ahh, so connect the beat buddy AFTER the aeros ! Thanks Phil !

@Phil_Flood is exactly right.

Another alternative is to put the beatbuddy into the aux in of the Aeros (but set the Aeros to not record from aux in). If I have to run one into the other, I prefer this route because the aux in of the Aeros seems to have more headroom than the beatbuddy, in my experience.

@JaredSmythe, thanks for the tip, I’ll give that a go, just to ask (I’m very new to the aeros and beatbuddy ) how do you set the aeros to not record the aux ? Thanks buddy !

@Wingnuts1979 In the settings menu (accessible from the main screen), you should be able to configure those settings. Make sure that you have the latest firmware: Aeros firmware 2.15.x